Loading ...
Sorry, an error occurred while loading the content.

RE: Undefined MX record for a sender domain

Expand Messages
  • Scappatura Rocco
    Thank you Mark, ... It s ok for the case above, but in a case like the following: ;; QUESTION SECTION: ;cubemaxltd.com. IN MX
    Message 1 of 9 , Feb 29, 2012
    • 0 Attachment
      Thank you Mark,

      > On 16/02/2012 16:07, Scappatura Rocco wrote:
      >
      > >>
      > >> What do your logs say when your server tries to deliver the DSN?
      > >
      > > status=deferred (connect to domain.tld[xxx.yyy.uuu.vvv]:25: Connection
      > timed out)
      >
      > Which proves that the problem is not lack of DNS, since your server is
      > finding an IP address to deliver to.
      >
      > Your customer has probably got some kind of misconfiguration, but that
      > isn't really your problem.
      >

      It's ok for the case above, but in a case like the following:

      ;; QUESTION SECTION:
      ;cubemaxltd.com. IN MX

      <no answer>

      and

      ;; QUESTION SECTION:
      ;cubemaxltd.com. IN A

      <no answer>

      Where:

      Feb 27 04:05:19 av10 postfix/smtpd[23776]: 9B82034051: client=cubemaxltd.cubemaxltd.com[174.142.214.20], sasl_method=login, sasl_username=catia_rimondi_vantigroup_it
      Feb 27 04:05:20 av10 postfix/cleanup[23801]: 9B82034051: message-id=<00b801ccf4fc$95427c00$01000a0a@...>
      Feb 27 04:05:20 av10 postfix/qmgr[13455]: 9B82034051: from=<steve@...>, size=772, nrcpt=1 (queue active)
      Feb 27 04:05:20 av10 postfix/smtp[23811]: 9B82034051: to=<yogesh@...>, relay=127.0.0.1[127.0.0.1]:10024, delay=1, delays=0.61/0/0/0.44, dsn=2.0.0, status=sent (250 2.0.0 Ok, id=22526-10, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 6D35334052)
      Feb 27 04:05:20 av10 postfix/qmgr[13455]: 9B82034051: removed
      .
      .
      .
      Feb 27 04:05:20 av10 postfix/cleanup[23557]: 6D35334052: message-id=<00b801ccf4fc$95427c00$01000a0a@...>
      Feb 27 04:05:20 av10 postfix/qmgr[13455]: 6D35334052: from=<steve@...>, size=1218, nrcpt=1 (queue active)
      Feb 27 04:05:20 av10 amavis[22526]: (22526-10) Passed CLEAN, [174.142.214.20] [174.142.214.20] <steve@...> -> <yogesh@...>, Message-ID: <00b801ccf4fc$95427c00$01000a0a@...>, mail_id: t-ukdRvE+xFZ, Hits: 3.139, size: 772, queued_as: 6D35334052, 419 ms
      .
      .
      .
      Feb 29 02:50:50 av10 postfix/qmgr[13455]: 6D35334052: from=<steve@...>, size=1218, nrcpt=1 (queue active)
      Feb 29 02:50:54 av10 postfix/smtp[8288]: 6D35334052: host mail1.qlc.co.in[213.175.201.46] said: 450 4.1.8 <steve@...>: Sender address rejected: Domain not found (in reply to RCPT TO command)
      Feb 29 02:50:58 av10 postfix/smtp[8288]: 6D35334052: to=<yogesh@...>, relay=mail2.qlc.co.in[213.175.201.46]:25, delay=168338, delays=168330/0.03/4.5/3.3, dsn=4.1.8, status=deferred (host mail2.qlc.co.in[213.175.201.46] said: 450 4.1.8 <steve@...>: Sender address rejected: Domain not found (in reply to RCPT TO command))

      My server should have to reject the message, whereas - as you can see - it is accepted and sent to the destination mail host. I think that there is a trouble in my my recipient restriction configuration:

      permit_mynetworks
      permit_sasl_authenticated
      reject_unauth_destination
      reject_non_fqdn_sender
      reject_non_fqdn_recipient
      reject_unlisted_sender
      reject_unlisted_recipient
      reject_unknown_sender_domain
      reject_invalid_hostname
      reject_rbl_client zen.spamhaus.org
      reject_rbl_client bl.spamcop.net

      Maybe should I put:

      reject_unknown_sender_domain

      before:

      permit_sasl_authenticated

      ?

      And if so, is there an way to do so all messages in deferred queue will be reject in they have not a valid sender domain?

      Regards,

      rocsca
    Your message has been successfully submitted and would be delivered to recipients shortly.