Loading ...
Sorry, an error occurred while loading the content.

Postfix legacy release 2.8.8

Expand Messages
  • Wietse Venema
    [An on-line version of this announcement will be available at http://www.postfix.org/announcements/postfix-2.8.8.html] Postfix legacy release 2.8.8 is
    Message 1 of 5 , Feb 1, 2012
    View Source
    • 0 Attachment
      [An on-line version of this announcement will be available at
      http://www.postfix.org/announcements/postfix-2.8.8.html%5d

      Postfix legacy release 2.8.8 is available. This contains fixes that
      are already part of Postfix 2.9 and 2.10.

      * The Postfix sqlite client, introduced with Postfix 2.8, had
      an embarassing bug in its quoting routine. As the result of
      a last-minute code cleanup before release, this routine
      returned the unquoted text instead of the quoted text. The
      opportunities for mis-use are limited: Postfix sqlite database
      files are usually owned by root, and Postfix daemons usually
      run with non-root privileges so they can't corrupt the database.
      This problem was reported by Rob McGee (rob0).

      * The Postfix 2.8.4 fix for local delivery agent database lookup
      errors was incomplete. The fix correctly added new code to
      detect database lookup errors with mailbox_transport_maps,
      mailbox_command_maps or fallback_transport_maps, but it failed
      to log the problem, and to produce a defer logfile record
      which is needed for "delayed mail" and "mail too old" delivery
      status notifications.

      * The trace(8) service, used for DSN SUCCESS notifications, did
      not distinguish between notifications for a non-bounce or a
      bounce message, causing it to "reply" to mail with the null
      sender address. Problem reported by Sabahattin Gucukoglu.

      * Support for Dovecot auth over TCP sockets, using code that
      already existed for testing purposes. Patrick Koetter kindly
      provided an update for the SASL_README file.

      * Workaround in the LDAP client for changes in the under-documented
      OpenLDAP API, by Victor Duchovni.

      You can find the updated Postfix source code at the mirrors listed
      at http://www.postfix.org/.
    • Wietse Venema
      Postfix 2.8.8 is reissued. It contained a change that should not have been included and that caused a compilation error. You can undo the unwanted change to
      Message 2 of 5 , Feb 1, 2012
      View Source
      • 0 Attachment
        Postfix 2.8.8 is reissued. It contained a change that should not have
        been included and that caused a compilation error.

        You can undo the unwanted change to the mail_params.h file, or download an
        updated 2.8.8 release from the mirrors listed at http://www.postfix.org/.

        Wietse

        Wietse Venema:
        > [An on-line version of this announcement will be available at
        > http://www.postfix.org/announcements/postfix-2.8.8.html%5d
        >
        > Postfix legacy release 2.8.8 is available. This contains fixes that
        > are already part of Postfix 2.9 and 2.10.
        [snip]
      • Reindl Harald
        ... hi i guess the source i downloaded and compiled some minutes ago from ftp.porcupine.org is already the updated one or was i only one happy guy without
        Message 3 of 5 , Feb 1, 2012
        View Source
        • 0 Attachment
          Am 01.02.2012 20:32, schrieb Wietse Venema:
          > Postfix 2.8.8 is reissued. It contained a change that should not have
          > been included and that caused a compilation error.
          >
          > You can undo the unwanted change to the mail_params.h file, or download an
          > updated 2.8.8 release from the mirrors listed at http://www.postfix.org/

          hi

          i guess the source i downloaded and compiled some minutes ago
          from ftp.porcupine.org is already the updated one or was i
          only one happy guy without compile problems?

          this moment i rebuilt my rpm-repo and about to start testing :-)
        • ml
          ... i build with succes a rpm for centos 5 work all fine for me thanks Wietse -- http://pgp.mit.edu:11371/pks/lookup?op=get&search=0xC2626742 gpg --keyserver
          Message 4 of 5 , Feb 1, 2012
          View Source
          • 0 Attachment
            Le mercredi 01 février 2012 à 20:36 +0100, Reindl Harald a écrit :
            >
            > Am 01.02.2012 20:32, schrieb Wietse Venema:
            > > Postfix 2.8.8 is reissued. It contained a change that should not have
            > > been included and that caused a compilation error.
            > >
            > > You can undo the unwanted change to the mail_params.h file, or download an
            > > updated 2.8.8 release from the mirrors listed at http://www.postfix.org/
            >
            > hi
            >
            > i guess the source i downloaded and compiled some minutes ago
            > from ftp.porcupine.org is already the updated one or was i
            > only one happy guy without compile problems?
            >
            > this moment i rebuilt my rpm-repo and about to start testing :-)
            >
            >

            i build with succes a rpm for centos 5

            work all fine for me

            thanks Wietse

            --
            http://pgp.mit.edu:11371/pks/lookup?op=get&search=0xC2626742
            gpg --keyserver pgp.mit.edu --recv-key C2626742

            http://urlshort.eu fakessh @
            http://gplus.to/sshfake
            http://gplus.to/sshswilting
            http://gplus.to/john.swilting
            https://lists.fakessh.eu/mailman/
            This list is moderated by me, but all applications will be accepted
            provided they receive a note of presentation
          • Reindl Harald
            ... thanks from me too because developers do not hear this often enough if things are running well - rollout after some autotests of several functions on 20
            Message 5 of 5 , Feb 1, 2012
            View Source
            • 0 Attachment
              Am 01.02.2012 23:27, schrieb ml:
              >
              > Le mercredi 01 février 2012 à 20:36 +0100, Reindl Harald a écrit :
              >>
              >> Am 01.02.2012 20:32, schrieb Wietse Venema:
              >>> Postfix 2.8.8 is reissued. It contained a change that should not have
              >>> been included and that caused a compilation error.
              >>>
              >>> You can undo the unwanted change to the mail_params.h file, or download an
              >>> updated 2.8.8 release from the mirrors listed at http://www.postfix.org/
              >>
              >> hi
              >>
              >> i guess the source i downloaded and compiled some minutes ago
              >> from ftp.porcupine.org is already the updated one or was i
              >> only one happy guy without compile problems?
              >>
              >> this moment i rebuilt my rpm-repo and about to start testing :-)
              >
              > i build with succes a rpm for centos 5
              >
              > work all fine for me
              > thanks Wietse

              thanks from me too because developers do not hear this often enough
              if things are running well - rollout after some autotests of several
              functions on 20 machines, works like a charme as all postfix-releases
              i know the last years -> great work!
            Your message has been successfully submitted and would be delivered to recipients shortly.