Loading ...
Sorry, an error occurred while loading the content.

Re: sender delivery status notification not working

Expand Messages
  • Wietse Venema
    ... DSN works only if: 1 - The POSTFIX SMTP server sends the DSN announcement to the REMOTE SMTP client. 2 - The REMOTE SMTP client (Thunderbird) requests DSN
    Message 1 of 6 , Dec 30, 2011
    • 0 Attachment
      pritam raote:
      > Hello,
      >
      > * DSN(sender delivery status notification) does not work on my box running
      > postfix.
      > * the version of postfix on the non working box is postfix-2.8.7-1

      DSN works only if:

      1 - The POSTFIX SMTP server sends the DSN announcement to the REMOTE
      SMTP client.

      2 - The REMOTE SMTP client (Thunderbird) requests DSN support.

      To find out if (1) and (2) happen, you need to report the SMTP
      commands and replies between the POSTFIX SMTP server and the REMOTE
      SMTP client (Thunderbird). You can anonymize the email address.

      http://www.postfix.org/DEBUG_README.html#mail

      Wietse
    • pritam raote
      telnet localhost 25 Trying 127.0.0.1... Connected to localhost.localdomain (127.0.0.1). Escape character is ^] . 220 AAAAAAA-AAD.AAAAAAAAAAAA.com ESMTP
      Message 2 of 6 , Jan 2, 2012
      • 0 Attachment
        telnet localhost 25
        Trying 127.0.0.1...
        Connected to localhost.localdomain (127.0.0.1).
        Escape character is '^]'.
        220 AAAAAAA-AAD.AAAAAAAAAAAA.com ESMTP Postfix
        ehlo localhost
        250-AAAAAAA-AAD.AAAAAAAAAAAA.com
        250-PIPELINING
        250-SIZE 31457280
        250-VRFY
        250-ETRN
        250-STARTTLS
        250-AUTH LOGIN PLAIN
        250-AUTH=LOGIN PLAIN
        250-ENHANCEDSTATUSCODES
        250 8BITMIME
        quit
        221 2.0.0 Bye

        Server does not show DSN capabilities i.e 250-DSN  how to enable that ?

        * postconf output
        ------snip---------
        smtp_discard_ehlo_keyword_address_maps =
        smtp_discard_ehlo_keywords =
        ------snip-------------

        * The smtp server-client response.
        * On the server on which DSN does not work
        ---------------------------------------------------------------------------
        0[b2b140]: SMTP Send: MAIL FROM:<AAAA@...> SIZE=390

        0[b2b140]: SMTP entering state: 0
        0[b2b140]: SMTP Response: 250 2.1.0 Ok
        0[b2b140]: SMTP entering state: 5
        0[b2b140]: SMTP Send: RCPT TO:<AAAAAAAAAAAA@...>
        ---------------------------------------------------------------------------

        * On another server where it works
        ---------------------------------------------------------------------------
        0[a2b140]: SMTP Send: MAIL FROM:<AAAAAAAA@...> RET=FULL ENVID=<4F02A9CD.4060309@...> SIZE=391

        0[a2b140]: SMTP entering state: 0
        0[a2b140]: SMTP Response: 250 2.1.0 Ok
        0[a2b140]: SMTP entering state: 5
        0[a2b140]: SMTP Send: RCPT TO:<AAAAAAAAA@...> NOTIFY=SUCCESS,FAILURE,DELAY ORCPT=rfc822;mailhostingserver@...
        ---------------------------------------------------------------------------

        TIA,

        On Fri, Dec 30, 2011 at 8:50 PM, Wietse Venema <wietse@...> wrote:
        pritam raote:
        > Hello,
        >
        > * DSN(sender delivery status notification) does not work on my box running
        > postfix.
        > * the version of postfix on the non working box is postfix-2.8.7-1

        DSN works only if:

        1 - The POSTFIX SMTP server sends the DSN announcement to the REMOTE
           SMTP client.

        2 - The REMOTE SMTP client (Thunderbird) requests DSN support.

        To find out if (1) and (2) happen, you need to report the SMTP
        commands and replies between the POSTFIX SMTP server and the REMOTE
        SMTP client (Thunderbird). You can anonymize the email address.

        http://www.postfix.org/DEBUG_README.html#mail

               Wietse





         

         

      • pritam raote
        * Pls ignore this figured it out. It was disabled. Thanks telnet localhost 25
        Message 3 of 6 , Jan 2, 2012
        • 0 Attachment
          * Pls ignore this figured it out. It was disabled.

          Thanks


          telnet localhost 25
          Trying 127.0.0.1...
          Connected to localhost.localdomain (127.0.0.1).
          Escape character is '^]'.
          220 AAAAAAA-AAD.AAAAAAAAAAAA.com ESMTP Postfix
          ehlo localhost
          250-AAAAAAA-AAD.AAAAAAAAAAAA.com
          250-PIPELINING
          250-SIZE 31457280
          250-VRFY
          250-ETRN
          250-STARTTLS
          250-AUTH LOGIN PLAIN
          250-AUTH=LOGIN PLAIN
          250-ENHANCEDSTATUSCODES
          250 8BITMIME
          quit
          221 2.0.0 Bye

          Server does not show DSN capabilities i.e 250-DSN  how to enable that ?

          * postconf output
          ------snip---------
          smtp_discard_ehlo_keyword_address_maps =
          smtp_discard_ehlo_keywords =
          ------snip-------------

          * The smtp server-client response.
          * On the server on which DSN does not work
          ---------------------------------------------------------------------------
          0[b2b140]: SMTP Send: MAIL FROM:<AAAA@...> SIZE=390

          0[b2b140]: SMTP entering state: 0
          0[b2b140]: SMTP Response: 250 2.1.0 Ok
          0[b2b140]: SMTP entering state: 5
          0[b2b140]: SMTP Send: RCPT TO:<AAAAAAAAAAAA@...>
          ---------------------------------------------------------------------------

          * On another server where it works
          ---------------------------------------------------------------------------
          0[a2b140]: SMTP Send: MAIL FROM:<AAAAAAAA@...> RET=FULL ENVID=<4F02A9CD.4060309@...> SIZE=391

          0[a2b140]: SMTP entering state: 0
          0[a2b140]: SMTP Response: 250 2.1.0 Ok
          0[a2b140]: SMTP entering state: 5
          0[a2b140]: SMTP Send: RCPT TO:<AAAAAAAAA@...> NOTIFY=SUCCESS,FAILURE,DELAY ORCPT=rfc822;mailhostingserver@...
          ---------------------------------------------------------------------------

          TIA,


          On Fri, Dec 30, 2011 at 8:50 PM, Wietse Venema <wietse@...> wrote:
          pritam raote:
          > Hello,
          >
          > * DSN(sender delivery status notification) does not work on my box running
          > postfix.
          > * the version of postfix on the non working box is postfix-2.8.7-1

          DSN works only if:

          1 - The POSTFIX SMTP server sends the DSN announcement to the REMOTE
             SMTP client.

          2 - The REMOTE SMTP client (Thunderbird) requests DSN support.

          To find out if (1) and (2) happen, you need to report the SMTP
          commands and replies between the POSTFIX SMTP server and the REMOTE
          SMTP client (Thunderbird). You can anonymize the email address.

          http://www.postfix.org/DEBUG_README.html#mail

                 Wietse





           

           


        • Wietse Venema
          ... There is no DSN announcement, therefore, the mail client will not request delivery status notification. DSN support is available with Postfix 2.3 and
          Message 4 of 6 , Jan 3, 2012
          • 0 Attachment
            pritam raote:
            > ehlo localhost
            > 250-AAAAAAA-AAD.AAAAAAAAAAAA.com
            > 250-PIPELINING
            > 250-SIZE 31457280
            > 250-VRFY
            > 250-ETRN
            > 250-STARTTLS
            > 250-AUTH LOGIN PLAIN
            > 250-AUTH=LOGIN PLAIN
            > 250-ENHANCEDSTATUSCODES
            > 250 8BITMIME

            There is no DSN announcement, therefore, the mail client will not
            request delivery status notification.

            DSN support is available with Postfix 2.3 and later. To view
            Postfix settings use:

            $ postconf | grep smtpd_discard_ehlo

            $ grep smtpd_discard_ehlo /etc/postfix/master.cf

            Wietse
          • pritam raote
            * Yep the mistake i did was that i was grepping for smtp_discard instead of smtpd_discard postconf | grep smtp_disc smtp_discard_ehlo_keyword_address_maps =
            Message 5 of 6 , Jan 3, 2012
            • 0 Attachment
              * Yep the mistake i did was that i was grepping for smtp_discard instead of smtpd_discard

              postconf  | grep smtp_disc
              smtp_discard_ehlo_keyword_address_maps =
              smtp_discard_ehlo_keywords =

              postconf  | grep smtpd_disc
              postscreen_discard_ehlo_keyword_address_maps = $smtpd_discard_ehlo_keyword_address_maps
              postscreen_discard_ehlo_keywords = $smtpd_discard_ehlo_keywords
              smtpd_discard_ehlo_keyword_address_maps =
              smtpd_discard_ehlo_keywords = silent-discard, dsn

              * Sorry for all the trouble and thanks for the replies. You guys rock.


              $ postconf | grep smtpd_discard_ehlo

              $ grep smtpd_discard_ehlo /etc/postfix/master.cf

                     Wietse


            Your message has been successfully submitted and would be delivered to recipients shortly.