Loading ...
Sorry, an error occurred while loading the content.

Re: Listening on 587 but submission not enabled in master.cf

Expand Messages
  • email builder
    ... Even more embarrassing answer - that s what I get from testing using telnet from a windows computer.  I guess the firewall software redirects port 587 to
    Message 1 of 2 , Nov 29, 2011
    • 0 Attachment
      > Embarrassing question time...  was investigating use of port 587/submission in

      > addition to our usual 465/smtps, but I found that our server is already
      > listening on port 587.  ALL of the "submission" lines in master.cf are
      > commented out. 
      >
      >
      > Surely I just goofed something up, but I'm not sure where to start to track
      > down how postfix is listening on that port.  I can verify that it is definitely
      > the normal postfix instance because it's got our custom smtpd_banner and
      > accepts mail via our SASL authentication and whatnot.
      >
      > What can I look at to investigate how submission listeners are being enabled?

      Even more embarrassing answer - that's what I get from testing using telnet from a windows computer.  I guess the firewall software redirects port 587 to port 25 or some weird thing like that. 

      Testing from elsewhere shows that in fact there is no submission listener enabled.  Whew.

      Sorry for the noise!
    Your message has been successfully submitted and would be delivered to recipients shortly.