Loading ...
Sorry, an error occurred while loading the content.

Re: Cannot force Postfix to require password

Expand Messages
  • /dev/rob0
    ... This sort of sounds probable. Remove permit_mynetworks from your smtpd_recipient_restrictions. ... Perhaps this is because the real parameter name is
    Message 1 of 3 , Nov 25, 2011
    • 0 Attachment
      On Friday 25 November 2011 05:41:22 Bernard T. Higonnet wrote:
      > I would like to force all users sending mail to provide a name and
      > password.
      >
      > As of this moment, if, in the mail client (Thunderbird anyway), I
      > specify that the smtp server requires name and password it works
      > fine (that is: name is requested and proper password required
      > (duh)). But if in the Thunderbird description of the smtp server
      > the user chooses not to supply name and password that works too!
      >
      > I sort of think (sic) that this is true because the client is on
      > $mynetwork. If it were the case that only clients not on $mynetwork

      This sort of sounds probable. Remove permit_mynetworks from your
      smtpd_recipient_restrictions.

      > would have to provide name and password that would be OK but isn't
      > what I seek. I have not yet had an opportunity to test from
      > another network. I have tried to reduce $mynetwork to the server
      > machine but that didn't work.

      Perhaps this is because the real parameter name is "mynetworks"? We
      count off for spelling errors here, sorry.

      If this suggestion did not solve the problem, please see this before
      posting again:

      http://www.postfix.org/DEBUG_README.html#mail

      > I have tried smtpd_sasl_security_options = noanonymous but that
      > did not seem to have any effect.
      >
      > I have started saslauthd like so:
      >
      > saslauthd -a rimap -O imap_server_machine
      >
      >
      > I doubt it very pertinent but I am running
      >
      > 8.2-RELEASE-p3 FreeBSD 8.2-RELEASE-p3 #0: Tue Sep 27 18:45:57 UTC
      > 2011
      > root@...:/usr/obj/usr/src/sys/GENERIC
      > amd64
      >
      > and Postfix 2.8.7
      --
      Offlist mail to this address is discarded unless
      "/dev/rob0" or "not-spam" is in Subject: header
    Your message has been successfully submitted and would be delivered to recipients shortly.