Loading ...
Sorry, an error occurred while loading the content.

SASL forward problem

Expand Messages
  • kapetr
    Hello, I use posfix as forwarder. The target server is connected via stunnel4. It was working, but now I have changed ISP and the new smpt server has problem
    Message 1 of 2 , Nov 1, 2011
    • 0 Attachment
      Hello,

      I use posfix as forwarder.

      The target server is connected via stunnel4. It was working, but now
      I have changed ISP and the new smpt server has problem with Posfix
      as client.

      Here is TCP stream from Wireshark:

      xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
      220 mailout2.t-email.cz ESMTP
      EHLO 251-43-13-46.tmcz.cz
      250-mailout2.t-email.cz
      250-PIPELINING
      250-SIZE 15360000
      250-VRFY
      250-ETRN
      250-AUTH LOGIN PLAIN
      250-ENHANCEDSTATUSCODES
      250-8BITMIME
      250 DSN
      AUTH LOGIN
      334 XXXXXXXXXX
      YYYYYYY
      334 XXXXXXXXX
      YYYYYYY
      235 2.7.0 Authentication successful
      MAIL FROM:<jiri.panek@...> SIZE=517 AUTH=<>
      RCPT TO:<jipan@...> ORCPT=rfc822;jipan@...
      DATA
      250 2.1.0 Ok
      555 5.5.4 Unsupported option: AUTH=<>
      554 5.5.1 Error: no valid recipients
      RSET
      QUIT
      xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

      If I set this server direct (in place of 127.0.0.1 == Postfix) in
      Evolution with SSL and authentication, the mail is send OK!

      (Such ESMTP communication I can't follow of course).

      So ... there is problem in my Postfix or in ISPs SMTP server.

      Can someone help me please ?
      Can I configure my Postfix to be more compatible with the other
      server ?
      The problem is in format of FROM+TO ESMTP commands.

      If I use the ISPs server in mode without SSL and SASL, then Postfix
      can forward to him.
      In such case the stream looks like:

      yyyyyyyyyyyyyyyyyyy
      ...
      MAIL FROM:<jiri.panek@...> SIZE=517
      RCPT TO:<jipan@...> ORCPT=rfc822;jipan@...
      DATA
      250 2.1.0 Ok
      250 2.1.5 Ok
      354 End data with <CR><LF>.<CR><LF>
      ...
      yyyyyyyyyyyyyyyyyyy

      You see - the difference is "AUTH=<>" in first case

      Thanks

      --kapetr


      --
      Jak se vyhnout nachlazení a dalším zdravotním potížím v nepříjemném
      podzimním období? Čtěte speciál Zdraví na podzim na
      http://web.volny.cz/data/click.php?id=1290
    • Wietse Venema
      ... (there should be an RCPT TO reply here) ... Are you sure that the replies are received in this order? If that is the case, then the server mis-implements
      Message 2 of 2 , Nov 1, 2011
      • 0 Attachment
        kapetr:
        > Hello,
        >
        > I use posfix as forwarder.
        >
        > The target server is connected via stunnel4. It was working, but now
        > I have changed ISP and the new smpt server has problem with Posfix
        > as client.
        >
        > Here is TCP stream from Wireshark:
        >
        > xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
        > 220 mailout2.t-email.cz ESMTP
        > EHLO 251-43-13-46.tmcz.cz
        > 250-mailout2.t-email.cz
        > 250-PIPELINING
        > 250-SIZE 15360000
        > 250-VRFY
        > 250-ETRN
        > 250-AUTH LOGIN PLAIN
        > 250-ENHANCEDSTATUSCODES
        > 250-8BITMIME
        > 250 DSN
        > AUTH LOGIN
        > 334 XXXXXXXXXX
        > YYYYYYY
        > 334 XXXXXXXXX
        > YYYYYYY
        > 235 2.7.0 Authentication successful (this is the final reply to AUTH)
        > MAIL FROM:<jiri.panek@...> SIZE=517 AUTH=<>
        > RCPT TO:<jipan@...> ORCPT=rfc822;jipan@...
        > DATA
        > 250 2.1.0 Ok (this is the reply to *what*?)
        > 555 5.5.4 Unsupported option: AUTH=<> (this would be the reply to MAIL FROM)
        (there should be an RCPT TO reply here)
        > 554 5.5.1 Error: no valid recipients (this is the reply to DATA)

        Are you sure that the replies are received in this order?

        If that is the case, then the server mis-implements SMTP command
        pipelining. To turn that feature off in Postfix:

        /etc/postfix/main.cf:
        smtp_discard_ehlo_keywords = pipelining

        Do "postfix reload" and try again.

        Wietse
      Your message has been successfully submitted and would be delivered to recipients shortly.