Loading ...
Sorry, an error occurred while loading the content.

Re: postfix duplicate mail aliases

Expand Messages
  • Nikolaos Milas
    ... You may want to try: enable_original_recipient = no smtpd_discard_ehlo_keywords = silent-discard, dsn Notes: 1. When we activate these settings, in the
    Message 1 of 4 , Aug 1, 2011
    • 0 Attachment
      On Mon, Aug 01, 2011 at 02:52:31PM +0300, Vasil Mikhalenya wrote:

      >> Hi all,
      >>
      >> I can not find solution for the following problem:
      >> if I send mail to user1@mydomain, and list1@mydomain
      >> and /etc/aliases contains list1: user1,user2
      >> postfix duplicates email for the user1(2 identical email delivered to
      >> user1 mailbox)

      You may want to try:

      enable_original_recipient = no
      smtpd_discard_ehlo_keywords = silent-discard, dsn

      Notes:

      1. When we activate these settings, in the logs there is no more any
      indication of the original recipient!

      2. Also, this will eliminate duplicates only when your server is used as
      the original smtp server to send the emails. For mails sent from other
      servers to the group alias, duplication cannot be eliminated at the
      Postfix level (afaik).

      Nick
    • Victor Duchovni
      ... None of this has any impact on delivery to local aliases that overlap with each other or an explicitly specified original user. -- Viktor.
      Message 2 of 4 , Aug 1, 2011
      • 0 Attachment
        On Tue, Aug 02, 2011 at 12:25:59AM +0300, Nikolaos Milas wrote:

        > You may want to try:
        >
        > enable_original_recipient = no
        > smtpd_discard_ehlo_keywords = silent-discard, dsn

        None of this has any impact on delivery to local aliases that overlap
        with each other or an explicitly specified original user.

        --
        Viktor.
      Your message has been successfully submitted and would be delivered to recipients shortly.