Loading ...
Sorry, an error occurred while loading the content.

postfix duplicate mail aliases

Expand Messages
  • Vasil Mikhalenya
    Hi all, I can not find solution for the following problem: if I send mail to user1@mydomain, and list1@mydomain and /etc/aliases contains list1: user1,user2
    Message 1 of 4 , Aug 1, 2011
    • 0 Attachment
      Hi all,

      I can not find solution for the following problem:
      if I send mail to user1@mydomain, and list1@mydomain
      and /etc/aliases contains list1: user1,user2
      postfix duplicates email for the user1(2 identical email delivered to
      user1 mailbox)

      postconf -n output:

      alias_database = hash:/etc/aliases,hash:/etc/mail/sympa/aliases
      alias_maps = hash:/etc/aliases,hash:/etc/mail/sympa/aliases,ldap:/etc/postfix/ldap-aliases.cf
      append_dot_mydomain = no
      biff = no
      config_directory = /etc/postfix
      debug_peer_list = 127.0.0.1
      enable_original_recipient = no
      inet_interfaces = all
      mailbox_size_limit = 0
      mailbox_transport = dovecot
      mydestination = mx.mydomain, localhost.mydomain, localhost
      myhostname = mx.mydomain
      mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
      myorigin = /etc/mailname
      readme_directory = no
      recipient_delimiter = +
      relayhost =
      smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
      smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)

      Exim4 in that case delivers only 1 email

      Thank you.


      --
      Best regards,
      Vasil Mikhalenya
    • Victor Duchovni
      ... Yes, this is unavoidable without de-duplication below the local(8) transport. For example, with mailbox_transport = cyrus (a transport that delivers to
      Message 2 of 4 , Aug 1, 2011
      • 0 Attachment
        On Mon, Aug 01, 2011 at 02:52:31PM +0300, Vasil Mikhalenya wrote:

        > Hi all,
        >
        > I can not find solution for the following problem:
        > if I send mail to user1@mydomain, and list1@mydomain
        > and /etc/aliases contains list1: user1,user2
        > postfix duplicates email for the user1(2 identical email delivered to
        > user1 mailbox)

        Yes, this is unavoidable without de-duplication below the local(8)
        transport. For example, with mailbox_transport = cyrus (a transport
        that delivers to Cyrus IMAP mailboxes...) duplicate messages are
        suppressed by the Cyrus IMAP mailstore.

        Postfix delivers local mail to multiple users in parallel, and so
        duplicate elimination directly in local(8) is not currently available.

        --
        Viktor.
      • Nikolaos Milas
        ... You may want to try: enable_original_recipient = no smtpd_discard_ehlo_keywords = silent-discard, dsn Notes: 1. When we activate these settings, in the
        Message 3 of 4 , Aug 1, 2011
        • 0 Attachment
          On Mon, Aug 01, 2011 at 02:52:31PM +0300, Vasil Mikhalenya wrote:

          >> Hi all,
          >>
          >> I can not find solution for the following problem:
          >> if I send mail to user1@mydomain, and list1@mydomain
          >> and /etc/aliases contains list1: user1,user2
          >> postfix duplicates email for the user1(2 identical email delivered to
          >> user1 mailbox)

          You may want to try:

          enable_original_recipient = no
          smtpd_discard_ehlo_keywords = silent-discard, dsn

          Notes:

          1. When we activate these settings, in the logs there is no more any
          indication of the original recipient!

          2. Also, this will eliminate duplicates only when your server is used as
          the original smtp server to send the emails. For mails sent from other
          servers to the group alias, duplication cannot be eliminated at the
          Postfix level (afaik).

          Nick
        • Victor Duchovni
          ... None of this has any impact on delivery to local aliases that overlap with each other or an explicitly specified original user. -- Viktor.
          Message 4 of 4 , Aug 1, 2011
          • 0 Attachment
            On Tue, Aug 02, 2011 at 12:25:59AM +0300, Nikolaos Milas wrote:

            > You may want to try:
            >
            > enable_original_recipient = no
            > smtpd_discard_ehlo_keywords = silent-discard, dsn

            None of this has any impact on delivery to local aliases that overlap
            with each other or an explicitly specified original user.

            --
            Viktor.
          Your message has been successfully submitted and would be delivered to recipients shortly.