Loading ...
Sorry, an error occurred while loading the content.

Re: warning: SASL authentication failure: cannot connect to Courier authdaemond: No such file or directory [solved]

Expand Messages
  • mouss
    ... think about it a second: why would postfix check the permissions of a file that is accessed by an external library (cyrus-sasl)? find the answer elsewhere:
    Message 1 of 9 , Jul 26, 2011
    • 0 Attachment
      Le 26/07/2011 17:40, Claudio Prono a écrit :
      >
      >
      > Il 26/07/2011 17.37, Jerry ha scritto:
      >> On Tue, 26 Jul 2011 17:22:19 +0200
      >> Claudio Prono articulated:
      >>
      >>> Il 26/07/2011 17.13, Wietse Venema ha scritto:
      >>>> Claudio Prono:
      >>>>> Hello all,
      >>>>>
      >>>>> This problem is made me mad all today, with no solution...
      >>>> Turn off chroot. This is a magical cure for many mysteries.
      >>>>
      >>>> http://www.postfix.org/DEBUG_README.html#no_chroot
      >>>>
      >>>> If that solves the problem, complain to your distributor. They
      >>>> should not turn on chroot and make life difficult for newbies.
      >>>>
      >>> Tnx for the reply, but my chroot is already disabled, as you can see:
      >>>
      >>> #
      >>> ==========================================================================
      >>> # service type private unpriv chroot wakeup maxproc command +
      >>> args # (yes) (yes) (yes) (never) (100) #
      >>> ==========================================================================
      >>> smtp inet n - n - - smtpd
      >> As per the <http://www.postfix.com/DEBUG_README.html> page:
      >>
      >> Reporting problems to postfix-users@...
      >>
      >> If the problem is SASL related, consider including the output from the
      >> saslfinger tool. This can be found at
      >> http://postfix.state-of-mind.de/patrick.koetter/saslfinger/.
      >>
      > Ok, now works. Is strange but if i set the permissions of the folder
      > /var/run/authdaemon.courier-imap to 777, it doesn't work, and the error
      > is the last i have posted.
      > If i set the permissions correctly, like this:
      >
      > drwxrwx--- 2 root postfix 4096 Jul 26 17:35
      > authdaemon.courier-imap
      >
      > It works...
      >
      > Maybe a permission check from postfix of "too many permissions" on the
      > dir/socket? Dunno... but the error reported from Postfix is very strange...
      >

      think about it a second: why would postfix check the permissions of a
      file that is accessed by an external library (cyrus-sasl)?

      find the answer elsewhere: cyrus-sasl (I doubt it), courier,
      selinux/apparmor/whatever, ... etc.
    Your message has been successfully submitted and would be delivered to recipients shortly.