Loading ...
Sorry, an error occurred while loading the content.
 

Re: strange delay in pre-queue phase

Expand Messages
  • Oliver Schonrocks
    ... Thanks. That was it for sure. Just for the benefit of others: - it was hard for me to change the php client library, although I have posted a bug for Swift
    Message 1 of 4 , Jul 4, 2011
      On 01/07/11 19:24, Wietse Venema wrote:
      > The fix is for the client to append<CR><LF>.<CR>LF> to the message
      > content before writing it to the network.
      >
      > The workaround is for the client to turn off Nagle delays.

      Thanks. That was it for sure.

      Just for the benefit of others:

      - it was hard for me to change the php client library, although I have
      posted a bug for Swift Mailer
      http://swiftmailer.lighthouseapp.com/projects/21527-swift-mailer/tickets/204-nagle-delays-affect-mail-sending-throughput

      - it was also hard to change the client to turn off Nagle delays,
      because Swift Mailer is using the wrong php library to allow that.

      So I changed the system wide Nagle behaviour on the server, which is a
      freebsd system.

      http://lists.freebsd.org/pipermail/freebsd-stable/2008-June/043325.html

      sysctl net.inet.tcp.delacktime=10
      # (default 100ms)

      Which reduced 90% of the delay.

      Not ideal, but fine in this case, since most of the traffic to that
      hosts is LAN or very high speed WAN.

      Thanks again.

      --
      Oliver Schonrock
    Your message has been successfully submitted and would be delivered to recipients shortly.