Loading ...
Sorry, an error occurred while loading the content.

Re: Adjust smtp to limitations of a host

Expand Messages
  • Wietse Venema
    ... You ll have to use a combination of /etc/postfix/main.cf: slow_destination_rate_delay=x (this forces concurrency == 1) slow_destination_recipient_limit=y
    Message 1 of 16 , Apr 1, 2011
    • 0 Attachment
      Victor Duchovni:
      > > Many tanks for your time and help
      >
      > You probably can't do much with my advice, when the receiving system
      > is fubared, your options are limited.

      You'll have to use a combination of

      /etc/postfix/main.cf:
      slow_destination_rate_delay=x (this forces concurrency == 1)
      slow_destination_recipient_limit=y

      /etc/postfix/master.cf:
      slow unix - - n - - smtp
      -o smtp_connection_cache_on_demand=no

      that stays within the stated limits (which of course may not bear
      any relationship to reality, but that is a different matter).

      And these clowns will have to get used to abnormal email delays.
      I hope this isn't my tax money at work.

      Wietse
    • Victor Duchovni
      ... Of course, if their policy is that they only accept a trickle of mail from sites that are not their important business partners, the correct place to make
      Message 2 of 16 , Apr 1, 2011
      • 0 Attachment
        On Fri, Apr 01, 2011 at 01:39:41PM -0400, Wietse Venema wrote:

        > Victor Duchovni:
        > > > Many tanks for your time and help
        > >
        > > You probably can't do much with my advice, when the receiving system
        > > is fubared, your options are limited.
        >
        > You'll have to use a combination of
        >
        > /etc/postfix/main.cf:
        > slow_destination_rate_delay=x (this forces concurrency == 1)
        > slow_destination_recipient_limit=y
        >
        > /etc/postfix/master.cf:
        > slow unix - - n - - smtp
        > -o smtp_connection_cache_on_demand=no
        >
        > that stays within the stated limits (which of course may not bear
        > any relationship to reality, but that is a different matter).
        >
        > And these clowns will have to get used to abnormal email delays.
        > I hope this isn't my tax money at work.

        Of course, if their policy is that they only accept a trickle of
        mail from sites that are not their important business partners,
        the correct place to make adjustments is in their white-list.

        If their systems support a whitelist, the OP should find a way to
        get whitelisted.

        --
        Viktor.
      • Ultrabug
        ... I see indeed, I shall try this out on monday at work. ... It s not an american public host thanksfully (but french host, maybe that s why) :) ... Many
        Message 3 of 16 , Apr 1, 2011
        • 0 Attachment
          On 01/04/2011 19:39, Wietse Venema wrote:
          > Victor Duchovni:
          >>> Many tanks for your time and help
          >> You probably can't do much with my advice, when the receiving system
          >> is fubared, your options are limited.
          > You'll have to use a combination of
          >
          > /etc/postfix/main.cf:
          > slow_destination_rate_delay=x (this forces concurrency == 1)
          > slow_destination_recipient_limit=y
          >
          > /etc/postfix/master.cf:
          > slow unix - - n - - smtp
          > -o smtp_connection_cache_on_demand=no
          >
          I see indeed, I shall try this out on monday at work.
          > that stays within the stated limits (which of course may not bear
          > any relationship to reality, but that is a different matter).
          >
          > And these clowns will have to get used to abnormal email delays.
          > I hope this isn't my tax money at work.
          It's not an american public host thanksfully (but french host, maybe
          that's why) :)
          > Wietse
          Many thanks to you both for taking time to look on this matter. I'll
          keep this thread updated if/when I get this working better.

          Regards
        • Mark Alan
          On Thu, 31 Mar 2011 14:53:11 -0400, Victor Duchovni ... Tried the above setup. It does not help. We have much more 421 with this approach than we had with our
          Message 4 of 16 , Apr 2, 2011
          • 0 Attachment
            On Thu, 31 Mar 2011 14:53:11 -0400, Victor Duchovni
            <Victor.Duchovni@...> wrote:

            > > /etc/postfix/master.cf
            > > slow unix - - - - - smtp
            > > -o syslog_name=postfix-slow
            > > -o smtp_connection_reuse_time_limit=30s
            > > EOT
            > >
            > > /etc/postfix/main.cf
            > > slow_initial_destination_concurrency = 2
            > > slow_destination_concurrency_limit = 15
            > > slow_destination_concurrency_failed_cohort_limit = 5
            > > slow_destination_concurrency_positive_feedback = 1/5
            > > slow_destination_concurrency_negative_feedback = 1/8


            > (...) You can certainly try, and report your findings.

            Tried the above setup. It does not help.
            We have much more 421 with this approach than we had with our former
            setup.

            We will now try the following transport settings (based on a
            recent Wietse sugestion):

            slow unix - - - - - smtp
            -o syslog_name=postfix-slow
            -o default_destination_rate_delay=1s
            -o default_destination_recipient_limit=20
            -o smtp_connection_cache_on_demand=no

            As usual we will be reporting here the results.


            Thank you for your time and good will.


            M.
          • Wietse Venema
            ... THAT DOES NOT WORK. Please follow the instructions. As documented, the following parameters: xxx_destination_rate_delay xxx_destination_recipient_limit are
            Message 5 of 16 , Apr 2, 2011
            • 0 Attachment
              Mark Alan:
              > We will now try the following transport settings (based on a
              > recent Wietse sugestion):
              >
              > slow unix - - - - - smtp
              > -o syslog_name=postfix-slow
              > -o default_destination_rate_delay=1s
              > -o default_destination_recipient_limit=20
              > -o smtp_connection_cache_on_demand=no

              THAT DOES NOT WORK.

              Please follow the instructions.

              As documented, the following parameters:

              xxx_destination_rate_delay
              xxx_destination_recipient_limit

              are implemented by the QUEUE MANAGER not SMTP CLIENT.

              See my earlier email for what parameters go into main.cf and what
              go into master.cf.

              Wietse
            • Mark Alan
              On Sat, 2 Apr 2011 18:03:29 -0400 (EDT), Wietse Venema ... I keep forgetting the inner workings of the multiple inner postfix modules. So here it is the
              Message 6 of 16 , Apr 3, 2011
              • 0 Attachment
                On Sat, 2 Apr 2011 18:03:29 -0400 (EDT), Wietse Venema
                <wietse@...> wrote:

                > > slow unix - - - - - smtp
                > > -o syslog_name=postfix-slow
                > > -o default_destination_rate_delay=1s
                > > -o default_destination_recipient_limit=20
                > > -o smtp_connection_cache_on_demand=no
                > THAT DOES NOT WORK.
                > Please follow the instructions.
                > As documented, the following parameters:
                > xxx_destination_rate_delay
                > xxx_destination_recipient_limit
                > are implemented by the QUEUE MANAGER not SMTP CLIENT.

                I keep forgetting the inner workings of the multiple inner postfix
                modules.

                So here it is the revised setting:

                /etc/postfix/master.cf
                slow unix - - - - - smtp
                -o syslog_name=postfix-slow
                -o smtp_connection_cache_on_demand=no

                /etc/postfix/main.cf
                slow_destination_rate_delay = 1s
                postconf -e 'slow_destination_recipient_limit = 20


                I will be reporting the results.

                Thank you very much for your guidance.

                M.
              • Mark Alan
                On Sat, 2 Apr 2011 18:03:29 -0400 (EDT), Wietse Venema ... I keep forgetting the inner workings of the multiple inner postfix modules. So here it is the
                Message 7 of 16 , Apr 3, 2011
                • 0 Attachment
                  On Sat, 2 Apr 2011 18:03:29 -0400 (EDT), Wietse Venema
                  <wietse@...> wrote:
                  > > slow unix - - - - - smtp
                  > > -o syslog_name=postfix-slow
                  > > -o default_destination_rate_delay=1s
                  > > -o default_destination_recipient_limit=20
                  > > -o smtp_connection_cache_on_demand=no
                  > THAT DOES NOT WORK.
                  > Please follow the instructions.
                  > As documented, the following parameters:
                  > xxx_destination_rate_delay
                  > xxx_destination_recipient_limit
                  > are implemented by the QUEUE MANAGER not SMTP CLIENT.

                  I keep forgetting the inner workings of the multiple inner postfix
                  modules.

                  So here it is the revised setting:

                  /etc/postfix/master.cf
                  slow unix - - - - - smtp
                  -o syslog_name=postfix-slow
                  -o smtp_connection_cache_on_demand=no

                  /etc/postfix/main.cf
                  slow_destination_rate_delay = 1s
                  slow_destination_recipient_limit = 20


                  I will be reporting the results.

                  Thank you very much for your guidance.

                  M.
                • Victor Duchovni
                  ... The number of 421 responses is not a good metric for success. The real metric is the resulting average time in the queue for messages that are finally
                  Message 8 of 16 , Apr 3, 2011
                  • 0 Attachment
                    On Sat, Apr 02, 2011 at 06:59:42PM +0100, Mark Alan wrote:

                    > > > /etc/postfix/master.cf
                    > > > slow unix - - - - - smtp
                    > > > -o syslog_name=postfix-slow
                    > > > -o smtp_connection_reuse_time_limit=30s
                    > > > EOT
                    > > >
                    > > > /etc/postfix/main.cf
                    > > > slow_initial_destination_concurrency = 2
                    > > > slow_destination_concurrency_limit = 15
                    > > > slow_destination_concurrency_failed_cohort_limit = 5
                    > > > slow_destination_concurrency_positive_feedback = 1/5
                    > > > slow_destination_concurrency_negative_feedback = 1/8
                    >
                    > > (...) You can certainly try, and report your findings.
                    >
                    > Tried the above setup. It does not help.
                    > We have much more 421 with this approach than we had with our former
                    > setup.

                    The number of 421 responses is not a good metric for success. The real
                    metric is the resulting average time in the queue for messages that are
                    finally delivered.

                    A dymamic feedback mechanism that is able to go faster, will necessarily
                    elicit 421 responses at a stead rate, to keep it from reaching peak
                    capacity. Naturally, a statically hand-tuned configuration that stays
                    under the remote caps will not elicit 421 responses, but it is likely
                    to stay below the optimal throughput.

                    With sites whose 421 responses are NOT "sticky", the feedback controls
                    will in a variety of cases lead to a nearly optimal throughput with
                    some messages retried at a second MX or deferred, but the overall
                    delay can be smaller than conservative upper-bounds on concurrency
                    and message rates.

                    --
                    Viktor.
                  Your message has been successfully submitted and would be delivered to recipients shortly.