Loading ...
Sorry, an error occurred while loading the content.

RE: postfix can't open local recipient file .db extension

Expand Messages
  • motty.cruz
    Thanks for your reply and apologize for unconsciously breaking the mail list rules. I resolve the issue by re-installing Postfix. Originally I had installed
    Message 1 of 5 , Mar 29, 2011
    • 0 Attachment
      Re: postfix can't open local recipient file .db extension

      Thanks for your reply and apologize for unconsciously breaking the mail list rules.

      I resolve the issue by re-installing Postfix. Originally I had installed Postfix to use sql database, that is the issue I was having or so I assumed.

       

      Thanks,

      -motty

       

      From: owner-postfix-users@... [mailto:owner-postfix-users@...] On Behalf Of mouss
      Sent: Tuesday, March 29, 2011 1:37 PM
      To: 'Postfix users'
      Subject: Re: postfix can't open local recipient file .db extension

       

      Le 28/03/2011 21:01, motty.cruz a écrit :

      > Hello,
      >
      > I'm running Postfix on FreeBSD 8.2. Postfix complaints about this line in my
      > configuration
      > local_recipient_database = hash:/usr/local/etc/postfix/userdb,
      > hash:/usr/local/etc/postfix/uservirt
      >

      local_recipient_database is not a postfix parameter. please be rigorous
      in what you report.


      > The error:
      > postfix/smtpd[1476]: fatal: open database /usr/local/etc/postfix/userdb.db:
      > Invalid argument

      please show the output of 'postconf -n'.

      In the meantime, try
      # rm /usr/local/etc/postfix/userdb.db
      # postmap hash:/usr/local/etc/postfix/userdb



      >
      > my Configuration:

      please obey the rules that you got when you subscribed to the list.
      those rules weren't invented to annoy you, but to maximize your chances
      of getting effective help.
      start by showing output of 'postconf -n'.


      > alias_database = hash:/usr/local/etc/postfix/aliases
      > smtpd_sender_restrictions = reject_unknown_sender_domain,
      >     reject_non_fqdn_sender,
      >     permit_mynetworks
      > smtpd_helo_required = yes
      > disable_vrfy_command = yes
      >

      one of the reasons we prefer 'postconf -n' is that it is alpha-ordered
      which makes it easy for easy to look for parameters.


      No virus found in this message.
      Checked by AVG - www.avg.com
      Version: 10.0.1204 / Virus Database: 1498/3537 - Release Date: 03/29/11

    Your message has been successfully submitted and would be delivered to recipients shortly.