Loading ...
Sorry, an error occurred while loading the content.

Re: Local delivery & Mailman

Expand Messages
  • Michael Orlitzky
    ... This worked and did greatly simplify things. I removed all of the virtual stuff, went to local-users only, and reverted local_recipient_maps to $alias_maps
    Message 1 of 10 , Jan 31, 2011
    • 0 Attachment
      On 01/31/11 14:49, /dev/rob0 wrote:
      > On Fri, Jan 28, 2011 at 05:34:20PM -0500, Michael Orlitzky wrote:
      >> On 01/28/2011 03:28 PM, Ralf Hildebrandt wrote:
      >>> * Michael Orlitzky <michael@...>:
      >>>
      >>>> I tried with transport_maps:
      >>>>
      >>>> example.com local:
      >>>>
      >>>> and local_transport = error:... and got this (http3.viabit.com
      >>>> is myorigin):
      >>>>
      >>>> Jan 28 15:05:25 http3 postfix/error[20737]: 24944A302DF:
      >>>> to=<members@...>, orig_to=<members@...>,
      > -------------------^^^^^^^^^^^^^^^^
      >
      > This domain, your $myorigin, is the transport used, not the one you
      > have set for example.com.
      >
      > Do not use unqualified addresses as lookup results unless you are
      > certain where they are going. Apparently mydestination includes
      > $myorigin, and your virtual_alias_maps rewrote members@... to
      > "members". With example.com in transport_maps, leave it alone.
      >
      > This whole thing could be simpler with "mydestination = example.com"
      > and remove the local_transport and transport_maps settings.
      >

      This worked and did greatly simplify things. I removed all of the
      virtual stuff, went to local-users only, and reverted
      local_recipient_maps to $alias_maps in which Mailman will list all valid
      recipients. I didn't use the default for local_recipient_maps because I
      wanted to reject apache@... per my original message.


      >
      > This isn't a good idea in this case. Leave local_recipient_maps at
      > default and let Mailman manage your alias_maps.
      >
      >> local_transport = error:Local delivery is disabled.
      >
      > As per above, might not be needed.
      >
      >> mydomain = viabit.com
      >> myhostname = http3.viabit.com
      >> mynetworks_style = host
      >
      > You have not set mydestination, thus getting the default. Why?
      >

      I didn't know any better when I set it up.


      >
      > If the list domain is in mydestination, there is no need for any
      > virtual aliasing of Mailman addresses.
    Your message has been successfully submitted and would be delivered to recipients shortly.