Loading ...
Sorry, an error occurred while loading the content.
 

Re: Postfix and Postgrey Part II

Expand Messages
  • Gian Carlo Stagni
    ... Shame on me, I was obviously thinking to --delay . gc :-)
    Message 1 of 22 , Jan 1, 2011
      Il 01/01/2011 17:47, Gian Carlo Stagni ha scritto:

      >> /usr/local/sbin/postgrey --pidfile=/var/run/postgrey.pid --inet=10023 -d
      >> --user=postgrey --group=postgrey --dbd
      > The "-d" parameter set the amount of seconds...
      Shame on me, I was obviously thinking to "--delay".

      gc :-)
    • Ned Slider
      ... Create the file /etc/sysconfig/postgrey and add desired options like so: OPTIONS= --delay=30 --auto-whitelist-clients=1 Hope that helps.
      Message 2 of 22 , Jan 1, 2011
        On 01/01/11 21:37, jason hirsh wrote:
        >
        >
        > I can not find any info where the config file is suppose to be..

        Create the file /etc/sysconfig/postgrey

        and add desired options like so:

        OPTIONS="--delay=30 --auto-whitelist-clients=1"

        Hope that helps.
      • jason hirsh
        ... I have no such directory i am running freebsd 8.0
        Message 3 of 22 , Jan 1, 2011
          On Jan 1, 2011, at 7:36 PM, Ned Slider wrote:

          > On 01/01/11 21:37, jason hirsh wrote:
          >>
          >>
          >> I can not find any info where the config file is suppose to be..
          >
          > Create the file /etc/sysconfig/postgrey
          >


          I have no such directory

          i am running freebsd 8.0
          > and add desired options like so:
          >
          > OPTIONS="--delay=30 --auto-whitelist-clients=1"
          >
          > Hope that helps.
          >
        • Noel Jones
          ... If you installed from freebsd ports collection, you set the parameters in the /etc/rc.conf file. # /etc/rc.conf postgrey_enable=YES
          Message 4 of 22 , Jan 1, 2011
            On 1/1/2011 6:42 PM, jason hirsh wrote:
            >
            > On Jan 1, 2011, at 7:36 PM, Ned Slider wrote:
            >
            >> On 01/01/11 21:37, jason hirsh wrote:
            >>>
            >>>
            >>> I can not find any info where the config file is suppose to
            >>> be..
            >>
            >> Create the file /etc/sysconfig/postgrey
            >>
            >
            >
            > I have no such directory
            >
            > i am running freebsd 8.0


            If you installed from freebsd ports collection, you set the
            parameters in the /etc/rc.conf file.

            # /etc/rc.conf
            postgrey_enable=YES
            postgrey_flags="--inet=10023 ...more options..."

            See the port notes for more info, or the postgrey docs for
            available flags.


            Anyway, this is clearly not a postfix issue, but rather a
            postgrey issue. Send followup questions to a postgrey support
            forum.




            -- Noel Jones
          • Jeroen Geilman
            ... Recipients are processed one at a time. Postfix doesn t know if the previous invalid (450) recipient was the last one, until postfix receives a DATA
            Message 5 of 22 , Jan 2, 2011
              On 1/1/11 9:36 PM, Stan Hoeppner wrote:
              > Wietse Venema put forth on 1/1/2011 9:50 AM:
              >> Stan Hoeppner:
              >>> jason hirsh put forth on 12/31/2010 3:38 PM:
              >>>
              >>>> Dec 31 15:24:21 tuna postfix/smtpd[2514]:>
              >>>> asmtpout029.mac.com[17.148.16.104]: 554 5.5.1 Error: no valid recipients
              >>> Am I the only one that noticed this^? Or, am I the only one that
              >>> (mistakenly?) thinks it may be relevant?
              >> See RFC 2920 (perhaps after refreshing up on RFC 2821).
              >>
              >> Wietse
              > What exactly am I supposed to be looking for Wietse? What I was
              > pointing out is that it appears he returned both 450 and 554 responses
              > during the same smtp transaction with 17.148.16.104. I was of the
              > understanding that you return one or the other, not both. Is that what
              > I'm supposed to be reading about?

              Recipients are processed one at a time.
              Postfix doesn't know if the previous invalid (450) recipient was the
              last one, until postfix receives a DATA command from the client.
              It has no choice but to act the way it did.


              --
              J.
            • Jordi Espasa Clofent
              http://blog.minibofh.org/?p=45 -- I will face my fear. I will permit it to pass over me and through me. And when it has gone past I will turn the inner eye to
              Message 6 of 22 , Jan 3, 2011
                http://blog.minibofh.org/?p=45

                --
                I will face my fear. I will permit it to pass over me and through me.
                And when it has gone past I will turn the inner eye to see its path.
                Where the fear has gone there will be nothing. Only I will remain.
              • jason hirsh
                ... thank you for you info.. This is pretty much what I did to install and from what I have seen.. it doesn t learn for me asbit will grey list the same
                Message 7 of 22 , Jan 3, 2011
                  On Jan 3, 2011, at 7:03 AM, Jordi Espasa Clofent wrote:

                  > http://blog.minibofh.org/?p=45
                  >
                  > --


                  thank you for you info.. This is pretty much what I did to install
                  and from what I have seen.. it doesn't "learn" for me asbit will grey
                  list the same domain over and over again


                  > I will face my fear. I will permit it to pass over me and through
                  > me. And when it has gone past I will turn the inner eye to see its
                  > path. Where the fear has gone there will be nothing. Only I will
                  > remain.
                Your message has been successfully submitted and would be delivered to recipients shortly.