Loading ...
Sorry, an error occurred while loading the content.

Re: Postfix and Postgrey Part II

Expand Messages
  • Stan Hoeppner
    ... Am I the only one that noticed this^? Or, am I the only one that (mistakenly?) thinks it may be relevant? Dec 31 15:24:21 tuna postfix/smtpd[2514]:
    Message 1 of 22 , Jan 1, 2011
    • 0 Attachment
      jason hirsh put forth on 12/31/2010 3:38 PM:

      > Dec 31 15:24:21 tuna postfix/smtpd[2514]: >
      > asmtpout029.mac.com[17.148.16.104]: 554 5.5.1 Error: no valid recipients

      Am I the only one that noticed this^? Or, am I the only one that
      (mistakenly?) thinks it may be relevant?


      Dec 31 15:24:21 tuna postfix/smtpd[2514]: >
      asmtpout029.mac.com[17.148.16.104]: 450 4.2.0 <jason@...>:
      Recipient address rejected: Greylisted, see http:/
      Dec 31 15:24:21 tuna postfix/smtpd[2514]: <
      asmtpout029.mac.com[17.148.16.104]: DATA
      Dec 31 15:24:21 tuna postfix/smtpd[2514]: >
      asmtpout029.mac.com[17.148.16.104]: 554 5.5.1 Error: no valid recipients
      Dec 31 15:24:21 tuna postfix/smtpd[2514]: <
      asmtpout029.mac.com[17.148.16.104]: QUIT
      Dec 31 15:24:21 tuna postfix/smtpd[2514]: >
      asmtpout029.mac.com[17.148.16.104]: 221 2.0.0 Bye

      --
      Stan
    • jason hirsh
      ... The setting are the default from installation.. I haven t really figured out how to change them as I can not find any configuration other then the start up
      Message 2 of 22 , Jan 1, 2011
      • 0 Attachment
        On Jan 1, 2011, at 12:59 AM, Victor Duchovni wrote:

        > On Fri, Dec 31, 2010 at 06:26:41PM -0400, jason hirsh wrote:
        >
        >>> Where is the rest of this log entry, it too is truncated... Where
        >>> are
        >>> the other instances of this same client/sender/recipient triple
        >>> being
        >>> rejected?
        >>
        >> Dec 31 00:03:02 tuna postfix/smtpd[8857]: NOQUEUE: reject: RCPT from
        >> snt0-omc1-s51.snt0.hotmail.com[65.54.61.88]: 450 4.2.0 <jason@...
        >> >:
        >> Recipient address rejected: Greylisted, see
        >> http://postgrey.schweikert.ch/help/kasdivi.com.html;
        >> from=<captcurrent@...> to=<jason@...> proto=ESMTP
        >> helo=<snt0-omc1-s51.snt0.hotmail.com>
        >
        > This is better the client/sender triple appears constant for the
        > three log entries.
        >
        >> Dec 31 00:11:02 tuna postfix/smtpd[9013]: NOQUEUE: reject: RCPT from
        >> snt0-omc1-s51.snt0.hotmail.com[65.54.61.88]: 450 4.2.0 <jason@...
        >> >:
        >> Recipient address rejected: Greylisted, see
        >> http://postgrey.schweikert.ch/help/kasdivi.com.html;
        >> from=<captcurrent@...> to=<jason@...> proto=ESMTP
        >> helo=<snt0-omc1-s51.snt0.hotmail.com>
        >
        > This re-transmission is likely too soon, what is your minimum retry
        > time
        > set to (in the postgrey configuration).

        The setting are the default from installation.. I haven't really
        figured out how to change them as I can not find any configuration
        other then the start up script

        While the hotmail account interval is extremely short (I believe
        default is 5 minutes) I had similar situations with virtually all
        incoming mail unless i manually white listed it



        >
        >> Dec 31 00:15:02 tuna postfix/smtpd[9092]: NOQUEUE: reject: RCPT from
        >> snt0-omc1-s51.snt0.hotmail.com[65.54.61.88]: 450 4.2.0 <jason@...
        >> >:
        >> Recipient address rejected: Greylisted, see
        >> http://postgrey.schweikert.ch/help/kasdivi.com.html;
        >> from=<captcurrent@...> to=<jason@...> proto=ESMTP
        >> helo=<snt0-omc1-s51.snt0.hotmail.com>
        >>
        >> and so forth until i turned off postgrey
        >
        > OK, Postfix is behaving normally, so the question is why Postgrey is
        > not,
        > indeed the Postgrey logs and configuration are likely the right place
        > to look next.
        >

        only postgrey log entry is like this

        Dec 31 00:03:56 tuna postgrey[1250]: action=greylist, reason=new,
        client_name=qmta14.westchester.pa.mail.comcast.net,
        client_address=76.96.59.212, sender=dbowman7266@..., recipient=jason@...


        for each incoming mail

        the configuration is however the freebsd port installed it

        > Viktor.
      • Wietse Venema
        ... See RFC 2920 (perhaps after refreshing up on RFC 2821). Wietse
        Message 3 of 22 , Jan 1, 2011
        • 0 Attachment
          Stan Hoeppner:
          > jason hirsh put forth on 12/31/2010 3:38 PM:
          >
          > > Dec 31 15:24:21 tuna postfix/smtpd[2514]: >
          > > asmtpout029.mac.com[17.148.16.104]: 554 5.5.1 Error: no valid recipients
          >
          > Am I the only one that noticed this^? Or, am I the only one that
          > (mistakenly?) thinks it may be relevant?

          See RFC 2920 (perhaps after refreshing up on RFC 2821).

          Wietse
          >
          > Dec 31 15:24:21 tuna postfix/smtpd[2514]: >
          > asmtpout029.mac.com[17.148.16.104]: 450 4.2.0 <jason@...>:
          > Recipient address rejected: Greylisted, see http:/
          > Dec 31 15:24:21 tuna postfix/smtpd[2514]: <
          > asmtpout029.mac.com[17.148.16.104]: DATA
          > Dec 31 15:24:21 tuna postfix/smtpd[2514]: >
          > asmtpout029.mac.com[17.148.16.104]: 554 5.5.1 Error: no valid recipients
          > Dec 31 15:24:21 tuna postfix/smtpd[2514]: <
          > asmtpout029.mac.com[17.148.16.104]: QUIT
          > Dec 31 15:24:21 tuna postfix/smtpd[2514]: >
          > asmtpout029.mac.com[17.148.16.104]: 221 2.0.0 Bye
          >
          > --
          > Stan
          >
          >
        • Gian Carlo Stagni
          ... I use Debian, but the configuration may be similar. ... The -d parameter set the amount of seconds of delay and it should appear in the command line. I
          Message 4 of 22 , Jan 1, 2011
          • 0 Attachment
            Il 31/12/2010 22:13, jason hirsh ha scritto:

            > The issue is Postgrey keeps bouncingh the same message...

            > Freebsd 8.0
            I use Debian, but the configuration may be similar.

            > Postgrey is running as follows:
            > postgrey 1258 0.0 1.0 12196 10144 ?? Ss 3:05PM 0:00.21
            > /usr/local/sbin/postgrey --pidfile=/var/run/postgrey.pid --inet=10023 -d
            > --user=postgrey --group=postgrey --dbd
            The "-d" parameter set the amount of seconds of delay and it should
            appear in the command line.
            I don't know if you cut the line or the "-d" has no following value.
            In this case, I guess a "null" may be interpreted as an unlimited greytime.
            What is the content of "/etc/default/postgrey" (or wherever Freebsd puts
            the configuration file of Postgrey)?

            gc :-)
          • Stan Hoeppner
            ... What exactly am I supposed to be looking for Wietse? What I was pointing out is that it appears he returned both 450 and 554 responses during the same
            Message 5 of 22 , Jan 1, 2011
            • 0 Attachment
              Wietse Venema put forth on 1/1/2011 9:50 AM:
              > Stan Hoeppner:
              >> jason hirsh put forth on 12/31/2010 3:38 PM:
              >>
              >>> Dec 31 15:24:21 tuna postfix/smtpd[2514]: >
              >>> asmtpout029.mac.com[17.148.16.104]: 554 5.5.1 Error: no valid recipients
              >>
              >> Am I the only one that noticed this^? Or, am I the only one that
              >> (mistakenly?) thinks it may be relevant?
              >
              > See RFC 2920 (perhaps after refreshing up on RFC 2821).
              >
              > Wietse

              What exactly am I supposed to be looking for Wietse? What I was
              pointing out is that it appears he returned both 450 and 554 responses
              during the same smtp transaction with 17.148.16.104. I was of the
              understanding that you return one or the other, not both. Is that what
              I'm supposed to be reading about?

              --
              Stan
            • lst_hoe02@kwsoft.de
              ... There is clearly something missing. The last should be --dbdir= and the most valuable part is --delay= . Have a look where the parameters
              Message 6 of 22 , Jan 1, 2011
              • 0 Attachment
                Zitat von jason hirsh <hirshj@...>:

                > OK Everyone was such a help that I am back.. I got a new server and
                > thought things were going great
                >
                > The issue is Postgrey keeps bouncingh the same message i have tried
                > to debug using my mac.com, comcast.net hotmail.com
                > in all instances it kept boucing the mail until I entered the server
                > in the white
                >
                > Freebsd 8.0
                >
                > Postgrey is running as follows:
                > postgrey 1258 0.0 1.0 12196 10144 ?? Ss 3:05PM 0:00.21
                > /usr/local/sbin/postgrey --pidfile=/var/run/postgrey.pid
                > --inet=10023 -d --user=postgrey --group=postgrey --dbd

                There is clearly something missing. The last should be
                "--dbdir=<Path>" and the most valuable part is "--delay=<seconds>".
                Have a look where the parameters are set, most of the time you should
                be able to find out by examine the startscript.
                Be sure to use --auto-whitelist-clients=1 if you have found out where
                the config lives, the default of 5 is only useful if you have at least
                midsize traffic.

                Regards

                Andreas
              • Wietse Venema
                ... If you have a question about this sequence: C: MAIL FROM: S: 250 sender accepted C: RCPT TO: S: 4XX recipient greylisted C: DATA S: 5XX
                Message 7 of 22 , Jan 1, 2011
                • 0 Attachment
                  Stan Hoeppner:
                  > Wietse Venema put forth on 1/1/2011 9:50 AM:
                  > > Stan Hoeppner:
                  > >> jason hirsh put forth on 12/31/2010 3:38 PM:
                  > >>
                  > >>> Dec 31 15:24:21 tuna postfix/smtpd[2514]: >
                  > >>> asmtpout029.mac.com[17.148.16.104]: 554 5.5.1 Error: no valid recipients
                  > >>
                  > >> Am I the only one that noticed this^? Or, am I the only one that
                  > >> (mistakenly?) thinks it may be relevant?
                  > >
                  > > See RFC 2920 (perhaps after refreshing up on RFC 2821).
                  > >
                  > > Wietse
                  >
                  > What exactly am I supposed to be looking for Wietse? What I was
                  > pointing out is that it appears he returned both 450 and 554 responses
                  > during the same smtp transaction with 17.148.16.104. I was of the
                  > understanding that you return one or the other, not both. Is that what
                  > I'm supposed to be reading about?

                  If you have a question about this sequence:

                  C: MAIL FROM:<sender>
                  S: 250 sender accepted
                  C: RCPT TO:<recipient>
                  S: 4XX recipient greylisted
                  C: DATA
                  S: 5XX no valid recipients

                  Then it is perhaps illustrative to look at this from the sender's
                  perspective:

                  C: MAIL FROM:<sender>
                  RCPT TO:<recipient>
                  DATA
                  S: 250 sender accepted
                  4XX recipient greylisted
                  5XX no valid recipients

                  Now, please refresh up on RFC 2821 and then study RFC 2920.

                  Wietse
                • jason hirsh
                  ... Opps I made a mistake in cut and paste postgrey 1258 0.0 1.0 12196 9988 ?? Is 4:32PM 0:00.03 /usr/ local/sbin/postgrey
                  Message 8 of 22 , Jan 1, 2011
                  • 0 Attachment
                    On Jan 1, 2011, at 4:45 PM, lst_hoe02@... wrote:

                    > Zitat von jason hirsh <hirshj@...>:
                    >
                    >> OK Everyone was such a help that I am back.. I got a new server and
                    >> thought things were going great
                    >>
                    >> The issue is Postgrey keeps bouncingh the same message i have
                    >> tried to debug using my mac.com, comcast.net hotmail.com
                    >> in all instances it kept boucing the mail until I entered the
                    >> server in the white
                    >>
                    >> Freebsd 8.0
                    >>
                    >> Postgrey is running as follows:
                    >> postgrey 1258 0.0 1.0 12196 10144 ?? Ss 3:05PM 0:00.21 /
                    >> usr/local/sbin/postgrey --pidfile=/var/run/postgrey.pid --
                    >> inet=10023 -d --user=postgrey --group=postgrey --dbd
                    >
                    > There is clearly something missing. The last should be "--
                    > dbdir=<Path>" and the most valuable part is "--delay=<seconds>".
                    > Have a look where the parameters are set, most of the time you
                    > should be able to find out by examine the startscript.


                    Opps I made a mistake in cut and paste


                    postgrey 1258 0.0 1.0 12196 9988 ?? Is 4:32PM 0:00.03 /usr/
                    local/sbin/postgrey --pidfile=/var/run/postgrey.pid --inet=10023 -d --
                    user=postgrey --group=postgrey --dbdir=/var/db/postgrey --x



                    > Be sure to use --auto-whitelist-clients=1 if you have found out
                    > where the config lives, the default of 5 is only useful if you have
                    > at least midsize traffic.
                    >

                    I can not find any info where the config file is suppose to be.. i
                    changed the flags ij the startup script as follows
                    postgrey_flags=${postgrey_flags:-"--pidfile=${postgrey_pidfile} \
                    --inet=10023 -d --user=postgrey --group=postgrey --dbdir=/var/
                    db/postgrey \
                    --x-greylist-header=${postgrey_greylist_header}"}
                    --delay=30
                    --auto-whitelist-clients=1


                    My clients are off for the weekend so i restarted postgrey and will see





                    > Regards
                    >
                    > Andreas
                    >
                    >

                    postgrey 1257 0.0 1.0 12196 9988 ?? Is 4:20PM 0:00.03 /usr/
                    local/sbin/postgrey --pidfile=/var/run/postgrey.pid --inet=10023 -d --
                    user=postgrey --group=postgrey --dbdir=/var/db/postgrey --x
                    r
                  • Gian Carlo Stagni
                    ... Shame on me, I was obviously thinking to --delay . gc :-)
                    Message 9 of 22 , Jan 1, 2011
                    • 0 Attachment
                      Il 01/01/2011 17:47, Gian Carlo Stagni ha scritto:

                      >> /usr/local/sbin/postgrey --pidfile=/var/run/postgrey.pid --inet=10023 -d
                      >> --user=postgrey --group=postgrey --dbd
                      > The "-d" parameter set the amount of seconds...
                      Shame on me, I was obviously thinking to "--delay".

                      gc :-)
                    • Ned Slider
                      ... Create the file /etc/sysconfig/postgrey and add desired options like so: OPTIONS= --delay=30 --auto-whitelist-clients=1 Hope that helps.
                      Message 10 of 22 , Jan 1, 2011
                      • 0 Attachment
                        On 01/01/11 21:37, jason hirsh wrote:
                        >
                        >
                        > I can not find any info where the config file is suppose to be..

                        Create the file /etc/sysconfig/postgrey

                        and add desired options like so:

                        OPTIONS="--delay=30 --auto-whitelist-clients=1"

                        Hope that helps.
                      • jason hirsh
                        ... I have no such directory i am running freebsd 8.0
                        Message 11 of 22 , Jan 1, 2011
                        • 0 Attachment
                          On Jan 1, 2011, at 7:36 PM, Ned Slider wrote:

                          > On 01/01/11 21:37, jason hirsh wrote:
                          >>
                          >>
                          >> I can not find any info where the config file is suppose to be..
                          >
                          > Create the file /etc/sysconfig/postgrey
                          >


                          I have no such directory

                          i am running freebsd 8.0
                          > and add desired options like so:
                          >
                          > OPTIONS="--delay=30 --auto-whitelist-clients=1"
                          >
                          > Hope that helps.
                          >
                        • Noel Jones
                          ... If you installed from freebsd ports collection, you set the parameters in the /etc/rc.conf file. # /etc/rc.conf postgrey_enable=YES
                          Message 12 of 22 , Jan 1, 2011
                          • 0 Attachment
                            On 1/1/2011 6:42 PM, jason hirsh wrote:
                            >
                            > On Jan 1, 2011, at 7:36 PM, Ned Slider wrote:
                            >
                            >> On 01/01/11 21:37, jason hirsh wrote:
                            >>>
                            >>>
                            >>> I can not find any info where the config file is suppose to
                            >>> be..
                            >>
                            >> Create the file /etc/sysconfig/postgrey
                            >>
                            >
                            >
                            > I have no such directory
                            >
                            > i am running freebsd 8.0


                            If you installed from freebsd ports collection, you set the
                            parameters in the /etc/rc.conf file.

                            # /etc/rc.conf
                            postgrey_enable=YES
                            postgrey_flags="--inet=10023 ...more options..."

                            See the port notes for more info, or the postgrey docs for
                            available flags.


                            Anyway, this is clearly not a postfix issue, but rather a
                            postgrey issue. Send followup questions to a postgrey support
                            forum.




                            -- Noel Jones
                          • Jeroen Geilman
                            ... Recipients are processed one at a time. Postfix doesn t know if the previous invalid (450) recipient was the last one, until postfix receives a DATA
                            Message 13 of 22 , Jan 2, 2011
                            • 0 Attachment
                              On 1/1/11 9:36 PM, Stan Hoeppner wrote:
                              > Wietse Venema put forth on 1/1/2011 9:50 AM:
                              >> Stan Hoeppner:
                              >>> jason hirsh put forth on 12/31/2010 3:38 PM:
                              >>>
                              >>>> Dec 31 15:24:21 tuna postfix/smtpd[2514]:>
                              >>>> asmtpout029.mac.com[17.148.16.104]: 554 5.5.1 Error: no valid recipients
                              >>> Am I the only one that noticed this^? Or, am I the only one that
                              >>> (mistakenly?) thinks it may be relevant?
                              >> See RFC 2920 (perhaps after refreshing up on RFC 2821).
                              >>
                              >> Wietse
                              > What exactly am I supposed to be looking for Wietse? What I was
                              > pointing out is that it appears he returned both 450 and 554 responses
                              > during the same smtp transaction with 17.148.16.104. I was of the
                              > understanding that you return one or the other, not both. Is that what
                              > I'm supposed to be reading about?

                              Recipients are processed one at a time.
                              Postfix doesn't know if the previous invalid (450) recipient was the
                              last one, until postfix receives a DATA command from the client.
                              It has no choice but to act the way it did.


                              --
                              J.
                            • Jordi Espasa Clofent
                              http://blog.minibofh.org/?p=45 -- I will face my fear. I will permit it to pass over me and through me. And when it has gone past I will turn the inner eye to
                              Message 14 of 22 , Jan 3, 2011
                              • 0 Attachment
                                http://blog.minibofh.org/?p=45

                                --
                                I will face my fear. I will permit it to pass over me and through me.
                                And when it has gone past I will turn the inner eye to see its path.
                                Where the fear has gone there will be nothing. Only I will remain.
                              • jason hirsh
                                ... thank you for you info.. This is pretty much what I did to install and from what I have seen.. it doesn t learn for me asbit will grey list the same
                                Message 15 of 22 , Jan 3, 2011
                                • 0 Attachment
                                  On Jan 3, 2011, at 7:03 AM, Jordi Espasa Clofent wrote:

                                  > http://blog.minibofh.org/?p=45
                                  >
                                  > --


                                  thank you for you info.. This is pretty much what I did to install
                                  and from what I have seen.. it doesn't "learn" for me asbit will grey
                                  list the same domain over and over again


                                  > I will face my fear. I will permit it to pass over me and through
                                  > me. And when it has gone past I will turn the inner eye to see its
                                  > path. Where the fear has gone there will be nothing. Only I will
                                  > remain.
                                Your message has been successfully submitted and would be delivered to recipients shortly.