Loading ...
Sorry, an error occurred while loading the content.

Re: Maildrop filtering

Expand Messages
  • Ben
    ... Well, I managed to do what I need by setting maildrop for both virtual and local transport, and playing with pipe(8) parameters to pass to maildrop a mail
    Message 1 of 9 , Dec 7, 2010
    • 0 Attachment
      Le 05/12/2010 02:51, mouss a écrit :
      > Le 03/12/2010 17:56, Ben a écrit :
      >> [snip]
      >> All domains are virtual, I managed to pass all mails to maildrop, it
      >> works. The problem is that in this configuration, mail are not relayed
      >> to other hosts when the user configure mail redirection.
      >> A user can tell : keep the received mail in my mail account, and send a
      >> copy to anyone@...
      >
      > The big question is: how do they do that?
      > if they edit .forward, well, for sure that won't work.
      >
      > if mail is passed to maildrop, users will need maildrop filtering
      > snippets...
      >
      > or the forwarding must happen before delivery. for example, with
      > virtual_alias_maps:
      >
      > joe@... joe@..., joe@...
      >
      > will clone the message. then you can configure postfix to relay the
      > second address to where it should go. if you want .forward functionality,
      > replace forward.example.net with a domain listed under mydestination.
      >
      >> That's this fonctionnality that doesn't works anymore.
      >>
      >> I noticed that when I configure domains to be virtual (with
      >> virtual_mailbox_domains setting), the mails have a
      >> test_thehost.com@... shape.
      >> When I don't do this setup, mails have a test@... shape.
      >> Maybe it's related to the relay problem.
      >
      > postfix doesn't do that by default. so you either have something
      > configured to do the rewrite or mail is processed by something external
      > to postfix.
      >
      > most probably:
      >
      > - you used a virtual alias to rewrite
      > test@... test_thehost.com
      >
      > - myorigin is set to mx1.mybox.com, thus test_thehost.com becomes
      > test_thehost.com@...
      >
      > if it's that, then fix your virtual alias entry: add the domain part
      > explicitely. see the example I've given above (the one with "joe...").
      >
      > PS. that doesn't match your claimed 'postconf -n' (your postconf -n says
      > "myorigin=mx1.test.com", not mx1.mybox.com). When you hide private
      > infos, do so coherently. Otherwise, you're only making it hard for us to
      > help you...
      >
      > and anyway, do not hijack valid domains such as test.com and mybox.com.
      > Use example.com, example.net, example.org or *.example.
      >
      >
      >>>
      >> I would like to always use maildrop for delivering, but mail redirection
      >> don't works anymore when I do that.
      >
      > you can either redirect before passing mail to maildrop (example above),
      > or redirect in maildrop (maildrop has a CC and TO commands, among other
      > things).
      >
      Well, I managed to do what I need by setting maildrop for both virtual
      and local transport, and playing with pipe(8) parameters to pass to
      maildrop a mail that match mail_user table (myvirtual).
      And it's done :)
      Thanks a lot for your help.

      Ben
    Your message has been successfully submitted and would be delivered to recipients shortly.