Loading ...
Sorry, an error occurred while loading the content.

Re: How to drop the recipient address hostname when delivering mail via LMTP?

Expand Messages
  • Ralph Seichter
    ... I think that Dovecot is a great piece of software and would not presume to imply that it has a faulty LMTP implementation. More likely, I made some mistake
    Message 1 of 12 , Aug 30, 2010
    • 0 Attachment
      On 30.08.10 22:11, mouss wrote:

      > are you saying dovecot lmtp implementation has such a bug?

      I think that Dovecot is a great piece of software and would not presume
      to imply that it has a faulty LMTP implementation. More likely, I made
      some mistake in configuring Dovecot. Currently, all my efforts of using
      a Dovecot LMTP socket for Postfix's local deliveries fail, unless I add

      auth_username_format = %Ln

      to my Dovecot config. As far as I understand it, this parameter removes
      the domain part from all user lookups. I have not yet found a way to
      provide userdb data (using LDAP or /etc/passwd as sources) with fully
      qualified LMTP recipient addresses. Where would one specify such data in
      /etc/passwd anyway, unless by (mis)using the GECOS field?

      So, I don't say Dovecot has a bug, but I can't seem to find a way to
      accomodate the needs of both Postfix and Dovecot, where the former
      relies on fully qualified addresses which the latter rejects, at least
      in my setup. This is quite vexing.

      -Ralph
    Your message has been successfully submitted and would be delivered to recipients shortly.