Loading ...
Sorry, an error occurred while loading the content.
 

Delay deliver to a group of domains

Expand Messages
  • Pablo Garcia Melga
    Hi, I have a group of domains, that can t cope with our delivery rate, I need to send them mail at most at 1/second, how should I achieve that ? I tried to
    Message 1 of 7 , Aug 23, 2010
      Hi, I have a group of domains, that can't cope with our delivery rate,
      I need to send them mail at most at 1/second, how should I achieve
      that ?
      I tried to create a new transport in master.cf and reroute these
      domains thru this transpor but it doesn't seems to work.

      Any Help ?

      Regards, Pablo
    • Wietse Venema
      ... Postfix 2.5 and later has output rate delay support. What did you do? We can t say what mistake you made. Wietse
      Message 2 of 7 , Aug 23, 2010
        Pablo Garcia Melga:
        > Hi, I have a group of domains, that can't cope with our delivery rate,
        > I need to send them mail at most at 1/second, how should I achieve
        > that ?
        > I tried to create a new transport in master.cf and reroute these
        > domains thru this transpor but it doesn't seems to work.
        >
        > Any Help ?

        Postfix 2.5 and later has output rate delay support.

        What did you do? We can't say what mistake you made.

        Wietse
      • Pablo Garcia Melga
        I added the following lines to the configuration master.cf smtpslow unix - - n - - smtp transport yahoo.com smtpslow:
        Message 3 of 7 , Aug 24, 2010
          I added the following lines to the configuration

          master.cf

          smtpslow unix - - n - - smtp

          transport

          yahoo.com smtpslow:
          yahoo.com.ar smtpslow:
          yahoo.com.mx smtpslow:
          ymail.com smtpslow:

          main.cf

          transport_maps = hash:/etc/postfix/transport

          smtpslow_destination_concurrency_limit = 10
          smtpslow_destination_recipient_limit = 5

          ran postmap transport and restarted the postfix service

          Regards, Pablo

          On Mon, Aug 23, 2010 at 8:05 PM, Wietse Venema <wietse@...> wrote:
          > Pablo Garcia Melga:
          >> Hi, I have a group of domains, that can't cope with our delivery rate,
          >> I need to send them mail at most at 1/second, how should I achieve
          >> that ?
          >> I tried to create a new transport in master.cf and reroute these
          >> domains thru this transpor but it doesn't seems to work.
          >>
          >> Any Help ?
          >
          > Postfix 2.5 and later has output rate delay support.
          >
          > What did you do? We can't say what mistake you made.
          >
          >        Wietse
          >
        • Wietse Venema
          ... Your configuration works exactly as documented: it sends mail as fast as possible while limiting the CONCURRENCY to 10 parallel connections. If you want to
          Message 4 of 7 , Aug 24, 2010
            Pablo Garcia Melga:
            > I added the following lines to the configuration
            >
            > master.cf
            >
            > smtpslow unix - - n - - smtp
            >
            > transport
            >
            > yahoo.com smtpslow:
            > yahoo.com.ar smtpslow:
            > yahoo.com.mx smtpslow:
            > ymail.com smtpslow:
            >
            > main.cf
            >
            > transport_maps = hash:/etc/postfix/transport
            >
            > smtpslow_destination_concurrency_limit = 10
            > smtpslow_destination_recipient_limit = 5
            >
            > ran postmap transport and restarted the postfix service

            Your configuration works exactly as documented: it sends mail as
            fast as possible while limiting the CONCURRENCY to 10 parallel
            connections.

            If you want to limit the sending RATE, then you must (surprise)
            use the Postfix features that limit the sending RATE.

            http://www.postfix.org/postconf.5.html#transport_destination_rate_delay

            Wietse
          • Pablo Garcia Melga
            Thanks Wietse, works just fine.
            Message 5 of 7 , Aug 24, 2010
              Thanks Wietse, works just fine.



              On Tue, Aug 24, 2010 at 10:12 AM, Wietse Venema <wietse@...> wrote:
              > Pablo Garcia Melga:
              >> I added the following lines to the configuration
              >>
              >> master.cf
              >>
              >> smtpslow  unix  -       -       n       -       -       smtp
              >>
              >> transport
              >>
              >> yahoo.com     smtpslow:
              >> yahoo.com.ar  smtpslow:
              >> yahoo.com.mx  smtpslow:
              >> ymail.com     smtpslow:
              >>
              >> main.cf
              >>
              >> transport_maps = hash:/etc/postfix/transport
              >>
              >> smtpslow_destination_concurrency_limit = 10
              >> smtpslow_destination_recipient_limit = 5
              >>
              >> ran postmap transport and restarted the postfix service
              >
              > Your configuration works exactly as documented: it sends mail as
              > fast as possible while limiting the CONCURRENCY to 10 parallel
              > connections.
              >
              > If you want to limit the sending RATE, then you must (surprise)
              > use the Postfix features that limit the sending RATE.
              >
              > http://www.postfix.org/postconf.5.html#transport_destination_rate_delay
              >
              >        Wietse
              >
            • Pablo Garcia Melga
              I have achieved to use the delay, now I m seeing a lot of this messages in my logfiles warning: you may need to increase the main.cf
              Message 6 of 7 , Sep 1, 2010
                I have achieved to use the delay, now I'm seeing a lot of this
                messages in my logfiles
                "warning: you may need to increase the main.cf
                smtpslow_destination_concurrency_limit from 1"

                My settings are :

                smtpslow_destination_concurrency_limit = 10
                smtpslow_destination_recipient_limit = 15
                smtpslow_destination_rate_delay = 1s
                smtpslow_destination_concurrency_failed_cohort_limit = 5

                I've checked the logs and I'm sending roughly 1 mail per second using
                that transport, is there any way to send more ?, let say 5 messages
                per second but no more than that ?

                Regards, Pablo

                On Tue, Aug 24, 2010 at 12:46 PM, Pablo Garcia Melga <malevo@...> wrote:
                > Thanks Wietse, works just fine.
                >
                >
                >
                > On Tue, Aug 24, 2010 at 10:12 AM, Wietse Venema <wietse@...> wrote:
                >> Pablo Garcia Melga:
                >>> I added the following lines to the configuration
                >>>
                >>> master.cf
                >>>
                >>> smtpslow  unix  -       -       n       -       -       smtp
                >>>
                >>> transport
                >>>
                >>> yahoo.com     smtpslow:
                >>> yahoo.com.ar  smtpslow:
                >>> yahoo.com.mx  smtpslow:
                >>> ymail.com     smtpslow:
                >>>
                >>> main.cf
                >>>
                >>> transport_maps = hash:/etc/postfix/transport
                >>>
                >>> smtpslow_destination_concurrency_limit = 10
                >>> smtpslow_destination_recipient_limit = 5
                >>>
                >>> ran postmap transport and restarted the postfix service
                >>
                >> Your configuration works exactly as documented: it sends mail as
                >> fast as possible while limiting the CONCURRENCY to 10 parallel
                >> connections.
                >>
                >> If you want to limit the sending RATE, then you must (surprise)
                >> use the Postfix features that limit the sending RATE.
                >>
                >> http://www.postfix.org/postconf.5.html#transport_destination_rate_delay
                >>
                >>        Wietse
                >>
                >
              • Wietse Venema
                ... Currently, only full second delays are available. Sub-second time resolution is on the TODO list. The warning messages are telling you that you have a lot
                Message 7 of 7 , Sep 1, 2010
                  Pablo Garcia Melga:
                  > I have achieved to use the delay, now I'm seeing a lot of this
                  > messages in my logfiles
                  > "warning: you may need to increase the main.cf
                  > smtpslow_destination_concurrency_limit from 1"
                  >
                  > My settings are :
                  >
                  > smtpslow_destination_concurrency_limit = 10
                  > smtpslow_destination_recipient_limit = 15
                  > smtpslow_destination_rate_delay = 1s
                  > smtpslow_destination_concurrency_failed_cohort_limit = 5
                  >
                  > I've checked the logs and I'm sending roughly 1 mail per second using
                  > that transport, is there any way to send more ?, let say 5 messages
                  > per second but no more than that ?

                  Currently, only full second delays are available. Sub-second time
                  resolution is on the TODO list.

                  The warning messages are telling you that you have a lot of mail
                  for this slow destination, and that it is causing congestion. You
                  can shut up the warnings with "helpful_warnings = no" in main.cf
                  (and "postfix reload").

                  Wietse

                  > Regards, Pablo
                  >
                  > On Tue, Aug 24, 2010 at 12:46 PM, Pablo Garcia Melga <malevo@...> wrote:
                  > > Thanks Wietse, works just fine.
                  > >
                  > >
                  > >
                  > > On Tue, Aug 24, 2010 at 10:12 AM, Wietse Venema <wietse@...> wrote:
                  > >> Pablo Garcia Melga:
                  > >>> I added the following lines to the configuration
                  > >>>
                  > >>> master.cf
                  > >>>
                  > >>> smtpslow ?unix ?- ? ? ? - ? ? ? n ? ? ? - ? ? ? - ? ? ? smtp
                  > >>>
                  > >>> transport
                  > >>>
                  > >>> yahoo.com ? ? smtpslow:
                  > >>> yahoo.com.ar ?smtpslow:
                  > >>> yahoo.com.mx ?smtpslow:
                  > >>> ymail.com ? ? smtpslow:
                  > >>>
                  > >>> main.cf
                  > >>>
                  > >>> transport_maps = hash:/etc/postfix/transport
                  > >>>
                  > >>> smtpslow_destination_concurrency_limit = 10
                  > >>> smtpslow_destination_recipient_limit = 5
                  > >>>
                  > >>> ran postmap transport and restarted the postfix service
                  > >>
                  > >> Your configuration works exactly as documented: it sends mail as
                  > >> fast as possible while limiting the CONCURRENCY to 10 parallel
                  > >> connections.
                  > >>
                  > >> If you want to limit the sending RATE, then you must (surprise)
                  > >> use the Postfix features that limit the sending RATE.
                  > >>
                  > >> http://www.postfix.org/postconf.5.html#transport_destination_rate_delay
                  > >>
                  > >> ? ? ? ?Wietse
                  > >>
                  > >
                  >
                  >
                Your message has been successfully submitted and would be delivered to recipients shortly.