Loading ...
Sorry, an error occurred while loading the content.

how to get mails out of deferred queue ? (mail loop issue has been resolved in the meantime)

Expand Messages
  • Dr. Rainer Kaluscha
    Hi, we had a mail loop for one user so postfix put all his mails in the deferred queue: to= , status=SOFTBOUNCE (mail forwarding loop for
    Message 1 of 3 , Aug 3, 2010
    • 0 Attachment
      Hi,

      we had a mail loop for one user so postfix put all his mails in the deferred queue:

      to=<user@...>, status=SOFTBOUNCE (mail forwarding loop for user@...)

      Then we removed his .forward file so the mail loop issue was resolved. However, postfix keeps
      the mails in the deferred queue still giving the error message above, though local delivery is
      possible now.

      The only solution I found until now was to manually edit the files in
      /var/spool/postfix/deferred and change the adress in the Delivered-To header. Nevertheless, I
      think there should be a better solution, e.g. temporarily disabling loop detection.

      Any hints would be appreciated.

      Thnx in advance,
      Rainer Kaluscha

      P.S. We are using postfix-2.3.2, mails are passed through amavisd.

      --
      Dr. biol.hum. Dipl.-Inform. Rainer Kaluscha

      Forschungsinstitut für Rehabilitationsmedizin an der Universität Ulm
      Sitz: Moorsanatorium Bad Wurzach
      Karl-Wilhelm-Heck-Str. 12
      D-88410 Bad Wurzach
      Tel. ++49 7564 304-162
      Fax ++49 7564 304-8163
      e-mail: rainer.kaluscha@...
    • Matt Hayes
      ... Look at man postsuper and reference the -r option -Matt
      Message 2 of 3 , Aug 3, 2010
      • 0 Attachment
        On 8/3/2010 4:50 AM, Dr. Rainer Kaluscha wrote:
        > Hi,
        >
        > we had a mail loop for one user so postfix put all his mails in the
        > deferred queue:
        >
        > to=<user@...>, status=SOFTBOUNCE (mail forwarding loop for
        > user@...)
        >
        > Then we removed his .forward file so the mail loop issue was resolved.
        > However, postfix keeps the mails in the deferred queue still giving the
        > error message above, though local delivery is possible now.
        >
        > The only solution I found until now was to manually edit the files in
        > /var/spool/postfix/deferred and change the adress in the Delivered-To
        > header. Nevertheless, I think there should be a better solution, e.g.
        > temporarily disabling loop detection.
        >
        > Any hints would be appreciated.
        >
        > Thnx in advance,
        > Rainer Kaluscha
        >
        > P.S. We are using postfix-2.3.2, mails are passed through amavisd.
        >
        > --
        > Dr. biol.hum. Dipl.-Inform. Rainer Kaluscha
        >
        > Forschungsinstitut für Rehabilitationsmedizin an der Universität Ulm
        > Sitz: Moorsanatorium Bad Wurzach
        > Karl-Wilhelm-Heck-Str. 12
        > D-88410 Bad Wurzach
        > Tel. ++49 7564 304-162
        > Fax ++49 7564 304-8163
        > e-mail: rainer.kaluscha@...


        Look at man postsuper and reference the -r option

        -Matt
      • Dr. Rainer Kaluscha
        ... Requeueing on its own didn t do the trick (the message appeared with a new message id and the same error message). However, I used /etc/postfix/canonical
        Message 3 of 3 , Aug 3, 2010
        • 0 Attachment
          Am 03.08.2010 14:14, schrieb Matt Hayes:
          > On 8/3/2010 4:50 AM, Dr. Rainer Kaluscha wrote:
          >> Hi,
          >>
          >> we had a mail loop for one user so postfix put all his mails in the
          >> deferred queue:
          >>
          >> to=<user@...>, status=SOFTBOUNCE (mail forwarding loop for
          >> user@...)
          >>
          >> Then we removed his .forward file so the mail loop issue was resolved.
          >> However, postfix keeps the mails in the deferred queue still giving the
          >> error message above, though local delivery is possible now.
          >>
          >
          >
          > Look at man postsuper and reference the -r option
          >
          > -Matt

          Requeueing on its own didn't do the trick (the message appeared with a new message id and the
          same error message). However, I used /etc/postfix/canonical to rewrite user@... to
          new_user@.... After that, requeueing via postsuper delivered the mail to new_user
          so it could be forwarded to the original recipient.

          So your hint lead the way - thanks a lot.

          Yours, Rainer
        Your message has been successfully submitted and would be delivered to recipients shortly.