Loading ...
Sorry, an error occurred while loading the content.

Re: Misleading error message on backup MX

Expand Messages
  • Brian Evans - Postfix List
    ... global/mail_params.h 563:extern int var_mailbox_limit; Both of these parameters are signed integers as of Postfix 2.6.5 (and possibly later versions) Once
    Message 1 of 5 , Jul 1 11:03 AM
    • 0 Attachment
      On 7/1/2010 1:39 PM, Roland Ramthun wrote:
      > Hi all,
      >
      > I obviously have an configuration error on my backup MX, but can't sort it out alone.
      >
      > I use two mailservers, one primary MX and a secondary MX which relays messages to the primary.
      >
      > A cron job on eara now generated a mail to root, which should be sent to mail@....
      >
      > This doesn't happen, instead postfix logs the fatal configuration error below.
      >
      > I think the configuration error is misleading, what could the real problem be?
      > Can or should the message be fixed?
      >

      The problem is the configuration, see below:
      > ###
      > Jul 1 17:30:00 eara postfix/master[32664]: daemon started -- version 2.6.6, configuration /etc/postfix
      > Jul 1 17:30:01 eara postfix/qmgr[32671]: 1B0CE781817: from=<root@...>, size=2039, nrcpt=1 (queue active)
      > Jul 1 17:30:01 eara postfix/local[32674]: fatal: main.cf configuration error: mailbox_size_limit is smaller than message_size_limit
      > Jul 1 17:30:02 eara postfix/master[32664]: warning: process //usr/lib64/postfix/local pid 32674 exit status 1
      > Jul 1 17:30:02 eara postfix/master[32664]: warning: //usr/lib64/postfix/local: bad command startup -- throttling
      > ###
      > mailbox_size_limit = 10737418240
      > message_size_limit = 134217728
      global/mail_params.h
      563:extern int var_mailbox_limit;

      Both of these parameters are signed integers as of Postfix 2.6.5 (and
      possibly later versions)
      Once you exceed 2,147,483,647; you get overflows.

      Maybe Wieste should investigate changing the mailbox limit to a long (if
      he hasn't already) as disk space becomes cheaper all of the time.

      Brian
    • Roland Ramthun
      On Thu, 01 Jul 2010 14:03:23 -0400 ... This seems to be the case: Changing the mailbox limit to 0, as Luigi pointed out, or
      Message 2 of 5 , Jul 1 11:40 AM
      • 0 Attachment
        On Thu, 01 Jul 2010 14:03:23 -0400
        Brian Evans - Postfix List <grknight@...> wrote:

        > global/mail_params.h
        > 563:extern int var_mailbox_limit;
        >
        > Both of these parameters are signed integers as of Postfix 2.6.5 (and
        > possibly later versions)
        > Once you exceed 2,147,483,647; you get overflows.

        This seems to be the case: Changing the mailbox limit to 0, as Luigi pointed out, or <2,147,483,647 both solved the problem.

        As the limit is given in bytes this means you can't have mailboxes larger than ~2048MB.
        If this is a design decision, please consider to document it e.g. in the postconf man page (at least that's where I looked for info).

        Thanks for your quick help.

        Regards,
        Roland
      • Roland Ramthun
        On Thu, 01 Jul 2010 20:00:09 +0200 ... The configuration was partly copied from an old machine, this setting doesn t make sense in this setup. Changing the
        Message 3 of 5 , Jul 1 11:42 AM
        • 0 Attachment
          On Thu, 01 Jul 2010 20:00:09 +0200
          Luigi Rosa <lists@...> wrote:

          > What's the point in setting a mailbox limit on a backup MX server?
          >
          > If you set mailbox_size_limit to zero, what happens?

          The configuration was partly copied from an old machine, this setting doesn't make sense in this setup.
          Changing the value to 0 solves the problem, see my other mail.

          Thanks for your help,
          Roland
        Your message has been successfully submitted and would be delivered to recipients shortly.