Loading ...
Sorry, an error occurred while loading the content.

Re: set a catch-all for users that not exists in database

Expand Messages
  • David Touzeau
    ... THanks to explain to me the process but what is for you the best settings to fix the situation ?
    Message 1 of 22 , Jul 1, 2010
    • 0 Attachment
      On 01/07/2010 17:59, Markus Schönhaber wrote:
      > 01.07.2010 17:38, David Touzeau:
      >
      >> this is the content of
      >>
      >> /etc/postfix/mydestination
      >> -----------------------------------
      >> company.tld OK
      >>
      >> /etc/postfix/aliases
      >> -----------------------------------
      >> user1:user1@...
      >> user2:user2@...
      >> all-users:all-users@...
      >>
      >> /etc/postfix/virtual
      >> -----------------------------------
      >> @... all-users@...
      >
      >> catch-all still take the hand
      >
      > And that's OK, since cleanup(8) has rewritten the recipient address to
      > all-users@... according to virtual before local(8) is handed the
      > message and has the chance to do further rewriting according to aliases.
      > http://www.postfix.org/ADDRESS_REWRITING_README.html#overview
      >

      THanks to explain to me the process but what is for you the best
      settings to fix the situation ?
    • Markus Schönhaber
      ... Hm, I have already said what I consider the best fix for the situation: get rid of the catch-all and implement recipient validation. -- Regards mks
      Message 2 of 22 , Jul 1, 2010
      • 0 Attachment
        01.07.2010 18:13, David Touzeau:

        > THanks to explain to me the process but what is for you the best
        > settings to fix the situation ?

        Hm, I have already said what I consider the best fix for the situation:
        get rid of the catch-all and implement recipient validation.

        --
        Regards
        mks
      • David Touzeau
        I think i have found the solution the solution is to populate the /etc/postfix/virtual with user s emails addresses maps before the catch-all instead this
        Message 3 of 22 , Jul 1, 2010
        • 0 Attachment
          I think i have found the solution

          the solution is to populate the /etc/postfix/virtual with user's emails
          addresses maps before the catch-all

          instead this

          @... all-users@...


          fill this:

          user1@... user1@...
          user2@... user2@...
          all-users@... all-users@...
          @... all-users@...

          and it's works !

          Many thanks for your helps



          On 01/07/2010 18:51, Markus Schönhaber wrote:
          > 01.07.2010 18:13, David Touzeau:
          >
          >> THanks to explain to me the process but what is for you the best
          >> settings to fix the situation ?
          >
          > Hm, I have already said what I consider the best fix for the situation:
          > get rid of the catch-all and implement recipient validation.
          >
        Your message has been successfully submitted and would be delivered to recipients shortly.