Loading ...
Sorry, an error occurred while loading the content.
 

Postfix and Google Apps

Expand Messages
  • Cameron Smith
    I have google apps managing mail for my domain but would like to use my server to send newsletters and have run into an issue where I can send with SMTP from
    Message 1 of 7 , Jun 4, 2010
      I have google apps managing mail for my domain but would like to use my server to send newsletters and have run into an issue where I can send with SMTP from accounts on the server using Postfix but when someone replies to that email due to MX it routes to google and not the server.

      What do I have to do to geting this working?

      With Exim I believe it is with a smarthost entry. Is it done the same way with Postfix?

      Do I have to have a matching account at google apps and if so does it need any specific settings?

      Thanks!
      Cameron
    • Matt Hayes
      ... Personally, I d setup your postfix server to be something like lists.mydomain.com and set a separate MX for it. -Matt
      Message 2 of 7 , Jun 4, 2010
        On 6/4/2010 3:45 PM, Cameron Smith wrote:
        > I have google apps managing mail for my domain but would like to use my
        > server to send newsletters and have run into an issue where I can send
        > with SMTP from accounts on the server using Postfix but when someone
        > replies to that email due to MX it routes to google and not the server.
        >
        > What do I have to do to geting this working?
        >
        > With Exim I believe it is with a smarthost entry. Is it done the same
        > way with Postfix?
        >
        > Do I have to have a matching account at google apps and if so does it
        > need any specific settings?
        >
        > Thanks!
        > Cameron


        Personally, I'd setup your 'postfix' server to be something like
        lists.mydomain.com and set a separate MX for it.

        -Matt
      • Noel Jones
        ... Yes, that s normal and expected. ... It is working. Why do you want to change it? If you want a separate mail system, you can set up a subdomain for your
        Message 3 of 7 , Jun 4, 2010
          On 6/4/2010 2:45 PM, Cameron Smith wrote:
          > I have google apps managing mail for my domain but would like to use my
          > server to send newsletters and have run into an issue where I can send
          > with SMTP from accounts on the server using Postfix but when someone
          > replies to that email due to MX it routes to google and not the server.

          Yes, that's normal and expected.


          >
          > What do I have to do to geting this working?

          It is working. Why do you want to change it?

          If you want a separate mail system, you can set up a subdomain
          for your maillists, eg. lists.example.com, with an MX pointing
          to your postfix server.


          >
          > With Exim I believe it is with a smarthost entry. Is it done the same
          > way with Postfix?

          No, that's for sending mail.

          >
          > Do I have to have a matching account at google apps and if so does it
          > need any specific settings?

          Any mail you send out should have a valid username in google apps.


          >
          > Thanks!
          > Cameron

          -- Noel Jones
        • Cameron Smith
          OK this is getting off track and it s probably due to the way I started the thread so let me start over. Currently with my postfix setup when the newsletter is
          Message 4 of 7 , Jun 6, 2010

            OK this is getting off track and it's probably due to the way I started the thread so let me start over.


            Currently with my postfix setup when the newsletter is sent and an account on the domain set up in google apps is on the list they do not get the email at google apps as postfix is trying to deliver that locally.

            With Exim and Google Apps there is a way to allow functionality like I am asking for using the smarthosts entry in the exim config.

            How can I do this with Postfix?

            Thanks!
            Cameron


             On 6/4/2010 2:45 PM, Cameron Smith wrote:

            > I have google apps managing mail for my domain but would like to use my

            > server to send newsletters and have run into an issue where I can send

            > with SMTP from accounts on the server using Postfix but when someone

            > replies to that email due to MX it routes to google and not the server.

            Yes, that's normal and expected.


            >

            > What do I have to do to geting this working?

            It is working. Why do you want to change it?

            If you want a separate mail system, you can set up a subdomain
            for your maillists, eg. lists.example.com, with an MX pointing
            to your postfix server.


            >

            > With Exim I believe it is with a smarthost entry. Is it done the same

            > way with Postfix?

            No, that's for sending mail.

            >

            > Do I have to have a matching account at google apps and if so does it

            > need any specific settings?

            Any mail you send out should have a valid username in google apps.


            >

            > Thanks!

            > Cameron

               -- Noel Jones 

          • Noel Jones
            ... It s off track because you don t describe what problem you re trying to solve. So what are you asking for? If you want ALL mail for ALL domains
            Message 5 of 7 , Jun 6, 2010
              On 6/6/2010 4:31 PM, Cameron Smith wrote:
              > OK this is getting off track and it's probably due to the way I started
              > the thread so let me start over.
              >
              >
              > Currently with my postfix setup when the newsletter is sent and an
              > account on the domain set up in google apps is on the list they do not
              > get the email at google apps as postfix is trying to deliver that locally.
              >
              > With Exim and Google Apps there is a way to allow functionality like I
              > am asking for using the smarthosts entry in the exim config.
              >
              > How can I do this with Postfix?
              >
              > Thanks!
              > Cameron


              It's "off track" because you don't describe what problem
              you're trying to solve. So what are you asking for?

              If you want ALL mail for ALL domains delivered through google,
              use the relayhost setting in postfix. This is what some other
              mailers call a smarthost. Do not list your own domain
              anywhere in postfix.

              If you want your own domain delivered to google and other
              domains delivered directly, your domain should be configured
              as a relay_domain and NOT listed in mydestination.

              If you need a subset of your local accounts delivered to
              google apps, use a transport_maps entry to direct those
              accounts to google.

              http://www.postfix.org/documentation.html


              -- Noel Jones
            • Wietse Venema
              ... To receive your newsletter replies on your Postfix box, your newsletter reply-to address must resolve to your Postfix box. Options: - Change the newsletter
              Message 6 of 7 , Jun 6, 2010
                Cameron Smith:
                > I have google apps managing mail for my domain but would like to use my
                > server to send newsletters and have run into an issue where I can send
                > with SMTP from accounts on the server using Postfix but when someone
                > replies to that email due to MX it routes to google and not the server.

                To receive your newsletter replies on your Postfix box, your
                newsletter reply-to address must resolve to your Postfix box.

                Options:

                - Change the newsletter reply-to address to a new domain name
                (perhaps a subdomain of the managed domain) and set its MX record
                to your Postfix box.

                - Stop using Google apps for this domain, and change the MX record
                for the domain to your Postfix box.

                Wietse
              • Cameron Smith
                Thank you Noel and Wietse! Your helpful instructions have set me on the right path :) Have a great day, Cameron
                Message 7 of 7 , Jun 7, 2010
                  Thank you Noel and Wietse!

                  Your helpful instructions have set me on the right path :)

                  Have a great day,
                  Cameron

                  On Sun, Jun 6, 2010 at 3:21 PM, Wietse Venema <wietse@...> wrote:
                  Cameron Smith:
                  > I have google apps managing mail for my domain but would like to use my
                  > server to send newsletters and have run into an issue where I can send
                  > with SMTP from accounts on the server using Postfix but when someone
                  > replies to that email due to MX it routes to google and not the server.

                  To receive your newsletter replies on your Postfix box, your
                  newsletter reply-to address must resolve to your Postfix box.

                  Options:

                  - Change the newsletter reply-to address to a new domain name
                  (perhaps a subdomain of the managed domain) and set its MX record
                  to your Postfix box.

                  - Stop using Google apps for this domain, and change the MX record
                  for the domain to your Postfix box.

                         Wietse

                Your message has been successfully submitted and would be delivered to recipients shortly.