Loading ...
Sorry, an error occurred while loading the content.

How to get Windows to send FQDN when connecting to a relay

Expand Messages
  • James R. Marcus
    I have two applications that run on windows that return this error when I try to use my postfix relay to send mail. An error occurred while trying to send the
    Message 1 of 3 , Apr 26, 2010
    • 0 Attachment
      I have two applications that run on windows that return this error when I try to use my postfix relay to send mail.

      An error occurred while trying to send the test email. 504 5.5.2 : Helo command rejected: need fully-qualified hostname

      I have added the IPs to mynetworks, but Postfix is requiring a FQDN before allowing the server to relay. The servers have a PTR. Does anyone know how to get Windows to send the FQDN when connecting to a relay? Or is there a simple way to make an exception in Postfix?

      I'm guessing it gets denied here:
      smtpd_recipient_restrictions = reject_invalid_hostname, reject_non_fqdn_hostname, reject_non_fqdn_sender, reject_non_fqdn_recipient, reject_unknown_sender_domain, reject_unknown_recipient_domain, permit_mynetworks, reject_unauth_destination, reject_rbl_client cbl.abuseat.org, reject_rbl_client sbl.spamhaus.org, reject_rbl_client pbl.spamhaus.org permit

      Thanks,
      James
    • Wietse Venema
      ... Put permit_mynetworks before reject_non_fqdn_mumble . Wietse
      Message 2 of 3 , Apr 26, 2010
      • 0 Attachment
        James R. Marcus:
        > I have two applications that run on windows that return this error
        > when I try to use my postfix relay to send mail.
        >
        > An error occurred while trying to send the test email. 504 5.5.2
        > : Helo command rejected: need fully-qualified hostname
        >
        > I have added the IPs to mynetworks, but Postfix is requiring a
        > FQDN before allowing the server to relay.

        Put "permit_mynetworks" before "reject_non_fqdn_mumble".

        Wietse
      • James R. Marcus
        This solved my problem. Thanks, James On Apr 26, 2010, at 10:17 AM, Wietse Venema wrote: James R. Marcus: I have two applications that run on windows that
        Message 3 of 3 , Apr 26, 2010
        • 0 Attachment
          This solved my problem.
          Thanks,
          James
          On Apr 26, 2010, at 10:17 AM, Wietse Venema wrote:

          James R. Marcus:
          I have two applications that run on windows that return this error
          when I try to use my postfix relay to send mail.

          An error occurred while trying to send the test email. 504 5.5.2
          : Helo command rejected: need fully-qualified hostname

          I have added the IPs to mynetworks, but Postfix is requiring a
          FQDN before allowing the server to relay.

          Put "permit_mynetworks" before "reject_non_fqdn_mumble".

          Wietse


        Your message has been successfully submitted and would be delivered to recipients shortly.