Loading ...
Sorry, an error occurred while loading the content.

Sub-domains ignore transport relayhost

Expand Messages
  • Emmanuel Fusté
    Hello, Relevant config parameters: parent_domain_matches_subdomains = relay_domains = hash:some_relay_domains_map relay_relayhost = [a.b.c.d]
    Message 1 of 5 , Apr 1 6:05 AM
    • 0 Attachment
      Hello,

      Relevant config parameters:

      parent_domain_matches_subdomains =
      relay_domains = hash:some_relay_domains_map
      relay_relayhost = [a.b.c.d]

      some_relay_domains_map contain:

      xxx.com x
      yyy.com x
      aaa.xxx.com x
      bbb.yyy.com x

      symptom:
      messages for xxx.com and yyy.com are correctly relayed to [a.b.c.d]
      messages for aaa.xxx.com and bbb.yyy.com are tried to be delivered
      directly to the MX of aaa.xxx.com and bbb.yyy.com.

      Workaround:
      With a transport map, I force these subdomains to be routed to [a.b.c.d]:
      aaa.xxx.com relay:[a.b.c.d]
      bbb.yyy.com relay:[a.b.c.d]

      Note: using simply "aaa.xxx.com relay:" or "bbb.xxx.com relay:" in
      the transport map is not sufficient witch seems to imply that the
      problem is not the selection of the right transport but that
      "relay_relayhost = [a.b.c.d]" is ignored in the subdomain case.

      Is this an expected behavior ? or a bug ?
      It reminds me a previous discussion but I could not find it in my mail
      archives.
      I use Postfix 2.5.4.
      I checked all release notes and changelog of newer version but did not
      find any relevant changes.

      Best regards,
      Emmanuel.
    • Wietse Venema
      ... As always, use postconf -n output when reporting a problem. This would have revealed immediately that relay_relayhost is a mistake. Wietse
      Message 2 of 5 , Apr 1 6:20 AM
      • 0 Attachment
        Emmanuel Fusté:
        > relay_relayhost = [a.b.c.d]

        As always, use "postconf -n" output when reporting a problem. This
        would have revealed immediately that relay_relayhost is a mistake.

        Wietse
      • Emmanuel Fusté
        ... Ok so transport _ postfix-conf-parameter is no longer a supported syntax ? I double check and you re right: the main domains are working by accident
        Message 3 of 5 , Apr 1 6:50 AM
        • 0 Attachment
          Le 01/04/2010 15:20, Wietse Venema a écrit :
          > Emmanuel Fust�:
          >> relay_relayhost = [a.b.c.d]
          >
          > As always, use "postconf -n" output when reporting a problem. This
          > would have revealed immediately that relay_relayhost is a mistake.
          >
          > Wietse

          Ok so "transport"_"postfix-conf-parameter" is no longer a supported syntax ?

          I double check and you're right: the main domains are working by
          accident (MX=relayhost gateway).

          Yes I know that "postconf -n" did not report "relay_relayhost =
          [a.b.c.d]" but I was fooled by my half working setup.

          Could I achieve my goal with modifying the relay line in the master.cf like:

          relay unix - - - - - smtp
          -o smtp_fallback_relay=
          -o relayhost= [a.b.c.d]

          Or should I simply use the transport map and stop doing silly things ;-)

          Best regards,
          Emmanuel.
        • Wietse Venema
          ... This has never been supported for relayhost. Wietse
          Message 4 of 5 , Apr 1 7:15 AM
          • 0 Attachment
            Emmanuel Fusté:
            > Le 01/04/2010 15:20, Wietse Venema a ?crit :
            > > Emmanuel Fust?:
            > >> relay_relayhost = [a.b.c.d]
            > >
            > > As always, use "postconf -n" output when reporting a problem. This
            > > would have revealed immediately that relay_relayhost is a mistake.
            > >
            > > Wietse
            >
            > Ok so "transport"_"postfix-conf-parameter" is no longer a supported syntax ?

            This has never been supported for relayhost.

            Wietse

            > I double check and you're right: the main domains are working by
            > accident (MX=relayhost gateway).
            >
            > Yes I know that "postconf -n" did not report "relay_relayhost =
            > [a.b.c.d]" but I was fooled by my half working setup.
            >
            > Could I achieve my goal with modifying the relay line in the master.cf like:
            >
            > relay unix - - - - - smtp
            > -o smtp_fallback_relay=
            > -o relayhost= [a.b.c.d]
            >
            > Or should I simply use the transport map and stop doing silly things ;-)
            >
            > Best regards,
            > Emmanuel.
            >
            >
          • Victor Duchovni
            ... No. ... Yes. -- Viktor. P.S. Morgan Stanley is looking for a New York City based, Senior Unix system/email administrator to architect and sustain our
            Message 5 of 5 , Apr 1 11:17 AM
            • 0 Attachment
              On Thu, Apr 01, 2010 at 03:50:17PM +0200, Emmanuel Fust?? wrote:

              > Could I achieve my goal with modifying the relay line in the master.cf
              > like:
              >
              > relay unix - - - - - smtp
              > -o smtp_fallback_relay=
              > -o relayhost= [a.b.c.d]

              No.

              > Or should I simply use the transport map and stop doing silly things ;-)

              Yes.

              --
              Viktor.

              P.S. Morgan Stanley is looking for a New York City based, Senior Unix
              system/email administrator to architect and sustain our perimeter email
              environment. If you are interested, please drop me a note.
            Your message has been successfully submitted and would be delivered to recipients shortly.