Loading ...
Sorry, an error occurred while loading the content.

Re: Proxy Setting in Main.cf + Another question (with log snippit)

Expand Messages
  • Noel Jones
    ... proxy is not a postfix parameter, neither is Inet . If you re asking about proxy_interfaces setting, it should be set to the external IP address;
    Message 1 of 2 , Mar 31, 2010
    • 0 Attachment
      On 3/31/2010 3:46 PM, Josh Cason wrote:
      > My mailserver is behing a firewall that also does nat tranlastion. So
      > the inside has a dmz zone. When you hit from the oustide you hit the
      > outside / public ip numbers. You are hitting the firewall box. Then
      > going in to the dmz zone. The firewall is setup to route the proper
      > ports back and forth to the inside. Port 25/110 has two sets of rules.
      > One incomming and one outgoing.
      > 69.69.25.125 port 25 = 172.16.0.10 port 25. (both ways)
      > 172.16.0.10 port 25 = 69.69.25.125 port 25. (both ways)
      > (I don't do firewalls so my answer is limited.)
      >
      >
      > example:
      > (this is just a example with example numbers)
      >
      > fw: (69.69.24.123)
      > ext pub ip for mailserver: (69.69.25.125)
      > dmz: (172.16.0.1)
      > mailserver on inside in dmz zone: (172.16.0.10)
      >
      > So for the setting via proxy / inet.
      >
      > Inet = localhost, 172.16.0.10
      >
      > (WHAT DO I SET THIS PROXY TOO?)
      >
      > Proxy = 172.16.0.10 ???

      "proxy" is not a postfix parameter, neither is "Inet".

      If you're asking about proxy_interfaces setting, it should be
      set to the external IP address; 69.69.25.125
      http://www.postfix.org/postconf.5.html#proxy_interfaces

      If you're asking about inet_interfaces setting, it should
      normally be left at the default of "all".
      http://www.postfix.org/postconf.5.html#inet_interfaces

      >
      > Next question. (I can post more of the log if needed)
      >
      > This looks like a open relay. THis is the beginning of spam hitting my
      > server then it will get routed out to other mailservers. I changed a few
      > things to protect myself in the log file. But any ideas how to stop
      > this? I did post my configuration file a while back and check most
      > everything everybody was kind to sugguest. Including this proxy setting
      > I'm asking about. Notice the strange long id in front of the
      > www.myserver.net If it is a normal e-mail like twinkies@... it
      > gets bounced.
      >
      > Mar 23 20:46:44 primary postfix/smtpd[27713]: connect from
      > mailserver.myserver.net[xxx.xx.x.xxx]
      > Mar 23 20:46:44 primary postfix/smtpd[27713]: 6A3EE10D815B:
      > client=mailserver.myserver.net[xxx.xx.x.xxx]
      > Mar 23 20:46:44 primary postfix/cleanup[28671]: 6A3EE10D815B: hold:
      > header Received: from localhost (mailserver.myserver.net [17$
      > Mar 23 20:46:44 primary postfix/cleanup[28671]: 6A3EE10D815B:
      > message-id=<20100323204644.gu8pcnqs2s8wkkso@...>
      > Mar 23 20:46:44 primary postfix/smtpd[27713]: disconnect from
      > mailserver.myserver.net[xxx.xx.x.xxx]
      >

      This log snippit contains no useful information. The "strange
      long id" is a normal Message-ID header, which postfix always
      logs. If you want help, you need to show unmodified "postconf
      -n" output and unmodified logs demonstrating the problem.


      -- Noel Jones
    Your message has been successfully submitted and would be delivered to recipients shortly.