Loading ...
Sorry, an error occurred while loading the content.
 

Re: Simple mailing list for virtual domain

Expand Messages
  • Thomas Pfaff
    On Wed, 30 Sep 2009 12:04:18 +0200 ... From: Mail Delivery Subsystem To: Subject: Returned mail: see
    Message 1 of 9 , Sep 30, 2009
      On Wed, 30 Sep 2009 12:04:18 +0200
      Ralf Hildebrandt <Ralf.Hildebrandt@...> wrote:

      > * Thomas Pfaff <tpfaff@...>:
      > > Sep 30 11:53:40 gw postfix/qmgr[25164]: 079B412A5D1: removed
      > >
      > > On Wed, 30 Sep 2009 11:50:35 +0200
      > > Ralf Hildebrandt <Ralf.Hildebrandt@...> wrote:
      > >
      > > > * Thomas Pfaff <tpfaff@...>:
      > > > > Hi.
      > > > >
      > > > > I'm trying to get mail sent to list@... forward mail to
      > > > > a list of addresses set in /etc/postfix/virtual, like so:
      > > > >
      > > > > list@... foo@..., bar@...
      > > > >
      > > > > but I'm getting a 550 Host unknown when I try to mail this
      > > > > address. Obviously I'm an idiot and I need some assistance.
      > > >
      > > > Please show the log entry.
      >
      > So where's the "550 Host unknown"?
      > I just see "User unknown in virtual alias table"!
      >

      From: Mail Delivery Subsystem <MAILER-DAEMON@...>
      To: <tpfaff@...>
      Subject: Returned mail: see transcript for details
      Date: Wed, 30 Sep 2009 12:06:23 +0200 (CEST)

      The original message was received at Wed, 30 Sep 2009 12:06:22 +0200 (CEST)
      from tpfaff@localhost [127.0.0.1]

      ----- The following addresses had permanent fatal errors -----
      <list@...>

      ----- Transcript of session follows -----
      550 5.1.2 <list@...>... Host unknown (Name server: smtp1.tp76.info.: host not found)


      [message/delivery-status (294B)]
      Reporting-MTA: dns; ws.tp76.info
      Received-From-MTA: DNS; localhost
      Arrival-Date: Wed, 30 Sep 2009 12:06:22 +0200 (CEST)

      Final-Recipient: RFC822; list@...
      Action: failed
      Status: 5.1.2
      Remote-MTA: DNS; smtp1.tp76.info
      Last-Attempt-Date: Wed, 30 Sep 2009 12:06:23 +0200 (CEST)


      From: Thomas Pfaff <tpfaff@...>
      To: list@...
      Subject: test
      Date: Wed, 30 Sep 2009 12:06:22 +0200 (CEST)

      test
    • Thomas Pfaff
      On Wed, 30 Sep 2009 12:05:02 +0200 ... [...] ... I added `virtual_alias_maps = hash:/etc/postfix/virtual to main.cf. Same result.
      Message 2 of 9 , Sep 30, 2009
        On Wed, 30 Sep 2009 12:05:02 +0200
        Ralf Hildebrandt <Ralf.Hildebrandt@...> wrote:
        > * Thomas Pfaff <tpfaff@...>:
        >
        > > $ postconf -n
        [...]
        > > virtual_alias_domains = foo.com
        >
        > /etc/postfix/virtual is not being used in you "postconf -n" output.
        >

        I added `virtual_alias_maps = hash:/etc/postfix/virtual' to main.cf.

        Same result.
      • Wietse Venema
        ... If you look carefully, you will notice that the bounce email message is created by a non-Postfix system. So, fix that system. Wietse
        Message 3 of 9 , Sep 30, 2009
          Thomas Pfaff:
          > On Wed, 30 Sep 2009 12:05:02 +0200
          > Ralf Hildebrandt <Ralf.Hildebrandt@...> wrote:
          > > * Thomas Pfaff <tpfaff@...>:
          > >
          > > > $ postconf -n
          > [...]
          > > > virtual_alias_domains = foo.com
          > >
          > > /etc/postfix/virtual is not being used in you "postconf -n" output.
          > >
          >
          > I added `virtual_alias_maps = hash:/etc/postfix/virtual' to main.cf.
          >
          > Same result.

          If you look carefully, you will notice that the bounce email message
          is created by a non-Postfix system. So, fix that system.

          Wietse
        • Thomas Pfaff
          On Wed, 30 Sep 2009 06:37:47 -0400 (EDT) ... Just noticed that now. It s working fine sending mail from the outside, which I did not try. Sending mail from
          Message 4 of 9 , Sep 30, 2009
            On Wed, 30 Sep 2009 06:37:47 -0400 (EDT)
            wietse@... (Wietse Venema) wrote:

            > Thomas Pfaff:
            > > On Wed, 30 Sep 2009 12:05:02 +0200
            > > Ralf Hildebrandt <Ralf.Hildebrandt@...> wrote:
            > > > * Thomas Pfaff <tpfaff@...>:
            > > >
            > > > > $ postconf -n
            > > [...]
            > > > > virtual_alias_domains = foo.com
            > > >
            > > > /etc/postfix/virtual is not being used in you "postconf -n" output.
            > > >
            > >
            > > I added `virtual_alias_maps = hash:/etc/postfix/virtual' to main.cf.
            > >
            > > Same result.
            >
            > If you look carefully, you will notice that the bounce email message
            > is created by a non-Postfix system. So, fix that system.
            >

            Just noticed that now. It's working fine sending mail from the
            outside, which I did not try. Sending mail from the inside does
            not work, but that's another issue and OS specific.

            Thank you all for your quick help.

            Cheers,
            Thomas
          Your message has been successfully submitted and would be delivered to recipients shortly.