Loading ...
Sorry, an error occurred while loading the content.

Re: Maximum smtp process limit has been reached.

Expand Messages
  • Wietse Venema
    ... See also: http://www.postfix.org/STRESS_README.html Wietse
    Message 1 of 7 , Jul 2, 2009
    • 0 Attachment
      Jaroslaw Grzabel:
      > Hi,
      >
      > I'm struggling with new SMTP server and I noticed that sometimes it just
      > hangs because of:
      >
      > Jul 2 14:14:21 smtp postfix/master[17716]: warning: service "smtp" (25)
      > has reached its process limit "50": new clients may experience
      > noticeable delays
      > Jul 2 14:15:06 smtp postfix/master[17716]: warning: to avoid this
      > condition, increase the process count in master.cf or reduce the service
      > time per client

      See also: http://www.postfix.org/STRESS_README.html

      Wietse
    • Noel Jones
      ... type in: # postconf -e default_process_limit=100 and then # postfix reload ... Running postfix reload when postfix is busy just makes things worse. Clear
      Message 2 of 7 , Jul 2, 2009
      • 0 Attachment
        Jaroslaw Grzabel wrote:
        > Hi,
        >
        > I'm struggling with new SMTP server and I noticed that sometimes it just
        > hangs because of:
        >
        > Jul 2 14:14:21 smtp postfix/master[17716]: warning: service "smtp" (25)
        > has reached its process limit "50": new clients may experience
        > noticeable delays
        > Jul 2 14:15:06 smtp postfix/master[17716]: warning: to avoid this
        > condition, increase the process count in master.cf or reduce the service
        > time per client

        type in:
        # postconf -e default_process_limit=100
        and then
        # postfix reload


        >
        > The problem is when it happens I can't do nothing just reload postfix.

        Running postfix reload when postfix is busy just makes things
        worse. Clear the clog, then flush.

        > Is there any way to sort it out ? I increased that value now, but for me
        > it's not solving my problem because instead of increasing that I would
        > rather like to postfix struggles with with on its own somehow by reload
        > configuration or ... I don't know.

        Your mailserver receives more connections than postfix is
        configured to accept. Increase the number of connections
        allowed by increasing default_process_limit.


        > Maybe is there any timeout to setup, because after that when I took a
        > look at netstat it showed me a lot of connections from 127.0.0.1
        > (greylisting daemon).

        No, the problem is more incoming connections than postfix is
        configured to accept.

        >
        > Thank you for any help in advance.
        >
        > Regards,
        > Jarek

        Look at http://www.postfix.org/documentation.html under the
        "Problem Solving" section.


        -- Noel Jones
      • Jaroslaw Grzabel
        Hi, Sorry I didn t include any information about version. My postfix version is 2.3.3 installed from yum (Centos 5). Yeah, I read about stress mode and it
        Message 3 of 7 , Jul 2, 2009
        • 0 Attachment
          Hi,

          Sorry I didn't include any information about version. My postfix version is
          2.3.3 installed from yum (Centos 5).

          Yeah, I read about stress mode and it looks really good. Anyway I would
          rather want to stop reciving connection from postfix than hang the whole
          server.

          The problem is, Noel advised me to increase default_process_limit but I've
          already done it and later postfix hanged with the same message as below. I
          think the parameter default_destination_recipient_limit is responsible for
          that. Anyway I created MRTG graph to monitor number of processes, increased
          children level to 250 and I will see tomorrow on the graph what was the
          maximum load and how many processes was run.

          Postfix rather not causes high loads on my server so I can let it to use a
          lot of resources.

          Regards,
          Jarek


          -----Original Message-----
          From: owner-postfix-users@...
          [mailto:owner-postfix-users@...] On Behalf Of Wietse Venema
          Sent: Thursday, July 02, 2009 5:34 PM
          To: Postfix users
          Subject: Re: Maximum smtp process limit has been reached.

          Jaroslaw Grzabel:
          > Hi,
          >
          > I'm struggling with new SMTP server and I noticed that sometimes it just
          > hangs because of:
          >
          > Jul 2 14:14:21 smtp postfix/master[17716]: warning: service "smtp" (25)
          > has reached its process limit "50": new clients may experience
          > noticeable delays
          > Jul 2 14:15:06 smtp postfix/master[17716]: warning: to avoid this
          > condition, increase the process count in master.cf or reduce the service
          > time per client

          See also: http://www.postfix.org/STRESS_README.html

          Wietse
        • Noel Jones
          ... Please don t top-post. No, that default_destination_recipient_limit is unrelated; it s only used when sending mail. You need to keep increasing your
          Message 4 of 7 , Jul 2, 2009
          • 0 Attachment
            Jaroslaw Grzabel wrote:
            > Hi,
            >
            > Sorry I didn't include any information about version. My postfix version is
            > 2.3.3 installed from yum (Centos 5).
            >
            > Yeah, I read about stress mode and it looks really good. Anyway I would
            > rather want to stop reciving connection from postfix than hang the whole
            > server.
            >
            > The problem is, Noel advised me to increase default_process_limit but I've
            > already done it and later postfix hanged with the same message as below. I
            > think the parameter default_destination_recipient_limit is responsible for
            > that.

            Please don't top-post.

            No, that default_destination_recipient_limit is unrelated;
            it's only used when sending mail.

            You need to keep increasing your default_process_limit until
            it's greater than the number of connections being directed at
            your server. Postfix on modern hardware will run fine with
            far more than the default number of processes.

            So what are all these connections? Legit mail? Spam flood?
            Hanging Zombies? Klingons? That's important to know before
            you decide what to do next.

            If you're under attack from spambots/zombies that are holding
            connections open for too long, you can add
            # main.cf
            smtpd_timeout = 60s
            which is not RFC compliant, but seems to be safe for general
            use. Also see the other suggestions in the STRESS_README. In
            particular, the section
            http://www.postfix.org/STRESS_README.html#legacy
            discusses settings that will work with your version of postfix.

            But if your server is simply busy with lots of legit
            connections, this won't help. In that case you need to
            provision for the load.

            -- Noel Jones
          • Ralf Hildebrandt
            ... Yes, so activate the stress mode ... Well, so you re under attack. Activate the stress mode. Try stuff like fail2ban. ... Why? -- Ralf Hildebrandt
            Message 5 of 7 , Jul 2, 2009
            • 0 Attachment
              * Jaroslaw Grzabel <jarek@...>:
              > Hi,
              >
              > Sorry I didn't include any information about version. My postfix version is
              > 2.3.3 installed from yum (Centos 5).
              >
              > Yeah, I read about stress mode and it looks really good. Anyway I would
              > rather want to stop reciving connection from postfix than hang the whole
              > server.

              Yes, so activate the stress mode

              > The problem is, Noel advised me to increase default_process_limit but I've
              > already done it and later postfix hanged with the same message as below.

              Well, so you're under attack. Activate the stress mode. Try stuff like
              fail2ban.

              > I think the parameter default_destination_recipient_limit is
              > responsible for that.

              Why?
              --
              Ralf Hildebrandt
              Geschäftsbereich IT | Abteilung Netzwerk
              Charité - Universitätsmedizin Berlin
              Campus Benjamin Franklin
              Hindenburgdamm 30 | D-12203 Berlin
              Tel. +49 30 450 570 155 | Fax: +49 30 450 570 962
              ralf.hildebrandt@... | http://www.charite.de
            Your message has been successfully submitted and would be delivered to recipients shortly.