Loading ...
Sorry, an error occurred while loading the content.

Re: DKIM options in Postfix *SOLVED*

Expand Messages
  • Guy
    ... It certainly looks like it. ... I also needed to add an extra policy bank as given in the readme and -o content_filter=smtp-amavis:[127.0.0.1]:10026 to
    Message 1 of 1 , Jul 1 5:32 AM
    • 0 Attachment
      2009/6/30 Ralf Hildebrandt <Ralf.Hildebrandt@...>:
      > That would make sense. Some decision process in that stage to find out
      > if the mail needs to be signed...
      >
      > Maybe that kind of lookup is slow?

      It certainly looks like it.

      > I set it up according to the readme:
      >
      > dkim_key('charite.de',  'default', '/etc/ssl/private/default.private.pem');
      > $enable_dkim_verification = 1;  # enable DKIM signatures verification
      > $enable_dkim_signing = 1;    # load DKIM signing code, needs keys in dkim_key()
      >
      > That's it.

      I also needed to add an extra policy bank as given in the readme and
      "-o content_filter=smtp-amavis:[127.0.0.1]:10026" to my submission
      options. The main thing I was uncertain from was whether the default
      return port (10025) was OK instead of a completely separate route. As
      it turns out the default route works fine and signing through amavis
      works like a charm. Hasn't caused any slow down in the transaction

      Thanks for the help.
      Guy

      --
      Don't just do something...sit there!
    Your message has been successfully submitted and would be delivered to recipients shortly.