Loading ...
Sorry, an error occurred while loading the content.

Re: A few postfix issues - LDAP / anvil and sasl?

Expand Messages
  • Evan Platt
    ... Just following up (or bumping if you will) my old thread.. Still running postfix without tls, LDAP or cyrus sasl... # postconf -m btree cidr environ hash
    Message 1 of 14 , Jun 30, 2009
    • 0 Attachment
      At 06:34 PM 6/22/2009, you wrote:

      >Googling around, a few suggestions seem to be
      >make -f Makefile.init makefiles CCARGS='-DUSE_SASL_AUTH
      >-I/sw/include/sasl -DUSE_TLS -I/usr/include/openssl -DUSE_CYRUS_SASL
      >-I/usr/local/lib/sasl2 -DHAS_SSL -I/usr/local/ssl/include/openssl'
      >AUXLIBS='-L/usr/lib -lldap -L/usr/lib -llber -L/usr/lib -lsasl2 -lssl'
      >
      >I tried this, and the last few lines of make are:
      >
      >FO -DNO_KQUEUE -DHAS_PCRE -I/sw/include -g -O -I. -I../../include
      >-DMACOSX -c smtpd_resolve.c
      >cc -DUSE_SASL_AUTH -I/sw/include/sasl -DUSE_TLS
      >-I/usr/include/openssl -DUSE_CYRUS_SASL -I/usr/local/lib/sasl2
      >-DHAS_SSL -I/usr/local/ssl/include/openssl -DBIND_8_COMPAT
      >-DNO_NETINFO -DNO_KQUEUE -DHAS_PCRE -I/sw/include -g -O -I.
      >-I../../include -DMACOSX -o smtpd smtpd.o smtpd_token.o
      >smtpd_check.o smtpd_chat.o smtpd_state.o smtpd_peer.o
      >smtpd_sasl_proto.o smtpd_sasl_glue.o smtpd_proxy.o smtpd_xforward.o
      >smtpd_dsn_fix.o smtpd_milter.o smtpd_resolve.o ../../lib/libmaster.a
      >../../lib/libtls.a ../../lib/libdns.a ../../lib/libxsasl.a
      >../../lib/libmilter.a ../../lib/libglobal.a ../../lib/libutil.a
      >-L/usr/lib -lldap -L/usr/lib -llber -L/usr/lib -lsasl2 -lssl
      >-L/sw/lib -lpcre -flat_namespace
      >/usr/libexec/gcc/powerpc-apple-darwin8/4.0.1/ld: Undefined symbols:
      >_sasl_set_path
      >
      >Am I on the right path? Any suggestions?

      Just following up (or bumping if you will) my old thread.. Still
      running postfix without tls, LDAP or cyrus sasl...

      # postconf -m
      btree
      cidr
      environ
      hash
      pcre
      proxy
      regexp
      static
      tcp
      unix

      Regarding the above make command I tried.. it looks like I have the
      wrong path specified at one point? Does that sound right? If so, what
      file is Postfix looking for at each argument, and I can make sure the
      directory is correct? Or am I troubleshooting this wrong...

      Thanks.

      Evan
    • Victor Duchovni
      ... You are using header files from SASL 2.1.22 or later, which define SASL_PATH_TYPE_CONFIG, but libraries from a version of SASL that does not have
      Message 2 of 14 , Jun 30, 2009
      • 0 Attachment
        On Tue, Jun 30, 2009 at 11:36:17AM -0700, Evan Platt wrote:

        > At 06:34 PM 6/22/2009, you wrote:
        >
        >> Googling around, a few suggestions seem to be
        >> make -f Makefile.init makefiles CCARGS='-DUSE_SASL_AUTH -I/sw/include/sasl
        >> -DUSE_TLS -I/usr/include/openssl -DUSE_CYRUS_SASL -I/usr/local/lib/sasl2
        >> -DHAS_SSL -I/usr/local/ssl/include/openssl' AUXLIBS='-L/usr/lib -lldap
        >> -L/usr/lib -llber -L/usr/lib -lsasl2 -lssl'
        >>
        >> I tried this, and the last few lines of make are:
        >>
        >> FO -DNO_KQUEUE -DHAS_PCRE -I/sw/include -g -O -I. -I../../include -DMACOSX
        >> -c smtpd_resolve.c
        >> cc -DUSE_SASL_AUTH -I/sw/include/sasl -DUSE_TLS -I/usr/include/openssl
        >> -DUSE_CYRUS_SASL -I/usr/local/lib/sasl2 -DHAS_SSL
        >> -I/usr/local/ssl/include/openssl -DBIND_8_COMPAT -DNO_NETINFO -DNO_KQUEUE
        >> -DHAS_PCRE -I/sw/include -g -O -I. -I../../include -DMACOSX -o smtpd
        >> smtpd.o smtpd_token.o smtpd_check.o smtpd_chat.o smtpd_state.o
        >> smtpd_peer.o smtpd_sasl_proto.o smtpd_sasl_glue.o smtpd_proxy.o
        >> smtpd_xforward.o smtpd_dsn_fix.o smtpd_milter.o smtpd_resolve.o
        >> ../../lib/libmaster.a ../../lib/libtls.a ../../lib/libdns.a
        >> ../../lib/libxsasl.a ../../lib/libmilter.a ../../lib/libglobal.a
        >> ../../lib/libutil.a -L/usr/lib -lldap -L/usr/lib -llber -L/usr/lib -lsasl2
        >> -lssl -L/sw/lib -lpcre -flat_namespace
        >> /usr/libexec/gcc/powerpc-apple-darwin8/4.0.1/ld: Undefined symbols:
        >> _sasl_set_path
        >>
        >> Am I on the right path? Any suggestions?

        You are using header files from SASL 2.1.22 or later, which
        define SASL_PATH_TYPE_CONFIG, but libraries from a version
        of SASL that does not have "sasl_set_path()".

        Change the order of "-L/sw/lib" to put it ahead of "-lsasl2".

        --
        Viktor.

        Disclaimer: off-list followups get on-list replies or get ignored.
        Please do not ignore the "Reply-To" header.

        To unsubscribe from the postfix-users list, visit
        http://www.postfix.org/lists.html or click the link below:
        <mailto:majordomo@...?body=unsubscribe%20postfix-users>

        If my response solves your problem, the best way to thank me is to not
        send an "it worked, thanks" follow-up. If you must respond, please put
        "It worked, thanks" in the "Subject" so I can delete these quickly.
      • Brian Evans - Postfix List
        ... As http://www.postfix.org/LDAP_README.html#build says, you seem to have omitted -DHAS_LDAP and, possibly, an include location for it.
        Message 3 of 14 , Jun 30, 2009
        • 0 Attachment
          Evan Platt wrote:
          > At 06:34 PM 6/22/2009, you wrote:
          >
          >> Googling around, a few suggestions seem to be
          >> make -f Makefile.init makefiles CCARGS='-DUSE_SASL_AUTH
          >> -I/sw/include/sasl -DUSE_TLS -I/usr/include/openssl -DUSE_CYRUS_SASL
          >> -I/usr/local/lib/sasl2 -DHAS_SSL -I/usr/local/ssl/include/openssl'
          >> AUXLIBS='-L/usr/lib -lldap -L/usr/lib -llber -L/usr/lib -lsasl2 -lssl'
          >>
          >
          > Just following up (or bumping if you will) my old thread.. Still
          > running postfix without tls, LDAP or cyrus sasl...
          As http://www.postfix.org/LDAP_README.html#build says, you seem to have
          omitted -DHAS_LDAP and, possibly, an include location for it.
        • Evan Platt
          ... That s way above my head - is there an easy way to fix that? ... Am I misunderstanding? It is already? (I m assuming you mean /usr/lib? I don t have a
          Message 4 of 14 , Jun 30, 2009
          • 0 Attachment
            At 12:02 PM 6/30/2009, you wrote:

            >You are using header files from SASL 2.1.22 or later, which
            >define SASL_PATH_TYPE_CONFIG, but libraries from a version
            >of SASL that does not have "sasl_set_path()".

            That's way above my head - is there an easy way to fix that?

            >Change the order of "-L/sw/lib" to put it ahead of "-lsasl2".

            Am I misunderstanding? It is already? (I'm assuming you mean
            /usr/lib? I don't have a /sw/lib, there's the /usr/lib/ but that is
            before -lsasl2?

            make -f Makefile.init makefiles CCARGS='-DUSE_SASL_AUTH
            -I/sw/include/sasl -DUSE_TLS -I/usr/include/openssl -DUSE_CYRUS_SASL
            -I/usr/local/lib/sasl2 -DHAS_SSL -I/usr/local/ssl/include/openssl'
            AUXLIBS='-L/usr/lib -lldap -L/usr/lib -llber -L/usr/lib -lsasl2 -lssl'
          • Victor Duchovni
            ... There was an -L/sw/lib in your previous post. Where are the libraries that go with /sw/include/sasl? Put the -L/... setting for these ahead of -lsasl2 .
            Message 5 of 14 , Jun 30, 2009
            • 0 Attachment
              On Tue, Jun 30, 2009 at 02:04:07PM -0700, Evan Platt wrote:

              > At 12:02 PM 6/30/2009, you wrote:
              >
              >> You are using header files from SASL 2.1.22 or later, which
              >> define SASL_PATH_TYPE_CONFIG, but libraries from a version
              >> of SASL that does not have "sasl_set_path()".
              >
              > That's way above my head - is there an easy way to fix that?
              >
              >> Change the order of "-L/sw/lib" to put it ahead of "-lsasl2".
              >
              > Am I misunderstanding? It is already? (I'm assuming you mean /usr/lib? I
              > don't have a /sw/lib, there's the /usr/lib/ but that is before -lsasl2?
              >
              > make -f Makefile.init makefiles CCARGS='-DUSE_SASL_AUTH -I/sw/include/sasl
              > -DUSE_TLS -I/usr/include/openssl -DUSE_CYRUS_SASL -I/usr/local/lib/sasl2
              > -DHAS_SSL -I/usr/local/ssl/include/openssl' AUXLIBS='-L/usr/lib -lldap
              > -L/usr/lib -llber -L/usr/lib -lsasl2 -lssl'

              There was an -L/sw/lib in your previous post. Where are the libraries
              that go with /sw/include/sasl? Put the -L/... setting for these ahead
              of "-lsasl2".


              --
              Viktor.

              Disclaimer: off-list followups get on-list replies or get ignored.
              Please do not ignore the "Reply-To" header.

              To unsubscribe from the postfix-users list, visit
              http://www.postfix.org/lists.html or click the link below:
              <mailto:majordomo@...?body=unsubscribe%20postfix-users>

              If my response solves your problem, the best way to thank me is to not
              send an "it worked, thanks" follow-up. If you must respond, please put
              "It worked, thanks" in the "Subject" so I can delete these quickly.
            Your message has been successfully submitted and would be delivered to recipients shortly.