Loading ...
Sorry, an error occurred while loading the content.

mail forwarding is not working at all

Expand Messages
  • J. Bakshi
    Dear all, I hope you all are very well. I have come with a strange problem with my email server which is running almost 2 years now. actually I have never
    Message 1 of 3 , Jun 2, 2009
    • 0 Attachment
      Dear all,

      I hope you all are very well.

      I have come with a strange problem with my email server which is running
      almost 2 years now. actually I have never tried the mail forwarding
      with the system but it has the option. Today I need to add the mail
      forwarding feature and found that the forwarding is not working. This is
      a suse 10.2 server with postfix-2.5.1-28.5.

      I have alredy gone through the mail; mail.info; mail.err and mail.warn
      log but no error reports related to this issue.

      More details
      ---------------------

      here is the config from my main.cf for forwarding

      ``````````````````````````````
      virtual_alias_domains = hash:/etc/postfix/virtual
      virtual_alias_maps =
      mysql:/etc/postfix/mysql-virtual-alias-maps.cf,mysql:/etc/postfix/mysql-email2email.cf
      virtual_gid_maps = static:5000
      virtual_mailbox_domains =
      mysql:/etc/postfix/mysql-virtual-mailbox-domains.cf
      virtual_mailbox_maps = mysql:/etc/postfix/mysql-virtual-mailbox-maps.cf
      virtual_transport = dovecot
      dovecot_destination_recipient_limit = 1
      virtual_uid_maps = static:5000
      ``````````````````````````````````````````````````````````````````

      The mysql-virtual-alias-maps.cf and the mysql-email2email.cf has the
      mysql query with the correct database, userid/password to communicate
      the mysql. More over if I check like

      ``````````````````````
      postmap -q <email-id> mysql:/etc/postfix/mysql-virtual-alias-maps.cf
      ````````````````````````````
      then it replies back the righ alias already set for that email id.

      but still the mails received by the <email-id> and not its alias email
      address.

      Is there anything required to enable the forwarding ?

      Here is the postconf -n

      `````````````````````````````````````````
      alias_maps = hash:/etc/aliases
      biff = no
      canonical_maps = hash:/etc/postfix/canonical
      command_directory = /usr/sbin
      config_directory = /etc/postfix
      daemon_directory = /usr/lib/postfix
      data_directory = /var/lib/postfix
      debug_peer_level = 2
      disable_dns_lookups = no
      disable_mime_output_conversion = no
      html_directory = /usr/share/doc/packages/postfix/html
      inet_protocols = all
      mail_owner = postfix
      mail_spool_directory = /var/mail
      mailbox_size_limit = 0
      mailq_path = /usr/bin/mailq
      manpage_directory = /usr/share/man
      message_size_limit = 20480000
      mydestination = $myhostname, localhost.$mydomain
      mydomain = <mydomain>
      myhostname = <my hostname>
      mynetworks_style = subnet
      newaliases_path = /usr/bin/newaliases
      queue_directory = /var/spool/postfix
      readme_directory = /usr/share/doc/packages/postfix/README_FILES
      receive_override_options = no_address_mappings
      relocated_maps = hash:/etc/postfix/relocated
      sample_directory = /usr/share/doc/packages/postfix/samples
      sendmail_path = /usr/sbin/sendmail
      setgid_group = maildrop
      smtp_use_tls = yes
      smtpd_recipient_restrictions =
      permit_mynetworks,permit_sasl_authenticated,reject_unauth_destination
      smtpd_sasl_auth_enable = yes
      smtpd_sasl_path = private/auth
      smtpd_sasl_type = dovecot
      smtpd_tls_auth_only = yes
      smtpd_tls_cert_file = /etc/ssl/certs/postfix.pem
      smtpd_tls_key_file = /etc/ssl/private/postfix.pem
      smtpd_use_tls = yes
      strict_8bitmime = no
      strict_rfc821_envelopes = no
      unknown_local_recipient_reject_code = 550
      virtual_alias_domains = hash:/etc/postfix/virtual
      virtual_alias_maps =
      mysql:/etc/postfix/mysql-virtual-alias-maps.cf,mysql:/etc/postfix/mysql-email2email.cf
      virtual_gid_maps = static:5000
      virtual_mailbox_domains =
      mysql:/etc/postfix/mysql-virtual-mailbox-domains.cf
      virtual_mailbox_maps = mysql:/etc/postfix/mysql-virtual-mailbox-maps.cf
      virtual_transport = dovecot
      virtual_uid_maps = static:5000
      `````````````````````````````````````````

      with regards
    • Magnus Bäck
      ... [...] ... This explicitly disables address rewriting like aliasing. Unless you have something in your master.cf that overrides and enables rewriting, this
      Message 2 of 3 , Jun 2, 2009
      • 0 Attachment
        On Tue, June 2, 2009 11:08 am, J. Bakshi said:

        > I have come with a strange problem with my email server which is running
        > almost 2 years now. actually I have never tried the mail forwarding
        > with the system but it has the option. Today I need to add the mail
        > forwarding feature and found that the forwarding is not working. This is
        > a suse 10.2 server with postfix-2.5.1-28.5.

        [...]

        > receive_override_options = no_address_mappings

        This explicitly disables address rewriting like aliasing. Unless you have
        something in your master.cf that overrides and enables rewriting, this is
        the culprit.

        [...]

        --
        Magnus Bäck
        magnus@...
      • J. Bakshi
        ... Hello Magnus, You are a Hero !!! I have reset the setting like ````````````` receive_override_options = ```````````````` and the forwarding start working.
        Message 3 of 3 , Jun 2, 2009
        • 0 Attachment
          Magnus Bäck wrote:
          > On Tue, June 2, 2009 11:08 am, J. Bakshi said:
          >
          >
          >> I have come with a strange problem with my email server which is running
          >> almost 2 years now. actually I have never tried the mail forwarding
          >> with the system but it has the option. Today I need to add the mail
          >> forwarding feature and found that the forwarding is not working. This is
          >> a suse 10.2 server with postfix-2.5.1-28.5.
          >>
          >
          > [...]
          >
          >
          >> receive_override_options = no_address_mappings
          >>
          >
          > This explicitly disables address rewriting like aliasing. Unless you have
          > something in your master.cf that overrides and enables rewriting, this is
          > the culprit.
          >

          Hello Magnus,

          You are a Hero !!!
          I have reset the setting like

          `````````````

          receive_override_options =
          ````````````````

          and the forwarding start working.

          Millions of thanks.




          > [...]
          >
          >
        Your message has been successfully submitted and would be delivered to recipients shortly.