Loading ...
Sorry, an error occurred while loading the content.
 

Re: cant login via SSL on port 465

Expand Messages
  • admin2
    ... thanks for the quick reply. here is the relevant section of my master.cf # # Postfix master process configuration file. For details on the format # of
    Message 1 of 4 , Jun 1, 2009
      Darren Pilgrim wrote:
      > admin2 wrote:
      >> hi there list people,
      >>
      >> I am just getting used to admin'ing postfix and got TLS working on
      >> both port 25 and port 587.
      >>
      >> I am now attempting to get SSL via port 465 working. I have the port
      >> answering, can see the banner, and can even authenticate when I
      >> 'telnet localhost 465' after generating a user's test string with
      >> "perl -MMIME::Base64 -e 'print
      >> encode_base64("username\0username\0password");'"
      >
      > If you can telnet to port 465 and see the banner, then you don't have
      > SSL enabled. You probably need to set smtpd_tls_wrappermode=yes for the
      > smtps entry in master.cf. If that's already there, please show us your
      > master.cf.

      thanks for the quick reply. here is the relevant section of my master.cf

      #
      # Postfix master process configuration file. For details on the format
      # of the file, see the master(5) manual page (command: "man 5 master").
      #
      # Do not forget to execute "postfix reload" after editing this file.
      #
      # ==========================================================================
      # service type private unpriv chroot wakeup maxproc command + args
      # (yes) (yes) (yes) (never) (100)
      # ==========================================================================
      smtp inet n - - - - smtpd
      submission inet n - - - - smtpd
      # -o smtpd_tls_security_level=encrypt
      # -o smtpd_sasl_auth_enable=yes
      # -o smtpd_sasl_security_options = noanonymous
      # -o smtpd_sasl_application_name = smtpd
      # -o broken_sasl_auth_clients = yes
      # -o
      smtpd_client_restrictions=permit_sasl_authenticated,permit_mynetworks,check_relay_domains,reject
      # -o smtpd_client_restrictions=permit_sasl_authenticated,reject
      # -o milter_macro_daemon_name=ORIGINATING
      smtps inet n - - - - smtpd
      # -o smtpd_tls_wrappermode=yes
      # -o smtpd_sasl_auth_enable=yes
      # -o smtpd_sasl_security_options = noanonymous
      # -o smtpd_sasl_application_name = smtpd
      # -o broken_sasl_auth_clients = yes
      # -o
      smtpd_client_restrictions=permit_sasl_authenticated,permit_mynetworks,check_relay_domains,reject
      # -o smtpd_client_restrictions=permit_sasl_authenticated,reject
      # -o milter_macro_daemon_name=ORIGINATING
    • admin2
      ... Darren, you fixed it! the following mod to the master.cf file works fine! thank you! smtps inet n - - - - smtpd -o
      Message 2 of 4 , Jun 1, 2009
        Darren Pilgrim wrote:
        > admin2 wrote:
        >> hi there list people,
        >>
        >> I am just getting used to admin'ing postfix and got TLS working on
        >> both port 25 and port 587.
        >>
        >> I am now attempting to get SSL via port 465 working. I have the port
        >> answering, can see the banner, and can even authenticate when I
        >> 'telnet localhost 465' after generating a user's test string with
        >> "perl -MMIME::Base64 -e 'print
        >> encode_base64("username\0username\0password");'"
        >
        > If you can telnet to port 465 and see the banner, then you don't have
        > SSL enabled. You probably need to set smtpd_tls_wrappermode=yes for the
        > smtps entry in master.cf. If that's already there, please show us your
        > master.cf.

        Darren,

        you fixed it! the following mod to the master.cf file works fine!

        thank you!


        smtps inet n - - - - smtpd
        -o smtpd_tls_wrappermode=yes
      Your message has been successfully submitted and would be delivered to recipients shortly.