Loading ...
Sorry, an error occurred while loading the content.

Re: Beginner Help With Rate Limit

Expand Messages
  • Drew Tomlinson
    ... Thank you. I did try default_destination_rate_delay = 10s before but not smtp*_ as I though default would cover all. But I will try your suggestion for
    Message 1 of 5 , May 31 2:03 PM
    • 0 Attachment
      Wietse Venema wrote:
      > Drew Tomlinson:
      >
      >> I'm running Postfix 2.6 and using phplist to send a newsletter to about
      >> 200 members of my church. All the mail makes it from phplist into the
      >> postfix queue on my local machine. From my local machine, I have to
      >> relay all my mail via my ISP's server. I am able to send about 10
      >> messages from my local queue to my ISP before I start seeing errors in
      >> my maillog:
      >>
      >> status=deferred (delivery temporarily suspended: lost connection
      >>
      >> On the next queue run, another 10 messages get through before my ISP
      >> starts dropping connection again. I called my ISP and it said that as
      >> long as I sent in batches of 100 or less, there were no restrictions.
      >>
      >> I checked man 5 postconf and see options such as
      >> default_destination_recipient_limit, default_destination_rate_delay, and
      >> default_destination_concurrency_limit. All the defaults seem like they
      >> would be below my ISPs limit of 100 but I don't really understand them.
      >> I've played with the options but still have trouble.
      >>
      >> Would someone please explain them to me or kick me to a link that will?
      >> My head is just too thick. :)
      >>
      >
      > Try:
      >
      > /etc/postfix/main.cf:
      > # Changing this requires that you execute "postfix reload".
      > smtp_destination_rate_delay = 10s
      >
      > or whatever will be sufficient to not violate the ISP's acceptable
      > use policy.
      >
      > http://www.postfix.org/postconf.5.html#default_destination_rate_delay
      >

      Thank you. I did try default_destination_rate_delay = 10s before but
      not smtp*_ as I though default would cover all. But I will try your
      suggestion for next month's newsletter and see if it works for me.

      Thanks,

      Drew

      --
      Be a Great Magician!
      Visit The Alchemist's Warehouse

      http://www.alchemistswarehouse.com
    Your message has been successfully submitted and would be delivered to recipients shortly.