Loading ...
Sorry, an error occurred while loading the content.

Re: changes in tls problem

Expand Messages
  • Wietse Venema
    ... Victor s patch should work, because there is a guard in the functions that do the sender/login matching. Wietse
    Message 1 of 5 , May 28, 2009
    • 0 Attachment
      Wietse Venema:
      > Victor Duchovni:
      > > On Thu, May 28, 2009 at 04:02:37PM +0800, Norbert P. Copones wrote:
      > >
      > > > this setting is fine in 2.5 and it guarantees that smtp auth
      > > > only operates in tls. this also prevents user at my domain
      > > > from spoofing as it requires authentication.
      > > >
      > > > however, a change in 2.6 in sasl broke this setup.
      > > >
      > > > using the config above, the following warning will occur since sasl
      > > > will only activate during tls.
      > > >
      > > > warning: restriction 'reject_authenticated_sender_sender_login_mismatch'
      > > > ignored: no SASL support
      > > > warning: restriction 'reject_unauthenticated_sender_sender_login_mismatch'
      > > > ignored: no SASL support
      > > >
      > > >
      > > > my workaround for this is to disable smtpd_tls_auth_only but this
      > > > also let user authenticate in plain-text mode.
      > > >
      > > > any other workarounds?
      > >
      > > Try this patch:

      Victor's patch should work, because there is a guard in the functions
      that do the sender/login matching.

      Wietse
    Your message has been successfully submitted and would be delivered to recipients shortly.