Loading ...
Sorry, an error occurred while loading the content.
 

Re: Disable content_filter (Solved!)

Expand Messages
  • Simon Schelkshorn
    ... I have two servers with identical configuration. During debugging I found, that only one of the two servers suffers from this problem. A diff on the two
    Message 1 of 7 , May 27, 2009
      > > The problem is, that I can send mail to the listener on
      > > 192.168.xxx.xxx on port 25, but that it is passed to the
      > > postfixfilter. My question is, how can I completely turn off
      > > contentfiltering for all mail received on 192.168.xxx.xxx and why
      > > does the "-o content_filter=" option turn off contentfiltering for
      > > the listener on localhost and not for the one on 192.168.xxx.xxx?

      I have two servers with identical configuration. During debugging I
      found, that only one of the two servers suffers from this problem. A
      diff on the two main.cf revealed the cause.

      On the server with the problem the address of the 192.168.xxx.xxx
      listener was listed in the inet_interfaces. It seems that in this
      case the definition of the "smtp" listener has a higher priority.
      After removing the address from inet_interfaces everything works now
      as expected.

      BR,
      Simon
    Your message has been successfully submitted and would be delivered to recipients shortly.