Loading ...
Sorry, an error occurred while loading the content.

Re: Inbound Only postfix gateway on home network/server lab CORRECTED **

Expand Messages
  • David Denny
    ... Thanks Noel. relayhost=[i.p.add.ress] now works Cheers DD
    Message 1 of 5 , Apr 3, 2009
    • 0 Attachment
      Noel Jones wrote:
      > David Denny wrote:
      >> Noel Jones wrote:
      >>> and a transport_maps entry to help postfix find this host if it's
      >>> different from the relayhost.
      >>>
      >>> # transport
      >>> xxxxx.yyyyy relay:[ip.of.internal.host]
      >>>
      >>>
      >>> -- Noel Jones
      >>
      >> Thanks Noel. I added the relayhost and transport entries.
      >> If I mail to david@[i.p.add.ress] it reaches the internal destination.
      >> If I mail to david@... it goes out to the internet
      >> So looks like a DNS issue.
      >> I copied /etc/hosts into the chroot directory /var/spool/postfix but
      >> that had no beneficial effect.
      >> Stumped... will continue with google unless or until someone else
      >> gets here first.
      >> Cheers
      >> DD
      >>
      >
      > If postfix is trying to send to the internet directly, your relayhost
      > setting didn't take.
      > http://www.postfix.org/postconf.5.html#relayhost
      >
      > If postfix can't find where to send mail for xxxx.yyyy, likely your
      > transport_maps entry is incorrect.
      > Note the lookup key in transport is the email domain, not necessarily
      > the hostname.
      > http://www.postfix.org/postconf.5.html#transport_maps
      > http://www.postfix.org/transport.5.html
      >
      > -- Noel Jones
      Thanks Noel.
      relayhost=[i.p.add.ress]
      now works

      Cheers
      DD
    Your message has been successfully submitted and would be delivered to recipients shortly.