Loading ...
Sorry, an error occurred while loading the content.

Re: rate limit outgoing mails with mailman

Expand Messages
  • Wietse Venema
    ... Yes, so it is time that you follow instructions in the welcome message and post postconf -n output instead of one-line fragments. Wietse TO REPORT A
    Message 1 of 23 , Jan 2, 2009
    • 0 Attachment
      jason@...:
      > excellent idea, so I did install the 2.5.4 version from the backport
      > and I now have
      > root@ohs:~# grep smtp_destination_rate_delay /etc/postfix/main.cf
      > smtp_destination_rate_delay = 10
      > root@ohs:~#

      > and I restarted postfix
      > Jan 2 08:03:56 ohs postfix/master[16208]: terminating on signal 15
      > Jan 2 08:03:58 ohs postfix/master[16312]: daemon started -- version 2.5.4, configuration /etc/postfix
      >
      > and now when I send an email to my mailman mailing list, I still see it sending out emails with no delay..
      >
      > Jan 2 08:04:52 ohs postfix/smtp[16349]: 72292189FF: to=<someuser@...>, relay=outgoing.verizon.net[206.46.232.12]:25,
      > delay=5.3, delays=0.12/0.51/0.36/4.3, dsn=2.5.0, status=sent (250 2.5.0 Ok.)
      > Jan 2 08:04:52 ohs postfix/qmgr[16316]: 72292189FF: removed
      > Jan 2 08:04:52 ohs postfix/smtp[16347]: 950C118A00: to=<someuser@...>, relay=outgoing.verizon.net[206.46.232.12]:25,
      > delay=5.2, delays=0.13/0.39/0.37/4.3, dsn=2.5.0, status=sent (250 2.5.0 Ok.)
      >
      > Jan 2 08:04:52 ohs postfix/smtp[16350]: 950C118A00: to=<someuser@...>, relay=outgoing.verizon.net[206.46.232.12]:25, delay=5.3,
      > delays=0.13/0.37/0.38/4.5, dsn=2.5.0, status=sent (250 2.5.0 Ok.)
      > Jan 2 08:04:52 ohs postfix/qmgr[16316]: 950C118A00: removed
      >
      > so it looks like all three of these went out with no delays inbetween each message, right?

      Yes, so it is time that you follow instructions in the welcome message
      and post "postconf -n" output instead of one-line fragments.

      Wietse

      TO REPORT A PROBLEM see http://www.postfix.org/DEBUG_README.html#mail

      TO (UN)SUBSCRIBE see http://www.postfix.org/lists.html

      Thank you for using Postfix.
    • Jason Welsh
      my apologies.. here is the output of postconf -n alias_database = hash:/etc/aliases alias_maps = hash:/etc/aliases append_dot_mydomain = no biff = no
      Message 2 of 23 , Jan 2, 2009
      • 0 Attachment
        my apologies.. here is the output of postconf -n


        alias_database = hash:/etc/aliases
        alias_maps = hash:/etc/aliases
        append_dot_mydomain = no
        biff = no
        config_directory = /etc/postfix
        default_destination_concurrency_limit = 1
        default_destination_recipient_limit = 1
        default_transport = smtp
        home_mailbox = Maildir/
        inet_interfaces = all
        initial_destination_concurrency = 1
        mailbox_size_limit = 0
        mydestination = orientalhealthsolutions.com, ohs.com,
        localhost.localdomain, localhost
        myhostname = ohs
        mynetworks = 127.0.0.0/8 192.168.1.5/32
        myorigin = /etc/mailname
        recipient_delimiter = +
        relayhost = outgoing.verizon.net
        smtp_destination_concurrency_limit = 1
        smtp_sasl_auth_enable = yes
        smtp_sasl_password_maps = hash:/etc/postfix/sasl/sasl_passwd
        smtp_sasl_security_options =
        smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache
        smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
        smtpd_recipient_limit = 1
        smtpd_tls_cert_file = /etc/ssl/certs/ssl-cert-snakeoil.pem
        smtpd_tls_key_file = /etc/ssl/private/ssl-cert-snakeoil.key
        smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
        smtpd_use_tls = yes


        and yes Victor, I tied with and without the processes set to 1..
        smtp inet n - - - 1 smtpd -D
        ^^^
        in master.cf is the correct way, right?

        regards,
        Jason




        Wietse Venema wrote:
        > jason@...:
        >
        >> excellent idea, so I did install the 2.5.4 version from the backport
        >> and I now have
        >> root@ohs:~# grep smtp_destination_rate_delay /etc/postfix/main.cf
        >> smtp_destination_rate_delay = 10
        >> root@ohs:~#
        >>
        >
        >
        >> and I restarted postfix
        >> Jan 2 08:03:56 ohs postfix/master[16208]: terminating on signal 15
        >> Jan 2 08:03:58 ohs postfix/master[16312]: daemon started -- version 2.5.4, configuration /etc/postfix
        >>
        >> and now when I send an email to my mailman mailing list, I still see it sending out emails with no delay..
        >>
        >> Jan 2 08:04:52 ohs postfix/smtp[16349]: 72292189FF: to=<someuser@...>, relay=outgoing.verizon.net[206.46.232.12]:25,
        >> delay=5.3, delays=0.12/0.51/0.36/4.3, dsn=2.5.0, status=sent (250 2.5.0 Ok.)
        >> Jan 2 08:04:52 ohs postfix/qmgr[16316]: 72292189FF: removed
        >> Jan 2 08:04:52 ohs postfix/smtp[16347]: 950C118A00: to=<someuser@...>, relay=outgoing.verizon.net[206.46.232.12]:25,
        >> delay=5.2, delays=0.13/0.39/0.37/4.3, dsn=2.5.0, status=sent (250 2.5.0 Ok.)
        >>
        >> Jan 2 08:04:52 ohs postfix/smtp[16350]: 950C118A00: to=<someuser@...>, relay=outgoing.verizon.net[206.46.232.12]:25, delay=5.3,
        >> delays=0.13/0.37/0.38/4.5, dsn=2.5.0, status=sent (250 2.5.0 Ok.)
        >> Jan 2 08:04:52 ohs postfix/qmgr[16316]: 950C118A00: removed
        >>
        >> so it looks like all three of these went out with no delays inbetween each message, right?
        >>
        >
        > Yes, so it is time that you follow instructions in the welcome message
        > and post "postconf -n" output instead of one-line fragments.
        >
        > Wietse
        >
        > TO REPORT A PROBLEM see http://www.postfix.org/DEBUG_README.html#mail
        >
        > TO (UN)SUBSCRIBE see http://www.postfix.org/lists.html
        >
        > Thank you for using Postfix.
        >

        --
        ================================================
        | Jason Welsh jason@... |
        | http://monsterjam.org DSS PGP: 0x5E30CC98 |
        | gpg key: http://monsterjam.org/gpg/ |
        ================================================
      • Victor Duchovni
        ... Point shotgun away from foot. -- Viktor. Disclaimer: off-list followups get on-list replies or get ignored. Please do not ignore the Reply-To header. To
        Message 3 of 23 , Jan 2, 2009
        • 0 Attachment
          On Fri, Jan 02, 2009 at 03:43:15PM -0500, Jason Welsh wrote:

          > initial_destination_concurrency = 1
          > default_destination_concurrency_limit = 1
          > default_destination_recipient_limit = 1
          > smtpd_recipient_limit = 1

          Point shotgun away from foot.

          --
          Viktor.

          Disclaimer: off-list followups get on-list replies or get ignored.
          Please do not ignore the "Reply-To" header.

          To unsubscribe from the postfix-users list, visit
          http://www.postfix.org/lists.html or click the link below:
          <mailto:majordomo@...?body=unsubscribe%20postfix-users>

          If my response solves your problem, the best way to thank me is to not
          send an "it worked, thanks" follow-up. If you must respond, please put
          "It worked, thanks" in the "Subject" so I can delete these quickly.
        • jason@monsterjam.org
          yes, and I also realized I had commented out the item that Wietse had wanted me to put in.. Im just trying too many things at once.. Let me clean it up and try
          Message 4 of 23 , Jan 2, 2009
          • 0 Attachment
            yes, and I also realized I had commented out the item that Wietse had wanted me to put in..
            Im just trying too many things at once.. Let me clean it up and try again.

            Jason


            On Fri, Jan 02, 2009 at 03:54:21PM -0500,
            Victor Duchovni wrote:
            > On Fri, Jan 02, 2009 at 03:43:15PM -0500, Jason Welsh wrote:
            >
            > > initial_destination_concurrency = 1
            > > default_destination_concurrency_limit = 1
            > > default_destination_recipient_limit = 1
            > > smtpd_recipient_limit = 1
            >
            > Point shotgun away from foot.
            >
            > --
            > Viktor.
            >
            > Disclaimer: off-list followups get on-list replies or get ignored.
            > Please do not ignore the "Reply-To" header.
            >
            > To unsubscribe from the postfix-users list, visit
            > http://www.postfix.org/lists.html or click the link below:
            > <mailto:majordomo@...?body=unsubscribe%20postfix-users>
            >
            > If my response solves your problem, the best way to thank me is to not
            > send an "it worked, thanks" follow-up. If you must respond, please put
            > "It worked, thanks" in the "Subject" so I can delete these quickly.

            --
            ================================================
            | Jason Welsh jason@... |
            | http://monsterjam.org DSS PGP: 0x5E30CC98 |
            | gpg key: http://monsterjam.org/gpg/ |
            ================================================
          • Wietse Venema
            ... Did you notice that there is no smtp_destination_rate_delay Wietse
            Message 5 of 23 , Jan 2, 2009
            • 0 Attachment
              Jason Welsh:
              > my apologies.. here is the output of postconf -n

              Did you notice that there is no smtp_destination_rate_delay

              Wietse
            • jason@monsterjam.org
              ... ok, here is my latest config.. alias_database = hash:/etc/aliases alias_maps = hash:/etc/aliases append_dot_mydomain = no biff = no config_directory =
              Message 6 of 23 , Jan 2, 2009
              • 0 Attachment
                On Fri, Jan 02, 2009 at 03:54:21PM -0500, Victor Duchovni wrote:
                > On Fri, Jan 02, 2009 at 03:43:15PM -0500, Jason Welsh wrote:
                >
                > > initial_destination_concurrency = 1
                > > default_destination_concurrency_limit = 1
                > > default_destination_recipient_limit = 1
                > > smtpd_recipient_limit = 1
                >
                > Point shotgun away from foot.
                >
                > --
                > Viktor.

                ok, here is my latest config..

                alias_database = hash:/etc/aliases
                alias_maps = hash:/etc/aliases
                append_dot_mydomain = no
                biff = no
                config_directory = /etc/postfix
                default_transport = smtp
                home_mailbox = Maildir/
                inet_interfaces = all
                mailbox_size_limit = 0
                mydestination = orientalhealthsolutions.com, ohs.com, localhost.localdomain, localhost
                myhostname = ohs
                mynetworks = 127.0.0.0/8 192.168.1.5/32
                myorigin = /etc/mailname
                recipient_delimiter = +
                relay_destination_rate_delay = 10
                relayhost = outgoing.verizon.net
                smtp_destination_rate_delay = 10
                smtp_sasl_auth_enable = yes
                smtp_sasl_password_maps = hash:/etc/postfix/sasl/sasl_passwd
                smtp_sasl_security_options =
                smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache
                smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
                smtpd_tls_cert_file = /etc/ssl/certs/ssl-cert-snakeoil.pem
                smtpd_tls_key_file = /etc/ssl/private/ssl-cert-snakeoil.key
                smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
                smtpd_use_tls = yes


                and heres my logs now

                Jan 2 16:04:57 ohs postfix/smtp[18389]: B08B018A00: to=<someuser@...>, relay=outgoing.verizon.net[206.46.232.12]:25,
                delay=0.89, delays=0.08/0.28/0.35/0.17, dsn=2.5.0, status=sent (250 2.5.0 Ok.)
                Jan 2 16:04:57 ohs postfix/qmgr[18371]: B08B018A00: removed
                Jan 2 16:05:12 ohs postfix/smtp[18389]: E50B018A02: to=<someuser@...>, relay=outgoing.verizon.net[206.46.232.12]:25, delay=15,
                delays=0.24/11/0.34/4.4, dsn=2.5.0, status=sent (250 2.5.0 Ok.)
                Jan 2 16:05:12 ohs postfix/smtp[18389]: E50B018A02: to=<someuser@...>, relay=outgoing.verizon.net[206.46.232.12]:25, delay=15,
                delays=0.24/11/0.34/4.4, dsn=2.5.0, status=sent (250 2.5.0 Ok.)
                Jan 2 16:05:12 ohs postfix/qmgr[18371]: E50B018A02: removed

                so there WAS a delay after the first one, but the second two seemed to go out together..
                so we are making progress.. i think.. ;)

                Jason
              • Wietse Venema
                ... The second message has TWO RECIPIENTS. Postfix inserts 10s delay between MESSAGE deliveries not RECIPIENTS. Wieste
                Message 7 of 23 , Jan 2, 2009
                • 0 Attachment
                  > Jan 2 16:04:57 ohs postfix/smtp[18389]: B08B018A00: to=<someuser@...>, relay=outgoing.verizon.net[206.46.232.12]:25,
                  > delay=0.89, delays=0.08/0.28/0.35/0.17, dsn=2.5.0, status=sent (250 2.5.0 Ok.)
                  > Jan 2 16:04:57 ohs postfix/qmgr[18371]: B08B018A00: removed
                  > Jan 2 16:05:12 ohs postfix/smtp[18389]: E50B018A02: to=<someuser@...>, relay=outgoing.verizon.net[206.46.232.12]:25, delay=15,
                  > delays=0.24/11/0.34/4.4, dsn=2.5.0, status=sent (250 2.5.0 Ok.)
                  > Jan 2 16:05:12 ohs postfix/smtp[18389]: E50B018A02: to=<someuser@...>, relay=outgoing.verizon.net[206.46.232.12]:25, delay=15,
                  > delays=0.24/11/0.34/4.4, dsn=2.5.0, status=sent (250 2.5.0 Ok.)
                  > Jan 2 16:05:12 ohs postfix/qmgr[18371]: E50B018A02: removed
                  >
                  > so there WAS a delay after the first one, but the second two seemed to go out together..
                  > so we are making progress.. i think.. ;)

                  The second message has TWO RECIPIENTS.

                  Postfix inserts 10s delay between MESSAGE deliveries not RECIPIENTS.

                  Wieste
                • Victor Duchovni
                  ... That s two recipients in a *single* delivery. Is there a problem with that? Postfix is correctly adding delays between message deliveries. -- Viktor.
                  Message 8 of 23 , Jan 2, 2009
                  • 0 Attachment
                    On Fri, Jan 02, 2009 at 04:08:09PM -0500, jason@... wrote:

                    > and heres my logs now
                    >
                    > Jan 2 16:04:57 ohs postfix/smtp[18389]: B08B018A00: to=<someuser@...>, relay=outgoing.verizon.net[206.46.232.12]:25,
                    > delay=0.89, delays=0.08/0.28/0.35/0.17, dsn=2.5.0, status=sent (250 2.5.0 Ok.)
                    > Jan 2 16:04:57 ohs postfix/qmgr[18371]: B08B018A00: removed
                    > Jan 2 16:05:12 ohs postfix/smtp[18389]: E50B018A02: to=<someuser@...>, relay=outgoing.verizon.net[206.46.232.12]:25, delay=15,
                    > delays=0.24/11/0.34/4.4, dsn=2.5.0, status=sent (250 2.5.0 Ok.)
                    > Jan 2 16:05:12 ohs postfix/smtp[18389]: E50B018A02: to=<someuser@...>, relay=outgoing.verizon.net[206.46.232.12]:25, delay=15,
                    > delays=0.24/11/0.34/4.4, dsn=2.5.0, status=sent (250 2.5.0 Ok.)
                    > Jan 2 16:05:12 ohs postfix/qmgr[18371]: E50B018A02: removed
                    >
                    > so there WAS a delay after the first one, but the second two seemed
                    > to go out together.. so we are making progress.. i think.. ;)

                    That's two recipients in a *single* delivery. Is there a problem with
                    that? Postfix is correctly adding delays between message deliveries.

                    --
                    Viktor.

                    Disclaimer: off-list followups get on-list replies or get ignored.
                    Please do not ignore the "Reply-To" header.

                    To unsubscribe from the postfix-users list, visit
                    http://www.postfix.org/lists.html or click the link below:
                    <mailto:majordomo@...?body=unsubscribe%20postfix-users>

                    If my response solves your problem, the best way to thank me is to not
                    send an "it worked, thanks" follow-up. If you must respond, please put
                    "It worked, thanks" in the "Subject" so I can delete these quickly.
                  • Jason Welsh
                    ... well, right, like I said, this is from a mailman mailing list , and there are 3 remote recipients in the list. But in the real list I want to implement,
                    Message 9 of 23 , Jan 2, 2009
                    • 0 Attachment
                      Wietse Venema wrote:
                      >> Jan 2 16:04:57 ohs postfix/smtp[18389]: B08B018A00: to=<someuser@...>, relay=outgoing.verizon.net[206.46.232.12]:25,
                      >> delay=0.89, delays=0.08/0.28/0.35/0.17, dsn=2.5.0, status=sent (250 2.5.0 Ok.)
                      >> Jan 2 16:04:57 ohs postfix/qmgr[18371]: B08B018A00: removed
                      >> Jan 2 16:05:12 ohs postfix/smtp[18389]: E50B018A02: to=<someuser@...>, relay=outgoing.verizon.net[206.46.232.12]:25, delay=15,
                      >> delays=0.24/11/0.34/4.4, dsn=2.5.0, status=sent (250 2.5.0 Ok.)
                      >> Jan 2 16:05:12 ohs postfix/smtp[18389]: E50B018A02: to=<someuser@...>, relay=outgoing.verizon.net[206.46.232.12]:25, delay=15,
                      >> delays=0.24/11/0.34/4.4, dsn=2.5.0, status=sent (250 2.5.0 Ok.)
                      >> Jan 2 16:05:12 ohs postfix/qmgr[18371]: E50B018A02: removed
                      >>
                      >> so there WAS a delay after the first one, but the second two seemed to go out together..
                      >> so we are making progress.. i think.. ;)
                      >>
                      >
                      > The second message has TWO RECIPIENTS.
                      >
                      > Postfix inserts 10s delay between MESSAGE deliveries not RECIPIENTS.
                      >
                      > Wieste
                      >
                      well, right, like I said, this is from a mailman mailing list , and
                      there are 3 remote recipients in the list. But in the real list I want
                      to implement, there are hundreds at various addresses and I would like
                      to throttle ALL outgoing deliveries if I can. I guess best case scenario
                      now is to serialize the delivery process somehow.

                      thanks/regards,
                      Jason

                      --
                      ================================================
                      | Jason Welsh jason@... |
                      | http://monsterjam.org DSS PGP: 0x5E30CC98 |
                      | gpg key: http://monsterjam.org/gpg/ |
                      ================================================
                    • Victor Duchovni
                      ... Postfix will send 50 recipients at a time by default. Does the ISP mandate a lower number of recipients per message? Sending more messages with fewer
                      Message 10 of 23 , Jan 2, 2009
                      • 0 Attachment
                        On Fri, Jan 02, 2009 at 04:16:26PM -0500, Jason Welsh wrote:

                        >
                        >
                        > Wietse Venema wrote:
                        > >>Jan 2 16:04:57 ohs postfix/smtp[18389]: B08B018A00:
                        > >>to=<someuser@...>,
                        > >>relay=outgoing.verizon.net[206.46.232.12]:25, delay=0.89,
                        > >>delays=0.08/0.28/0.35/0.17, dsn=2.5.0, status=sent (250 2.5.0 Ok.)
                        > >>Jan 2 16:04:57 ohs postfix/qmgr[18371]: B08B018A00: removed
                        > >>Jan 2 16:05:12 ohs postfix/smtp[18389]: E50B018A02:
                        > >>to=<someuser@...>, relay=outgoing.verizon.net[206.46.232.12]:25,
                        > >>delay=15, delays=0.24/11/0.34/4.4, dsn=2.5.0, status=sent (250 2.5.0 Ok.)
                        > >>Jan 2 16:05:12 ohs postfix/smtp[18389]: E50B018A02:
                        > >>to=<someuser@...>, relay=outgoing.verizon.net[206.46.232.12]:25,
                        > >>delay=15, delays=0.24/11/0.34/4.4, dsn=2.5.0, status=sent (250 2.5.0 Ok.)
                        > >>Jan 2 16:05:12 ohs postfix/qmgr[18371]: E50B018A02: removed
                        > >>
                        > >>so there WAS a delay after the first one, but the second two seemed to go
                        > >>out together..
                        > >>so we are making progress.. i think.. ;)
                        > >>
                        > >
                        > >The second message has TWO RECIPIENTS.
                        > >
                        > >Postfix inserts 10s delay between MESSAGE deliveries not RECIPIENTS.
                        >
                        > well, right, like I said, this is from a mailman mailing list , and
                        > there are 3 remote recipients in the list. But in the real list I want
                        > to implement, there are hundreds at various addresses and I would like
                        > to throttle ALL outgoing deliveries if I can. I guess best case scenario
                        > now is to serialize the delivery process somehow.

                        Postfix will send 50 recipients at a time by default. Does the ISP
                        mandate a lower number of recipients per message? Sending more messages
                        with fewer recipients each is certainly not helpful to the ISP. Whatever
                        you set the smtp_destination_recipient_limit to, don't make it 1.

                        If you really want to get one recipient per message, consider using VERP,
                        a good idea with lists anyway.

                        --
                        Viktor.

                        Disclaimer: off-list followups get on-list replies or get ignored.
                        Please do not ignore the "Reply-To" header.

                        To unsubscribe from the postfix-users list, visit
                        http://www.postfix.org/lists.html or click the link below:
                        <mailto:majordomo@...?body=unsubscribe%20postfix-users>

                        If my response solves your problem, the best way to thank me is to not
                        send an "it worked, thanks" follow-up. If you must respond, please put
                        "It worked, thanks" in the "Subject" so I can delete these quickly.
                      • Jason Welsh
                        ... I looked it up and here is the real scoop.. ;) *You may not include more than 100 recipients in a single email. Messages will not be sent to any recipients
                        Message 11 of 23 , Jan 2, 2009
                        • 0 Attachment
                          >> well, right, like I said, this is from a mailman mailing list , and
                          >> there are 3 remote recipients in the list. But in the real list I want
                          >> to implement, there are hundreds at various addresses and I would like
                          >> to throttle ALL outgoing deliveries if I can. I guess best case scenario
                          >> now is to serialize the delivery process somehow.
                          >>
                          >
                          > Postfix will send 50 recipients at a time by default. Does the ISP
                          > mandate a lower number of recipients per message? Sending more messages
                          > with fewer recipients each is certainly not helpful to the ISP. Whatever
                          > you set the smtp_destination_recipient_limit to, don't make it 1.
                          >
                          > If you really want to get one recipient per message, consider using VERP,
                          > a good idea with lists anyway.
                          >
                          >
                          I looked it up and here is the real scoop.. ;)

                          *You may not include more than 100 recipients in a single email. Messages will not
                          be sent to any recipients in excess of 100.
                          *You may not exceed 500 recipients in 1 hour. Exceeding 500 recipients in 1 hour
                          will result in the suspension of your ability to send email for 24 hours.

                          so If I use the following:
                          smtp_destination_recipient_limit = 8
                          smtp_destination_rate_delay = 60

                          this means that only 480 messages will get relayed in one hour, right?


                          thanks/regards,

                          Jason
                        • Victor Duchovni
                          ... No, it means up to 60 messages an hour with up to 8 recipients each. Using this ISP for bulk mailing is a really poor infrastructure choice. If you can t
                          Message 12 of 23 , Jan 2, 2009
                          • 0 Attachment
                            On Fri, Jan 02, 2009 at 04:53:23PM -0500, Jason Welsh wrote:

                            > I looked it up and here is the real scoop.. ;)
                            >
                            > *You may not include more than 100 recipients in a single email. Messages
                            > will not
                            > be sent to any recipients in excess of 100.
                            > *You may not exceed 500 recipients in 1 hour. Exceeding 500 recipients in 1
                            > hour
                            > will result in the suspension of your ability to send email for 24 hours.
                            >
                            > so If I use the following:
                            > smtp_destination_recipient_limit = 8
                            > smtp_destination_rate_delay = 60
                            >
                            > this means that only 480 messages will get relayed in one hour, right?

                            No, it means up to 60 messages an hour with up to 8 recipients each.

                            Using this ISP for bulk mailing is a really poor infrastructure choice.

                            If you can't make better choices, you may be better off with VERP
                            (resulting in 1 recipient per message), and at most 450 messages per
                            hour via a rate delay of 8 seconds per message. With VERP you can also
                            determine, in a lot more cases, which recipient is causing persistent
                            bounces and must be removed from your list.

                            --
                            Viktor.

                            Disclaimer: off-list followups get on-list replies or get ignored.
                            Please do not ignore the "Reply-To" header.

                            To unsubscribe from the postfix-users list, visit
                            http://www.postfix.org/lists.html or click the link below:
                            <mailto:majordomo@...?body=unsubscribe%20postfix-users>

                            If my response solves your problem, the best way to thank me is to not
                            send an "it worked, thanks" follow-up. If you must respond, please put
                            "It worked, thanks" in the "Subject" so I can delete these quickly.
                          • jason@monsterjam.org
                            please see inline ... but this still keeps me within the limits that verizon has set, right? ... wasnt my choice, it was my client s ... fair enough, Ill look
                            Message 13 of 23 , Jan 2, 2009
                            • 0 Attachment
                              please see inline

                              >
                              > No, it means up to 60 messages an hour with up to 8 recipients each.
                              but this still keeps me within the limits that verizon has set, right?

                              >
                              > Using this ISP for bulk mailing is a really poor infrastructure choice.
                              wasnt my choice, it was my client's

                              >
                              > If you can't make better choices, you may be better off with VERP
                              > (resulting in 1 recipient per message), and at most 450 messages per
                              > hour via a rate delay of 8 seconds per message. With VERP you can also
                              > determine, in a lot more cases, which recipient is causing persistent
                              > bounces and must be removed from your list.
                              fair enough, Ill look into it.

                              thanks for your patience and help!

                              Jason
                            • jason@monsterjam.org
                              ... I tested and it looks like these settings will do what I want. thanks folks. Jason
                              Message 14 of 23 , Jan 2, 2009
                              • 0 Attachment
                                > > so If I use the following:
                                > > smtp_destination_recipient_limit = 8
                                > > smtp_destination_rate_delay = 60
                                I tested and it looks like these settings will do what I want.

                                thanks folks.

                                Jason
                              Your message has been successfully submitted and would be delivered to recipients shortly.