Loading ...
Sorry, an error occurred while loading the content.
 

Re: Stupidly simple problem...

Expand Messages
  • Kurt Buff
    ... Which is odd, because I had the lines sendmail_enable= NO sendmail_submit_enable= NO sendmail_outbound_enable= NO sendmail_msp_queue_enable= NO in
    Message 1 of 10 , Sep 25, 2008
      On Thu, Sep 25, 2008 at 3:43 PM, Duane Hill <d.hill@...> wrote:
      > On Thu, 25 Sep 2008, Kurt Buff wrote:
      >
      >> On Thu, Sep 25, 2008 at 11:04 AM, mouss <mouss@...> wrote:
      >>>
      >>> Victor Duchovni wrote:
      >>>>
      >>>> On Thu, Sep 25, 2008 at 12:55:44PM -0400, Jorey Bump wrote:
      >>>>
      >>>>>> mydestination =
      >>>>>> mydomain = example.com
      >>>>>> myhostname = loki.example.com
      >>>>>
      >>>>> Try:
      >>>>>
      >>>>> mydestination = $myhostname, localhost
      >>>>
      >>>> Note, with the default setting "append_dot_mydomain = yes", mail to
      >>>> "user@localhost" becomes "user@localhost.$mydomain", so the right name
      >>>> to include in mydestination is "localhost.$mydomain":
      >>>>
      >>>> mydestination = $myhostname, localhost.$mydomain, localhost
      >>>>
      >>>> the final "localhost" is there "just in case", the real work is done by
      >>>> localhost.$mydomain.
      >>>>
      >>>
      >>> freebsd cron jobs don't set a domain, so he only has to deal with
      >>> @$myorigin. but he must first replace Sendmail with postfix.
      >>>
      >>> and he'd better set the relay host to the mail server.
      >>
      >> I don't believe sendmail was ever installed - IIRC, I selected to
      >> install with no MTA.
      >
      > Clearly your logs below demonstrate sendmail is still running. To totally
      > disable sendmail and its periodic cron jobs, see the contents of:
      >
      > /usr/ports/mail/postfix/pkg-message
      >
      > It tells you what needs to be done.
      >
      > Noel's already pointed out what log lines are Postfix and which is sendmail
      > in his recent response.

      Which is odd, because I had the lines

      sendmail_enable="NO"
      sendmail_submit_enable="NO"
      sendmail_outbound_enable="NO"
      sendmail_msp_queue_enable="NO"

      in /etc/rc.conf.

      Sigh.

      # pkg_delete postfix-2.4.6,1 (why? because I can't remember where
      sendmail stashes itself.)
      # rm /usr/sbin/sendmail
      # rm -rf /usr/libexec/sendmail
      # rm /etc/rc.d/sendmail
      # pkg_add -r postfix
      # ln /usr/local/sbin/sendmail /usr/sbin/sendmail
      # postfix start

      All is now good.

      It's so much fun being stupid in front of so many people.

      Thanks all.
    Your message has been successfully submitted and would be delivered to recipients shortly.