Loading ...
Sorry, an error occurred while loading the content.

lmtp port in 2.1.5 vs 2.3.8

Expand Messages
  • Rudy Gevaert
    Hi, Previously we were running postfix 2.1.5 (Debian Sarge) and now have upgraded to 2.3.8 (Etch). We have several lmtp transports in master.cf: mail1 unix
    Message 1 of 3 , Aug 5, 2008
    • 0 Attachment
      Hi,

      Previously we were running postfix 2.1.5 (Debian Sarge) and now have
      upgraded to 2.3.8 (Etch).

      We have several lmtp transports in master.cf:

      mail1 unix - - n - - lmtp
      mail2 unix - - n - - lmtp
      mail3 unix - - n - - lmtp

      We used an ldap directory to route to the correct backend:
      umTransport: mail1:mail1.ugent.be

      In postfix 2.1.5 the destination port of our lmtp connections was *by
      default* 2003. Because we had the following entry in /etc/services:
      lmtp 2003/tcp

      When I did the upgrade to 2.3.8 I noticed that was not the case anymore.
      It connected to an other port (I can't remember what anymore).

      I tried changing lmtp_tcp_port to 2003 but that didn't help. In the end
      I changed the result attribute of my ldap lookup to add the port number
      to the transport:
      result_format = %s:2003

      I was wondering why this was changed, or did I miss something?

      Thanks in advance,
      --
      -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
      Rudy Gevaert Rudy.Gevaert@... tel:+32 9 264 4734
      Directie ICT, afd. Infrastructuur ICT Department, Infrastructure office
      Groep Systemen Systems group
      Universiteit Gent Ghent University
      Krijgslaan 281, gebouw S9, 9000 Gent, Belgie www.UGent.be
      -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
    • Wietse Venema
      ... No, the built-in default LMTP TCP port was 24. However the precedence has changed. With 2.1.5, Postfix would use lmtp_tcp_port only if /etc/services had no
      Message 2 of 3 , Aug 5, 2008
      • 0 Attachment
        Rudy Gevaert:
        > Hi,
        >
        > Previously we were running postfix 2.1.5 (Debian Sarge) and now have
        > upgraded to 2.3.8 (Etch).
        >
        > We have several lmtp transports in master.cf:
        >
        > mail1 unix - - n - - lmtp
        > mail2 unix - - n - - lmtp
        > mail3 unix - - n - - lmtp
        >
        > We used an ldap directory to route to the correct backend:
        > umTransport: mail1:mail1.ugent.be
        >
        > In postfix 2.1.5 the destination port of our lmtp connections was *by
        > default* 2003.

        No, the built-in default LMTP TCP port was 24. However the precedence
        has changed. With 2.1.5, Postfix would use lmtp_tcp_port only if
        /etc/services had no entry for LMTP.

        > Because we had the following entry in /etc/services:
        > lmtp 2003/tcp
        >
        > When I did the upgrade to 2.3.8 I noticed that was not the case anymore.
        > It connected to an other port (I can't remember what anymore).

        The built-in default LMTP TCP port is still 24. However the precedence
        has changed. The lmtp_tcp_port parameter now overrides /etc/services.
        If you want to use /etc/services, you now need to specify:

        lmtp_tcp_port = lmtp

        > I tried changing lmtp_tcp_port to 2003 but that didn't help.

        You mis-typed something.

        I think the best way out is to drop support for lmtp_tcp_port,
        for consistency with SMTP.

        Wietse

        > In the end
        > I changed the result attribute of my ldap lookup to add the port number
        > to the transport:
        > result_format = %s:2003
        >
        > I was wondering why this was changed, or did I miss something?
        >
        > Thanks in advance,
        > --
        > -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
        > Rudy Gevaert Rudy.Gevaert@... tel:+32 9 264 4734
        > Directie ICT, afd. Infrastructuur ICT Department, Infrastructure office
        > Groep Systemen Systems group
        > Universiteit Gent Ghent University
        > Krijgslaan 281, gebouw S9, 9000 Gent, Belgie www.UGent.be
        > -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
        >
        >
      • Rudy Gevaert
        ... Ok, that clarifies it. ... You are probably right. It checked it again and that works. ... Thank you for your help. -- -- -- -- -- -- -- -- -- -- -- -- --
        Message 3 of 3 , Aug 6, 2008
        • 0 Attachment
          Wietse Venema wrote:
          > Rudy Gevaert:
          >> Hi,
          >>
          >> Previously we were running postfix 2.1.5 (Debian Sarge) and now have
          >> upgraded to 2.3.8 (Etch).
          >>
          >> We have several lmtp transports in master.cf:
          >>
          >> mail1 unix - - n - - lmtp
          >> mail2 unix - - n - - lmtp
          >> mail3 unix - - n - - lmtp
          >>
          >> We used an ldap directory to route to the correct backend:
          >> umTransport: mail1:mail1.ugent.be
          >>
          >> In postfix 2.1.5 the destination port of our lmtp connections was *by
          >> default* 2003.
          >
          > No, the built-in default LMTP TCP port was 24. However the precedence
          > has changed. With 2.1.5, Postfix would use lmtp_tcp_port only if
          > /etc/services had no entry for LMTP.

          Ok, that clarifies it.

          >> Because we had the following entry in /etc/services:
          >> lmtp 2003/tcp
          >>
          >> When I did the upgrade to 2.3.8 I noticed that was not the case anymore.
          >> It connected to an other port (I can't remember what anymore).
          >
          > The built-in default LMTP TCP port is still 24. However the precedence
          > has changed. The lmtp_tcp_port parameter now overrides /etc/services.
          > If you want to use /etc/services, you now need to specify:
          >
          > lmtp_tcp_port = lmtp
          >
          >> I tried changing lmtp_tcp_port to 2003 but that didn't help.
          >
          > You mis-typed something.

          You are probably right. It checked it again and that works.

          > I think the best way out is to drop support for lmtp_tcp_port,
          > for consistency with SMTP.

          Thank you for your help.



          --
          -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
          Rudy Gevaert Rudy.Gevaert@... tel:+32 9 264 4734
          Directie ICT, afd. Infrastructuur ICT Department, Infrastructure office
          Groep Systemen Systems group
          Universiteit Gent Ghent University
          Krijgslaan 281, gebouw S9, 9000 Gent, Belgie www.UGent.be
          -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
        Your message has been successfully submitted and would be delivered to recipients shortly.