Loading ...
Sorry, an error occurred while loading the content.

fatal: no login name found for user ID

Expand Messages
  • oxy
    hi! i have the following problem: my apache vhost users are virtual and only got UID (10000...10500) when a vhost tries to send a mail via php mail() postfix
    Message 1 of 11 , Jul 1, 2008
    • 0 Attachment
      hi!

      i have the following problem:
      my apache vhost users are virtual and only got UID (10000...10500)
      when a vhost tries to send a mail via php mail() postfix says:
      fatal: no login name found for user ID
      is there any solution? it's ok for me to disable that check in postfix
      and every non existent user could send message from localhost..
      or should is rewrite the sender (i prefer the first one, if it's possible)
      if the rewrite is the only solution how can i do that?

      thanks for your help, all!
      Csaba Banhalmi
    • Wietse Venema
      ... Specify the sender address on the command line with: /usr/sbin/sendmail -f user@example.com recipient... Wietse
      Message 2 of 11 , Jul 1, 2008
      • 0 Attachment
        oxy:
        > hi!
        >
        > i have the following problem:
        > my apache vhost users are virtual and only got UID (10000...10500)
        > when a vhost tries to send a mail via php mail() postfix says:
        > fatal: no login name found for user ID
        > is there any solution?

        Specify the sender address on the command line with:

        /usr/sbin/sendmail -f user@... recipient...

        Wietse

        > it's ok for me to disable that check in postfix
        > and every non existent user could send message from localhost..
        > or should is rewrite the sender (i prefer the first one, if it's possible)
        > if the rewrite is the only solution how can i do that?
        >
        > thanks for your help, all!
        > Csaba Banhalmi
        >
        >
      • oxy
        i think it s not possible.. the mails are going out from ~500 vhosts with different UID-s with php mail(), different CMS systems.. how can i use this command
        Message 3 of 11 , Jul 1, 2008
        • 0 Attachment
          i think it's not possible..
          the mails are going out from ~500 vhosts with different UID-s with php
          mail(),
          different CMS systems..
          how can i use this command to override _every_ uid@...?
          (sorry if i misunderstand you)


          Wietse Venema írta:
          > oxy:
          >
          >> hi!
          >>
          >> i have the following problem:
          >> my apache vhost users are virtual and only got UID (10000...10500)
          >> when a vhost tries to send a mail via php mail() postfix says:
          >> fatal: no login name found for user ID
          >> is there any solution?
          >>
          >
          > Specify the sender address on the command line with:
          >
          > /usr/sbin/sendmail -f user@... recipient...
          >
          > Wietse
          >
          >
          >> it's ok for me to disable that check in postfix
          >> and every non existent user could send message from localhost..
          >> or should is rewrite the sender (i prefer the first one, if it's possible)
          >> if the rewrite is the only solution how can i do that?
          >>
          >> thanks for your help, all!
          >> Csaba Banhalmi
          >>
          >>
          >>
          >
          >
        • Wietse Venema
          ... To send email you MUST provide a valid sender email address. Wietse
          Message 4 of 11 , Jul 1, 2008
          • 0 Attachment
            oxy:
            > i think it's not possible..
            > the mails are going out from ~500 vhosts with different UID-s with php
            > mail(),
            > different CMS systems..
            > how can i use this command to override _every_ uid@...?
            > (sorry if i misunderstand you)

            To send email you MUST provide a valid sender email address.

            Wietse

            > Wietse Venema ?rta:
            > > oxy:
            > >
            > >> hi!
            > >>
            > >> i have the following problem:
            > >> my apache vhost users are virtual and only got UID (10000...10500)
            > >> when a vhost tries to send a mail via php mail() postfix says:
            > >> fatal: no login name found for user ID
            > >> is there any solution?
            > >>
            > >
            > > Specify the sender address on the command line with:
            > >
            > > /usr/sbin/sendmail -f user@... recipient...
            > >
            > > Wietse
            > >
            > >
            > >> it's ok for me to disable that check in postfix
            > >> and every non existent user could send message from localhost..
            > >> or should is rewrite the sender (i prefer the first one, if it's possible)
            > >> if the rewrite is the only solution how can i do that?
            > >>
            > >> thanks for your help, all!
            > >> Csaba Banhalmi
            > >>
            > >>
            > >>
            > >
            > >
            >
            >
          • oxy
            so is there any way to rewrite every ~500 uid-s to for example www@domain.tld?
            Message 5 of 11 , Jul 1, 2008
            • 0 Attachment
              so is there any way to rewrite every ~500 uid-s to for example
              www@...?

              Wietse Venema írta:
              > oxy:
              >
              >> i think it's not possible..
              >> the mails are going out from ~500 vhosts with different UID-s with php
              >> mail(),
              >> different CMS systems..
              >> how can i use this command to override _every_ uid@...?
              >> (sorry if i misunderstand you)
              >>
              >
              > To send email you MUST provide a valid sender email address.
              >
              > Wietse
              >
              >
              >> Wietse Venema ?rta:
              >>
              >>> oxy:
              >>>
              >>>
              >>>> hi!
              >>>>
              >>>> i have the following problem:
              >>>> my apache vhost users are virtual and only got UID (10000...10500)
              >>>> when a vhost tries to send a mail via php mail() postfix says:
              >>>> fatal: no login name found for user ID
              >>>> is there any solution?
              >>>>
              >>>>
              >>> Specify the sender address on the command line with:
              >>>
              >>> /usr/sbin/sendmail -f user@... recipient...
              >>>
              >>> Wietse
              >>>
              >>>
              >>>
              >>>> it's ok for me to disable that check in postfix
              >>>> and every non existent user could send message from localhost..
              >>>> or should is rewrite the sender (i prefer the first one, if it's possible)
              >>>> if the rewrite is the only solution how can i do that?
              >>>>
              >>>> thanks for your help, all!
              >>>> Csaba Banhalmi
              >>>>
              >>>>
              >>>>
              >>>>
              >>>
              >>>
              >>
              >
              >
            • Wietse Venema
              ... To specify the /usr/sbin/sendmail -f user@example.com... , use php.ini, or use ini_set(parametername, parametervalue). Wietse
              Message 6 of 11 , Jul 1, 2008
              • 0 Attachment
                oxy:
                > hi!
                >
                > i have the following problem:
                > my apache vhost users are virtual and only got UID (10000...10500)
                > when a vhost tries to send a mail via php mail() postfix says:
                > fatal: no login name found for user ID
                > is there any solution?

                Wietse:
                > Specify the sender address on the command line with:
                > /usr/sbin/sendmail -f user@... recipient...

                oxy:
                > i think it's not possible..
                > the mails are going out from ~500 vhosts with different UID-s with php
                > mail(),
                > different CMS systems..
                > how can i use this command to override _every_ uid@...?
                > (sorry if i misunderstand you)

                Wietse:
                > To send email you MUST provide a valid sender email address.

                oxy:
                > so is there any way to rewrite every ~500 uid-s to for example
                > www@...?

                To specify the "/usr/sbin/sendmail -f user@......",
                use php.ini, or use ini_set(parametername, parametervalue).

                Wietse
              • oxy
                thank you, it seems like a good idea :) can you tell me what parameters should i add to sendmail? /usr/sbin/sendmail -f user@example.com was not enough
                Message 7 of 11 , Jul 1, 2008
                • 0 Attachment
                  thank you, it seems like a good idea :)
                  can you tell me what parameters should i add to sendmail?
                  "/usr/sbin/sendmail -f user@..."
                  was not enough

                  Wietse Venema írta:
                  > oxy:
                  >
                  >> hi!
                  >>
                  >> i have the following problem:
                  >> my apache vhost users are virtual and only got UID (10000...10500)
                  >> when a vhost tries to send a mail via php mail() postfix says:
                  >> fatal: no login name found for user ID
                  >> is there any solution?
                  >>
                  >
                  > Wietse:
                  >
                  >> Specify the sender address on the command line with:
                  >> /usr/sbin/sendmail -f user@... recipient...
                  >>
                  >
                  > oxy:
                  >
                  >> i think it's not possible..
                  >> the mails are going out from ~500 vhosts with different UID-s with php
                  >> mail(),
                  >> different CMS systems..
                  >> how can i use this command to override _every_ uid@...?
                  >> (sorry if i misunderstand you)
                  >>
                  >
                  > Wietse:
                  >
                  >> To send email you MUST provide a valid sender email address.
                  >>
                  >
                  > oxy:
                  >
                  >> so is there any way to rewrite every ~500 uid-s to for example
                  >> www@...?
                  >>
                  >
                  > To specify the "/usr/sbin/sendmail -f user@......",
                  > use php.ini, or use ini_set(parametername, parametervalue).
                  >
                  > Wietse
                  >
                • Victor Duchovni
                  ... The right solution is to assign to each valid uid a entry in the appropriate passwd file as part of the provisioning process for such uids. -- Viktor.
                  Message 8 of 11 , Jul 1, 2008
                  • 0 Attachment
                    On Tue, Jul 01, 2008 at 05:50:54PM +0200, oxy wrote:

                    > thank you, it seems like a good idea :)
                    > can you tell me what parameters should i add to sendmail?
                    > "/usr/sbin/sendmail -f user@..."
                    > was not enough

                    The right solution is to assign to each valid uid a entry in the
                    appropriate passwd file as part of the provisioning process for such uids.

                    --
                    Viktor.

                    Disclaimer: off-list followups get on-list replies or get ignored.
                    Please do not ignore the "Reply-To" header.

                    To unsubscribe from the postfix-users list, visit
                    http://www.postfix.org/lists.html or click the link below:
                    <mailto:majordomo@...?body=unsubscribe%20postfix-users>

                    If my response solves your problem, the best way to thank me is to not
                    send an "it worked, thanks" follow-up. If you must respond, please put
                    "It worked, thanks" in the "Subject" so I can delete these quickly.
                  • oxy
                    thanks for everybody, sendmail_path = /usr/sbin/sendmail -f www@domain.tld -t -i solved my problem! cheers!
                    Message 9 of 11 , Jul 1, 2008
                    • 0 Attachment
                      thanks for everybody,
                      sendmail_path = /usr/sbin/sendmail -f www@... -t -i
                      solved my problem!
                      cheers!

                      Victor Duchovni írta:
                      > On Tue, Jul 01, 2008 at 05:50:54PM +0200, oxy wrote:
                      >
                      >
                      >> thank you, it seems like a good idea :)
                      >> can you tell me what parameters should i add to sendmail?
                      >> "/usr/sbin/sendmail -f user@..."
                      >> was not enough
                      >>
                      >
                      > The right solution is to assign to each valid uid a entry in the
                      > appropriate passwd file as part of the provisioning process for such uids.
                      >
                      >
                    • Wietse Venema
                      ... In php.ini: sendmail_path = /usr/sbin/sendmail -t -i -f user@example.com According to PHP documentation, the parameter may also be set via httpd.conf.
                      Message 10 of 11 , Jul 1, 2008
                      • 0 Attachment
                        oxy:
                        > my apache vhost users are virtual and only got UID (10000...10500)
                        > when a vhost tries to send a mail via php mail() postfix says:
                        > fatal: no login name found for user ID
                        > is there any solution?

                        Wietse:
                        > Specify the sender address on the command line with:
                        > /usr/sbin/sendmail -f user@... recipient...

                        oxy:
                        > i think it's not possible..
                        > the mails are going out from ~500 vhosts with different UID-s with php
                        > mail(),
                        > different CMS systems..
                        > how can i use this command to override _every_ uid@...?
                        > (sorry if i misunderstand you)

                        Wietse:
                        > To send email you MUST provide a valid sender email address.

                        oxy:
                        > so is there any way to rewrite every ~500 uid-s to for example
                        > www@...?

                        Wietse Venema ?rta:
                        > To specify the "/usr/sbin/sendmail -f user@......",
                        > use php.ini, or use ini_set(parametername, parametervalue).

                        oxy:
                        > thank you, it seems like a good idea :)
                        > can you tell me what parameters should i add to sendmail?
                        > "/usr/sbin/sendmail -f user@..."
                        > was not enough

                        In php.ini:
                        sendmail_path = /usr/sbin/sendmail -t -i -f user@...

                        According to PHP documentation, the parameter may also be set via
                        httpd.conf.

                        http://us3.php.net/manual/en/mail.configuration.php
                        http://us3.php.net/manual/en/ini.php

                        Wietse
                      • oxy
                        thank you for all your help!
                        Message 11 of 11 , Jul 1, 2008
                        • 0 Attachment
                          thank you for all your help!

                          Wietse Venema írta:
                          > oxy:
                          >
                          > In php.ini:
                          > sendmail_path = /usr/sbin/sendmail -t -i -f user@...
                          >
                          > According to PHP documentation, the parameter may also be set via
                          > httpd.conf.
                          >
                          > http://us3.php.net/manual/en/mail.configuration.php
                          > http://us3.php.net/manual/en/ini.php
                          >
                          > Wietse
                          >
                        Your message has been successfully submitted and would be delivered to recipients shortly.