Loading ...
Sorry, an error occurred while loading the content.

Re: Recipient limit, need advice

Expand Messages
  • Daniel Chojecki
    ... i have set above parameter and still not working as expected. I have checked spamassasin logs and i can see that To: field still contains two addresses.
    Message 1 of 9 , Jul 1, 2008
    • 0 Attachment
      2008/6/30 mouss <mouss@...>:

      > spamfilter_destination_recipient_limit = 1

      i have set above parameter and still not working
      as expected.

      I have checked spamassasin logs and i can see that
      "To:" field still contains two addresses.

      Any idea ?

      --
      Best Regards,
      Daniel Chojecki
    • mouss
      ... then change your spamfilter (it is a script I guess) to print its command lines args ($@) to a file so that you can look at them. any reason why you don t
      Message 2 of 9 , Jul 1, 2008
      • 0 Attachment
        Daniel Chojecki wrote:
        > 2008/6/30 mouss <mouss@...>:
        >
        >
        >> spamfilter_destination_recipient_limit = 1
        >>
        >
        > i have set above parameter and still not working
        > as expected.
        >
        > I have checked spamassasin logs and i can see that
        > "To:" field still contains two addresses.
        >
        > Any idea ?
        >
        >

        then change your spamfilter (it is a script I guess) to print its
        command lines args ($@) to a file so that you can look at them.

        any reason why you don't use amavisd-new?
      • Wietse Venema
        ... yes. Postfix does not use the To: field for email delivery. Wietse
        Message 3 of 9 , Jul 1, 2008
        • 0 Attachment
          Daniel Chojecki:
          > I have checked spamassasin logs and i can see that
          > "To:" field still contains two addresses.
          >
          > Any idea ?

          yes.

          Postfix does not use the To: field for email delivery.

          Wietse
        • Daniel Chojecki
          ... ok, so tell me what this change: default_destination_recipient_limit = 1 From documentation: default_destination_recipient_limit (default: 50) The default
          Message 4 of 9 , Jul 1, 2008
          • 0 Attachment
            2008/7/1 Wietse Venema <wietse@...>:

            > Postfix does not use the To: field for email delivery.

            ok, so tell me what this change:
            default_destination_recipient_limit = 1

            From documentation:

            default_destination_recipient_limit (default: 50)

            The default maximal number of recipients per message delivery.
            This is the default limit for delivery via the lmtp(8), pipe(8),
            smtp(8) and virtual(8) delivery agents.

            Setting this parameter to a value of 1 changes the meaning of the
            corresponding per-destination concurrency limit from concurrency per
            domain into concurrency per recipient.

            Use transport_destination_recipient_limit to specify a
            transport-specific override, where transport is the master.cf name of
            the message delivery transport.

            I understand that postfix will "copy" email and send the same message
            as many times
            as number of recipients to any delivery agent, am i right ?

            Second thing:
            in my configuration i have:
            spamfilter_destination_recipient_limit = 1
            when i do
            postconf|grep spamfilter
            i found nothing. Good or bad ?

            --
            Best Regards,
            Daniel Chojecki
          • Wietse Venema
            ... This parameter controls the number of recipients per mail delivery transaction. With multi-recipient email, it also affects the number of mail delivery
            Message 5 of 9 , Jul 1, 2008
            • 0 Attachment
              Daniel Chojecki:
              > 2008/7/1 Wietse Venema <wietse@...>:
              >
              > > Postfix does not use the To: field for email delivery.
              >
              > ok, so tell me what this change:
              > default_destination_recipient_limit = 1

              This parameter controls the number of recipients per mail delivery
              transaction. With multi-recipient email, it also affects the number
              of mail delivery transactions that Postfix makes. To see how many
              transactions Postfix makes, LOOK AT THE LOGFILE NOT THE TO: FIELD.

              I recommend that you read a book on email principles, before making
              random tweaks to an email system and claiming that it does not
              work.

              Wietse
            Your message has been successfully submitted and would be delivered to recipients shortly.