Loading ...
Sorry, an error occurred while loading the content.
 

Re: Concurrent connections

Expand Messages
  • Victor Duchovni
    ... Don t confuse the recipient count limit for a single message with the number of messages delivered over a single SMTP session. Which are you trying to
    Message 1 of 9 , Jun 29, 2008
      On Sun, Jun 29, 2008 at 09:26:06AM -0400, Jeff wrote:

      > The free mail provider in question here will accept no more than 5 mails
      > in a single connection. Is the Postfix default really 50? Is it possible
      > to limit it by domain?

      Don't confuse the recipient count limit for a single message with the
      number of messages delivered over a single SMTP session. Which are you
      trying to limit? The recipient count or the delivery count?

      C: SYN S: SYN-ACK
      C: ACK S: 220
      C: EHLO S: 250
      C: MAIL S: 250
      C: RCPT S: 250 \
      C: ... S: 250 | Up to <transport>_destination_recipient_limit times
      C: RCPT S: 250 /
      C: DATA S: 354
      C: HDRBODY S: ACK
      C: .CRLF S: 250

      C: RSET S: 250
      C: MAIL S: 250
      C: RCPT S: 250 \
      C: ... S: 250 | Up to <transport>_destination_recipient_limit times
      C: RCPT S: 250 /
      C: DATA S: 354
      C: HDRBODY S: ACK
      C: .CRLF S: 250
      C: RSET S: 250

      ... If connection caching is enabled, and there is enough mail in
      the queue, a connection may be re-used for multiple deliveries,
      Postfix limits the total lifetime of cached connections, not the
      number of deliveries. The default limit is 300s, which is comparable
      to the SMTP command timeouts to avoid slow-server "attractors".

      C: RSET S: 250
      C: MAIL S: 250
      C: RCPT S: 250 \
      C: ... S: 250 | Up to <transport>_destination_recipient_limit times
      C: RCPT S: 250 /
      C: DATA S: 354
      C: HDRBODY S: ACK
      C: .CRLF S: 250
      C: QUIT S: 221

      --
      Viktor.

      Disclaimer: off-list followups get on-list replies or get ignored.
      Please do not ignore the "Reply-To" header.

      To unsubscribe from the postfix-users list, visit
      http://www.postfix.org/lists.html or click the link below:
      <mailto:majordomo@...?body=unsubscribe%20postfix-users>

      If my response solves your problem, the best way to thank me is to not
      send an "it worked, thanks" follow-up. If you must respond, please put
      "It worked, thanks" in the "Subject" so I can delete these quickly.
    Your message has been successfully submitted and would be delivered to recipients shortly.