Loading ...
Sorry, an error occurred while loading the content.

Re: Problems setting up mobile virtual server

Expand Messages
  • /dev/rob0
    ... Did you set generic_maps ? Where was postconf -n ? ... Did you set transport_maps ? Where was postconf -n ? ... This is Sendmail s sendmail(1), not
    Message 1 of 22 , Jun 2, 2008
    • 0 Attachment
      On Mon June 2 2008 12:15:43 Felipe Contreras wrote:
      > Perhaps, but can you explain me this?
      >
      > hostname:
      > annwn.felipec.org
      >
      > generic:
      > felipec@... felipe.contreras+test@...

      Did you set generic_maps ? Where was "postconf -n"?

      > transport:
      > felipec.org relay:company.com

      Did you set transport_maps ? Where was "postconf -n"?

      > Jun 2 20:04:46 annwn sendmail[11371]: m52H4i30011371: from=felipec,

      This is Sendmail's sendmail(1), not Postfix's.

      > Jun 2 20:04:47 annwn postfix/smtp[11376]: connect to
      > gmail-smtp-in.l.google.com[209.85.135.27]:25: Connection refused

      That looks like port 25 blocking.
      --
      Offlist mail to this address is discarded unless
      "/dev/rob0" or "not-spam" is in Subject: header
    • Felipe Contreras
      ... Yes: smtp_generic_maps = hash:/etc/postfix/generic transport_maps = hash:/etc/postfix/transport ... Ahh, good catch. ... Yes, that s what my company does.
      Message 2 of 22 , Jun 2, 2008
      • 0 Attachment
        On Mon, Jun 2, 2008 at 10:26 PM, /dev/rob0 <rob0@...> wrote:
        > On Mon June 2 2008 12:15:43 Felipe Contreras wrote:
        >> Perhaps, but can you explain me this?
        >>
        >> hostname:
        >> annwn.felipec.org
        >>
        >> generic:
        >> felipec@... felipe.contreras+test@...
        >
        > Did you set generic_maps ? Where was "postconf -n"?
        >
        >> transport:
        >> felipec.org relay:company.com
        >
        > Did you set transport_maps ? Where was "postconf -n"?

        Yes:

        smtp_generic_maps = hash:/etc/postfix/generic
        transport_maps = hash:/etc/postfix/transport

        >> Jun 2 20:04:46 annwn sendmail[11371]: m52H4i30011371: from=felipec,
        >
        > This is Sendmail's sendmail(1), not Postfix's.

        Ahh, good catch.

        >> Jun 2 20:04:47 annwn postfix/smtp[11376]: connect to
        >> gmail-smtp-in.l.google.com[209.85.135.27]:25: Connection refused
        >
        > That looks like port 25 blocking.

        Yes, that's what my company does. That's why I have to relay through
        the company smtp.

        Anway, transport still seems to be used for destination addresses, my
        domain is not used at all.

        Best regards.

        --
        Felipe Contreras
      • Wietse Venema
        ... The relay host can be chosen based on the domain portion of the envelope sender address (with sender_dependent_relayhost_maps) but this is not necessarily
        Message 3 of 22 , Jun 2, 2008
        • 0 Attachment
          Felipe Contreras:
          > So it doesn't matter which hostname I have, there doesn't seem to be a
          > way to choose the relay host based on my origin domain.

          The relay host can be chosen based on the domain portion of the
          envelope sender address (with sender_dependent_relayhost_maps) but
          this is not necessarily what you need, because it does not control
          the use of smtp_generic_maps.

          Wietse
        • Felipe Contreras
          ... That seems to work, except that I can t find documentation regarding the format. I tried: company.com relay:company.com Then company.com
          Message 4 of 22 , Jun 2, 2008
          • 0 Attachment
            On Mon, Jun 2, 2008 at 10:52 PM, Wietse Venema <wietse@...> wrote:
            > Felipe Contreras:
            >> So it doesn't matter which hostname I have, there doesn't seem to be a
            >> way to choose the relay host based on my origin domain.
            >
            > The relay host can be chosen based on the domain portion of the
            > envelope sender address (with sender_dependent_relayhost_maps) but
            > this is not necessarily what you need, because it does not control
            > the use of smtp_generic_maps.

            That seems to work, except that I can't find documentation regarding the format.

            I tried:
            company.com relay:company.com

            Then
            company.com relay:[smtp.company.com]

            Then:
            @... relay:[smtp.company.com]

            And finally
            @... [smtp.company.com]

            Thanks.

            --
            Felipe Contreras
          • Wietse Venema
            ... $ man 5 postconf | less +/^sender_dependent_relayhost_maps sender_dependent_relayhost_maps (default: empty) A sender-dependent override for the global
            Message 5 of 22 , Jun 2, 2008
            • 0 Attachment
              Felipe Contreras:
              > On Mon, Jun 2, 2008 at 10:52 PM, Wietse Venema <wietse@...> wrote:
              > > Felipe Contreras:
              > >> So it doesn't matter which hostname I have, there doesn't seem to be a
              > >> way to choose the relay host based on my origin domain.
              > >
              > > The relay host can be chosen based on the domain portion of the
              > > envelope sender address (with sender_dependent_relayhost_maps) but
              > > this is not necessarily what you need, because it does not control
              > > the use of smtp_generic_maps.
              >
              > That seems to work, except that I can't find documentation regarding the format.
              >

              $ man 5 postconf | less '+/^sender_dependent_relayhost_maps'
              sender_dependent_relayhost_maps (default: empty)
              A sender-dependent override for the global relayhost parameter setting.
              The tables are searched by the envelope sender address and @domain.
              This information is overruled with relay_transport, default_transport
              and with the transport(5) table.

              The lookup result is the relayhost override, and has (surprise)
              the same form as the relayhost parameter value.

              $ man 5 postconf | less '+/^relayhost'

              Wietse
            • Felipe Contreras
              ... From that text I would assume @company.com should work, but it doesn t, only @host.company.com seems to work here. Best regards. -- Felipe Contreras
              Message 6 of 22 , Jun 2, 2008
              • 0 Attachment
                On Tue, Jun 3, 2008 at 12:30 AM, Wietse Venema <wietse@...> wrote:
                > Felipe Contreras:
                >> On Mon, Jun 2, 2008 at 10:52 PM, Wietse Venema <wietse@...> wrote:
                >> > Felipe Contreras:
                >> >> So it doesn't matter which hostname I have, there doesn't seem to be a
                >> >> way to choose the relay host based on my origin domain.
                >> >
                >> > The relay host can be chosen based on the domain portion of the
                >> > envelope sender address (with sender_dependent_relayhost_maps) but
                >> > this is not necessarily what you need, because it does not control
                >> > the use of smtp_generic_maps.
                >>
                >> That seems to work, except that I can't find documentation regarding the format.
                >>
                >
                > $ man 5 postconf | less '+/^sender_dependent_relayhost_maps'
                > sender_dependent_relayhost_maps (default: empty)
                > A sender-dependent override for the global relayhost parameter setting.
                > The tables are searched by the envelope sender address and @domain.
                > This information is overruled with relay_transport, default_transport
                > and with the transport(5) table.

                From that text I would assume @... should work, but it
                doesn't, only @... seems to work here.

                Best regards.

                --
                Felipe Contreras
              • Victor Duchovni
                ... Given an address of the form localpart@domain, the lookup keys are: localpart@domain @domain in that order. This is a common feature of all the address
                Message 7 of 22 , Jun 2, 2008
                • 0 Attachment
                  On Tue, Jun 03, 2008 at 12:44:29AM +0300, Felipe Contreras wrote:

                  > On Tue, Jun 3, 2008 at 12:30 AM, Wietse Venema <wietse@...> wrote:
                  > > Felipe Contreras:
                  > >> On Mon, Jun 2, 2008 at 10:52 PM, Wietse Venema <wietse@...> wrote:
                  > >> > Felipe Contreras:
                  > >> >> So it doesn't matter which hostname I have, there doesn't seem to be a
                  > >> >> way to choose the relay host based on my origin domain.
                  > >> >
                  > >> > The relay host can be chosen based on the domain portion of the
                  > >> > envelope sender address (with sender_dependent_relayhost_maps) but
                  > >> > this is not necessarily what you need, because it does not control
                  > >> > the use of smtp_generic_maps.
                  > >>
                  > >> That seems to work, except that I can't find documentation regarding the format.
                  > >>
                  > >
                  > > $ man 5 postconf | less '+/^sender_dependent_relayhost_maps'
                  > > sender_dependent_relayhost_maps (default: empty)
                  > > A sender-dependent override for the global relayhost parameter setting.
                  > > The tables are searched by the envelope sender address and @domain.
                  > > This information is overruled with relay_transport, default_transport
                  > > and with the transport(5) table.
                  >
                  > From that text I would assume @... should work, but it
                  > doesn't, only @... seems to work here.
                  >

                  Given an address of the form localpart@domain, the lookup keys are:

                  localpart@domain
                  @domain

                  in that order. This is a common feature of all the address rewriting tables.

                  --
                  Viktor.

                  Disclaimer: off-list followups get on-list replies or get ignored.
                  Please do not ignore the "Reply-To" header.

                  To unsubscribe from the postfix-users list, visit
                  http://www.postfix.org/lists.html or click the link below:
                  <mailto:majordomo@...?body=unsubscribe%20postfix-users>

                  If my response solves your problem, the best way to thank me is to not
                  send an "it worked, thanks" follow-up. If you must respond, please put
                  "It worked, thanks" in the "Subject" so I can delete these quickly.
                • Wietse Venema
                  ... Your envelope sender address has the form user@host.company.com. Postfix works as documented. Wietse
                  Message 8 of 22 , Jun 2, 2008
                  • 0 Attachment
                    Felipe Contreras:
                    > > $ man 5 postconf | less '+/^sender_dependent_relayhost_maps'
                    > > sender_dependent_relayhost_maps (default: empty)
                    > > A sender-dependent override for the global relayhost parameter setting.
                    > > The tables are searched by the envelope sender address and @domain.
                    > > This information is overruled with relay_transport, default_transport
                    > > and with the transport(5) table.
                    >
                    > From that text I would assume @... should work, but it
                    > doesn't, only @... seems to work here.

                    Your envelope sender address has the form user@....
                    Postfix works as documented.

                    Wietse
                  Your message has been successfully submitted and would be delivered to recipients shortly.