Loading ...
Sorry, an error occurred while loading the content.

Re: Problems setting up mobile virtual server

Expand Messages
  • Victor Duchovni
    ... Transport resolution happens before generic mapping. See ADDRESS_REWRITING_README. This said, why are you using Postfix on your laptop at all? I don t, it
    Message 1 of 22 , Jun 2, 2008
    • 0 Attachment
      On Mon, Jun 02, 2008 at 06:17:03PM +0300, Felipe Contreras wrote:

      > Hi,
      >
      > I want to use postfix in my laptop both in work and from home. My
      > laptop has a virtual hostname, so I want addresses mapped, and for
      > that I'm using "generic" to map them.
      >
      > Next I set up "transport" to use a relay host if I'm at work
      > (host.company.com) or direct if I'm at home (host.felipec.org). The
      > problem is that apparently the addresses were already mapped in
      > "generic" so now I have no way to distinguish them.
      >
      > Any ideas?

      Transport resolution happens before generic mapping. See ADDRESS_REWRITING_README.

      This said, why are you using Postfix on your laptop at all? I don't,
      it just runs an MUA.

      --
      Viktor.

      Disclaimer: off-list followups get on-list replies or get ignored.
      Please do not ignore the "Reply-To" header.

      To unsubscribe from the postfix-users list, visit
      http://www.postfix.org/lists.html or click the link below:
      <mailto:majordomo@...?body=unsubscribe%20postfix-users>

      If my response solves your problem, the best way to thank me is to not
      send an "it worked, thanks" follow-up. If you must respond, please put
      "It worked, thanks" in the "Subject" so I can delete these quickly.
    • Felipe Contreras
      On Mon, Jun 2, 2008 at 6:31 PM, Victor Duchovni ... I read the document and it doesn t say at which point generic is run. It says it s part of Address
      Message 2 of 22 , Jun 2, 2008
      • 0 Attachment
        On Mon, Jun 2, 2008 at 6:31 PM, Victor Duchovni
        <Victor.Duchovni@...> wrote:
        > On Mon, Jun 02, 2008 at 06:17:03PM +0300, Felipe Contreras wrote:
        >
        >> Hi,
        >>
        >> I want to use postfix in my laptop both in work and from home. My
        >> laptop has a virtual hostname, so I want addresses mapped, and for
        >> that I'm using "generic" to map them.
        >>
        >> Next I set up "transport" to use a relay host if I'm at work
        >> (host.company.com) or direct if I'm at home (host.felipec.org). The
        >> problem is that apparently the addresses were already mapped in
        >> "generic" so now I have no way to distinguish them.
        >>
        >> Any ideas?
        >
        > Transport resolution happens before generic mapping. See ADDRESS_REWRITING_README.
        >
        > This said, why are you using Postfix on your laptop at all? I don't,
        > it just runs an MUA.

        I read the document and it doesn't say at which point generic is run.
        It says it's part of "Address rewriting with remote delivery", while
        transport is part of "Address rewriting when mail is delivered", but
        not which one of these two comes first.

        Anyway, I can see that generic is run first because when I use
        gmail.com in transport it's properly relayed, and generic is mapping
        from felipec.org to gmail.com.

        I want to use mutt and I want to send e-emails as if I used my
        gmail.com account. And of course I can't rely with gmail.com nor send
        emails to it when I'm at work unless I rely with my company's smtp
        server.

        Right?

        --
        Felipe Contreras
      • Brian Evans
        ... Please don t abuse Postfix as an MDA. For your case, a bit of googling would have brought you to http://www.andrews-corner.org/mutt.html Brian
        Message 3 of 22 , Jun 2, 2008
        • 0 Attachment
          Felipe Contreras wrote:
          > On Mon, Jun 2, 2008 at 6:31 PM, Victor Duchovni
          > <Victor.Duchovni@...> wrote:
          >
          >> On Mon, Jun 02, 2008 at 06:17:03PM +0300, Felipe Contreras wrote:
          >>
          >>
          >>> Hi,
          >>>
          >>> I want to use postfix in my laptop both in work and from home. My
          >>> laptop has a virtual hostname, so I want addresses mapped, and for
          >>> that I'm using "generic" to map them.
          >>>
          >>> Next I set up "transport" to use a relay host if I'm at work
          >>> (host.company.com) or direct if I'm at home (host.felipec.org). The
          >>> problem is that apparently the addresses were already mapped in
          >>> "generic" so now I have no way to distinguish them.
          >>>
          >>> Any ideas?
          >>>
          >> Transport resolution happens before generic mapping. See ADDRESS_REWRITING_README.
          >>
          >> This said, why are you using Postfix on your laptop at all? I don't,
          >> it just runs an MUA.
          >>
          >
          > I read the document and it doesn't say at which point generic is run.
          > It says it's part of "Address rewriting with remote delivery", while
          > transport is part of "Address rewriting when mail is delivered", but
          > not which one of these two comes first.
          >
          > Anyway, I can see that generic is run first because when I use
          > gmail.com in transport it's properly relayed, and generic is mapping
          > from felipec.org to gmail.com.
          >
          > I want to use mutt and I want to send e-emails as if I used my
          > gmail.com account. And of course I can't rely with gmail.com nor send
          > emails to it when I'm at work unless I rely with my company's smtp
          > server.
          >
          > Right?
          Please don't abuse Postfix as an MDA.
          For your case, a bit of googling would have brought you to
          http://www.andrews-corner.org/mutt.html

          Brian
        • Victor Duchovni
          ... This is simply not true, unless you have a content filter, and have not disabled generic mapping in the content filter smtp service. -- Viktor. Disclaimer:
          Message 4 of 22 , Jun 2, 2008
          • 0 Attachment
            On Mon, Jun 02, 2008 at 06:58:55PM +0300, Felipe Contreras wrote:

            > Anyway, I can see that generic is run first because when I use
            > gmail.com in transport it's properly relayed, and generic is mapping
            > from felipec.org to gmail.com.

            This is simply not true, unless you have a content filter, and have not
            disabled generic mapping in the content filter smtp service.

            --
            Viktor.

            Disclaimer: off-list followups get on-list replies or get ignored.
            Please do not ignore the "Reply-To" header.

            To unsubscribe from the postfix-users list, visit
            http://www.postfix.org/lists.html or click the link below:
            <mailto:majordomo@...?body=unsubscribe%20postfix-users>

            If my response solves your problem, the best way to thank me is to not
            send an "it worked, thanks" follow-up. If you must respond, please put
            "It worked, thanks" in the "Subject" so I can delete these quickly.
          • Wietse Venema
            ... No, transport mapping happens before generic mapping. You are perhaps confused with the effects of an SMTP-based content filter. ... This is easy. Use
            Message 5 of 22 , Jun 2, 2008
            • 0 Attachment
              Felipe Contreras:
              > Anyway, I can see that generic is run first because when I use
              > gmail.com in transport it's properly relayed, and generic is mapping
              > from felipec.org to gmail.com.

              No, transport mapping happens before generic mapping. You are
              perhaps confused with the effects of an SMTP-based content filter.

              > I want to use mutt and I want to send e-emails as if I used my
              > gmail.com account. And of course I can't rely with gmail.com nor send
              > emails to it when I'm at work unless I rely with my company's smtp
              > server.

              This is easy. Use different Postfix configuration files depending on
              whether you are at home or at work.

              Wietse
            • Felipe Contreras
              Hi, ... I used Postfix because I was already familiar with it and I know it s mature. I just tried that msmtp and it can t connect, probably it doesn t have
              Message 6 of 22 , Jun 2, 2008
              • 0 Attachment
                Hi,

                On Mon, Jun 2, 2008 at 7:28 PM, Brian Evans <grknight@...> wrote:
                > Felipe Contreras wrote:
                >>
                >> On Mon, Jun 2, 2008 at 6:31 PM, Victor Duchovni
                >> <Victor.Duchovni@...> wrote:
                >>
                >>>
                >>> On Mon, Jun 02, 2008 at 06:17:03PM +0300, Felipe Contreras wrote:
                >>>
                >>>
                >>>>
                >>>> Hi,
                >>>>
                >>>> I want to use postfix in my laptop both in work and from home. My
                >>>> laptop has a virtual hostname, so I want addresses mapped, and for
                >>>> that I'm using "generic" to map them.
                >>>>
                >>>> Next I set up "transport" to use a relay host if I'm at work
                >>>> (host.company.com) or direct if I'm at home (host.felipec.org). The
                >>>> problem is that apparently the addresses were already mapped in
                >>>> "generic" so now I have no way to distinguish them.
                >>>>
                >>>> Any ideas?
                >>>>
                >>>
                >>> Transport resolution happens before generic mapping. See
                >>> ADDRESS_REWRITING_README.
                >>>
                >>> This said, why are you using Postfix on your laptop at all? I don't,
                >>> it just runs an MUA.
                >>>
                >>
                >> I read the document and it doesn't say at which point generic is run.
                >> It says it's part of "Address rewriting with remote delivery", while
                >> transport is part of "Address rewriting when mail is delivered", but
                >> not which one of these two comes first.
                >>
                >> Anyway, I can see that generic is run first because when I use
                >> gmail.com in transport it's properly relayed, and generic is mapping
                >> from felipec.org to gmail.com.
                >>
                >> I want to use mutt and I want to send e-emails as if I used my
                >> gmail.com account. And of course I can't rely with gmail.com nor send
                >> emails to it when I'm at work unless I rely with my company's smtp
                >> server.
                >>
                >> Right?
                >
                > Please don't abuse Postfix as an MDA.
                > For your case, a bit of googling would have brought you to
                > http://www.andrews-corner.org/mutt.html

                I used Postfix because I was already familiar with it and I know it's mature.

                I just tried that msmtp and it can't connect, probably it doesn't have
                support for proxies.

                I'm reluctant to try other similar MTAs since esmtp and ssmtp seem
                outdated. Do you have any other recommendation or can I use Postfix
                now?

                Besides, at some point I might want to buy a real domain and redirect
                to my gmail.com account, and maybe even a real host.

                Best regards.

                --
                Felipe Contreras
              • Felipe Contreras
                Hi, ... Perhaps, but can you explain me this? hostname: annwn.felipec.org generic: felipec@annwn.felipec.org felipe.contreras+test@gmail.com transport:
                Message 7 of 22 , Jun 2, 2008
                • 0 Attachment
                  Hi,

                  On Mon, Jun 2, 2008 at 7:53 PM, Wietse Venema <wietse@...> wrote:
                  > Felipe Contreras:
                  >> Anyway, I can see that generic is run first because when I use
                  >> gmail.com in transport it's properly relayed, and generic is mapping
                  >> from felipec.org to gmail.com.
                  >
                  > No, transport mapping happens before generic mapping. You are
                  > perhaps confused with the effects of an SMTP-based content filter.

                  Perhaps, but can you explain me this?

                  hostname:
                  annwn.felipec.org

                  generic:
                  felipec@... felipe.contreras+test@...

                  transport:
                  felipec.org relay:company.com

                  Jun 2 20:04:46 annwn sendmail[11371]: m52H4i30011371: from=felipec,
                  size=381, class=0, nrcpts=1,
                  msgid=<20080602170444.GA11360@...>,
                  relay=felipec@localhost
                  Jun 2 20:04:46 annwn postfix/smtpd[11372]: connect from
                  localhost.localdomain[127.0.0.1]
                  Jun 2 20:04:46 annwn postfix/smtpd[11372]: 810C34C048:
                  client=localhost.localdomain[127.0.0.1]
                  Jun 2 20:04:46 annwn postfix/cleanup[11375]: 810C34C048:
                  message-id=<20080602170444.GA11360@...>
                  Jun 2 20:04:46 annwn postfix/qmgr[11237]: 810C34C048:
                  from=<felipec@...>, size=763, nrcpt=1 (queue active)
                  Jun 2 20:04:46 annwn sendmail[11371]: m52H4i30011371:
                  to=felipe.contreras@..., ctladdr=felipec (500/500),
                  delay=00:00:02, xdelay=00:00:00, mailer=relay, pri=30381,
                  relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (Ok: queued as
                  810C34C048)
                  Jun 2 20:04:46 annwn postfix/smtpd[11372]: disconnect from
                  localhost.localdomain[127.0.0.1]
                  Jun 2 20:04:47 annwn postfix/smtp[11376]: connect to
                  gmail-smtp-in.l.google.com[209.85.135.27]:25: Connection refused
                  Jun 2 20:04:47 annwn postfix/smtp[11376]: connect to
                  gmail-smtp-in.l.google.com[209.85.135.114]:25: Connection refused
                  Jun 2 20:04:47 annwn postfix/smtp[11376]: connect to
                  alt1.gmail-smtp-in.l.google.com[209.85.147.114]:25: Connection refused
                  Jun 2 20:04:47 annwn postfix/smtp[11376]: connect to
                  alt2.gmail-smtp-in.l.google.com[72.14.247.27]:25: Connection refused
                  Jun 2 20:04:47 annwn postfix/smtp[11376]: connect to
                  alt1.gmail-smtp-in.l.google.com[209.85.147.27]:25: Connection refused
                  Jun 2 20:04:47 annwn postfix/smtp[11376]: 810C34C048:
                  to=<felipe.contreras@...>, relay=none, delay=0.79,
                  delays=0.05/0.01/0.73/0, dsn=4.4.1, status=deferred (connect to
                  alt1.gmail-smtp-in.l.google.com[209.85.147.27]:25: Connection refused)

                  transport:
                  gmail.com relay:company.com

                  Jun 2 20:11:03 annwn sendmail[11669]: m52HB3F0011669: from=felipec,
                  size=370, class=0, nrcpts=1,
                  msgid=<20080602171103.GA11658@...>,
                  relay=felipec@localhost
                  Jun 2 20:11:03 annwn postfix/smtpd[11671]: connect from
                  localhost.localdomain[127.0.0.1]
                  Jun 2 20:11:03 annwn postfix/smtpd[11671]: C31A84C044:
                  client=localhost.localdomain[127.0.0.1]
                  Jun 2 20:11:03 annwn postfix/cleanup[11674]: C31A84C044:
                  message-id=<20080602171103.GA11658@...>
                  Jun 2 20:11:03 annwn postfix/qmgr[11500]: C31A84C044:
                  from=<felipec@...>, size=752, nrcpt=1 (queue active)
                  Jun 2 20:11:03 annwn sendmail[11669]: m52HB3F0011669:
                  to=felipe.contreras@..., ctladdr=felipec (500/500),
                  delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30370,
                  relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (Ok: queued as
                  C31A84C044)
                  Jun 2 20:11:03 annwn postfix/smtpd[11671]: disconnect from
                  localhost.localdomain[127.0.0.1]
                  Jun 2 20:11:03 annwn postfix/smtp[11675]: C31A84C044:
                  to=<felipe.contreras@...>,
                  relay=company.com[xxx.xxx.xxx.xxx]:25, delay=0.13,
                  delays=0.06/0.01/0.01/0.06, dsn=2.6.0, status=sent (250 2.6.0
                  <20080602171103.GA11658@...> Queued mail for delivery)
                  Jun 2 20:11:03 annwn postfix/qmgr[11500]: C31A84C044: removed

                  >> I want to use mutt and I want to send e-emails as if I used my
                  >> gmail.com account. And of course I can't rely with gmail.com nor send
                  >> emails to it when I'm at work unless I rely with my company's smtp
                  >> server.
                  >
                  > This is easy. Use different Postfix configuration files depending on
                  > whether you are at home or at work.

                  I just want to use different relay hosts depending on the domain I'm
                  at. Is that too much to ask?

                  Best regards.

                  --
                  Felipe Contreras
                • Wietse Venema
                  Felipe Contreras: [ Charset UTF-8 unsupported, converting... ] ... I d rather not. Configurations with content_filter are difficult to analyze. Wietse
                  Message 8 of 22 , Jun 2, 2008
                  • 0 Attachment
                    Felipe Contreras:
                    [ Charset UTF-8 unsupported, converting... ]
                    > Hi,
                    >
                    > On Mon, Jun 2, 2008 at 7:53 PM, Wietse Venema <wietse@...> wrote:
                    > > Felipe Contreras:
                    > >> Anyway, I can see that generic is run first because when I use
                    > >> gmail.com in transport it's properly relayed, and generic is mapping
                    > >> from felipec.org to gmail.com.
                    > >
                    > > No, transport mapping happens before generic mapping. You are
                    > > perhaps confused with the effects of an SMTP-based content filter.
                    >
                    > Perhaps, but can you explain me this?

                    I'd rather not. Configurations with content_filter are
                    difficult to analyze.

                    Wietse
                  • Victor Duchovni
                    ... The necessary background information is in: http://www.postfix.org/FILTER_README.html -- Viktor. Disclaimer: off-list followups get on-list replies or get
                    Message 9 of 22 , Jun 2, 2008
                    • 0 Attachment
                      On Mon, Jun 02, 2008 at 01:37:40PM -0400, Wietse Venema wrote:

                      > > > No, transport mapping happens before generic mapping. You are
                      > > > perhaps confused with the effects of an SMTP-based content filter.
                      > >
                      > > Perhaps, but can you explain me this?
                      >
                      > I'd rather not. Configurations with content_filter are
                      > difficult to analyze.

                      The necessary background information is in:

                      http://www.postfix.org/FILTER_README.html

                      --
                      Viktor.

                      Disclaimer: off-list followups get on-list replies or get ignored.
                      Please do not ignore the "Reply-To" header.

                      To unsubscribe from the postfix-users list, visit
                      http://www.postfix.org/lists.html or click the link below:
                      <mailto:majordomo@...?body=unsubscribe%20postfix-users>

                      If my response solves your problem, the best way to thank me is to not
                      send an "it worked, thanks" follow-up. If you must respond, please put
                      "It worked, thanks" in the "Subject" so I can delete these quickly.
                    • Felipe Contreras
                      On Mon, Jun 2, 2008 at 8:15 PM, Felipe Contreras ... Besides, sometimes I switch from the Intranet to normal Internet, both from work (wireless) and home
                      Message 10 of 22 , Jun 2, 2008
                      • 0 Attachment
                        On Mon, Jun 2, 2008 at 8:15 PM, Felipe Contreras
                        <felipe.contreras@...> wrote:
                        > Hi,
                        >
                        > On Mon, Jun 2, 2008 at 7:53 PM, Wietse Venema <wietse@...> wrote:
                        >> This is easy. Use different Postfix configuration files depending on
                        >> whether you are at home or at work.
                        >
                        > I just want to use different relay hosts depending on the domain I'm
                        > at. Is that too much to ask?

                        Besides, sometimes I switch from the Intranet to normal Internet, both
                        from work (wireless) and home (vpn).

                        Switching the postfix configuration each time I do that is far from ideal.

                        --
                        Felipe Contreras
                      • Wietse Venema
                        ... Yes, and thanks for asking so nicely. Wietse
                        Message 11 of 22 , Jun 2, 2008
                        • 0 Attachment
                          Felipe Contreras:
                          > On Mon, Jun 2, 2008 at 8:15 PM, Felipe Contreras
                          > <felipe.contreras@...> wrote:
                          > > Hi,
                          > >
                          > > On Mon, Jun 2, 2008 at 7:53 PM, Wietse Venema <wietse@...> wrote:
                          > >> This is easy. Use different Postfix configuration files depending on
                          > >> whether you are at home or at work.
                          > >
                          > > I just want to use different relay hosts depending on the domain I'm
                          > > at. Is that too much to ask?

                          Yes, and thanks for asking so nicely.

                          Wietse
                        • Felipe Contreras
                          ... I m sorry if I sounded aggressive to you, I m just trying explaining why I want to use Postfix. I ve just been told either not to use Postfix, or read
                          Message 12 of 22 , Jun 2, 2008
                          • 0 Attachment
                            On Mon, Jun 2, 2008 at 9:56 PM, Wietse Venema <wietse@...> wrote:
                            > Felipe Contreras:
                            >> On Mon, Jun 2, 2008 at 8:15 PM, Felipe Contreras
                            >> <felipe.contreras@...> wrote:
                            >> > Hi,
                            >> >
                            >> > On Mon, Jun 2, 2008 at 7:53 PM, Wietse Venema <wietse@...> wrote:
                            >> >> This is easy. Use different Postfix configuration files depending on
                            >> >> whether you are at home or at work.
                            >> >
                            >> > I just want to use different relay hosts depending on the domain I'm
                            >> > at. Is that too much to ask?
                            >
                            > Yes, and thanks for asking so nicely.

                            I'm sorry if I sounded aggressive to you, I'm just trying explaining
                            why I want to use Postfix.

                            I've just been told either not to use Postfix, or read pieces of
                            documentation that don't explain the behavior I'm experimenting.

                            So far the only document that has given me some light is OVERVIEW, and
                            that is after looking at the code. Now I see that smtp daemon is
                            supposed to be one using the generic_map and it's the last thing
                            before the data goes into the wire.

                            So I tried something else and now I see that the stuff in transport is
                            for the destination.

                            So it doesn't matter which hostname I have, there doesn't seem to be a
                            way to choose the relay host based on my origin domain.

                            --
                            Felipe Contreras
                          • Victor Duchovni
                            ... You did not say that s what you wanted. See SOHO_README. -- Viktor. Disclaimer: off-list followups get on-list replies or get ignored. Please do not ignore
                            Message 13 of 22 , Jun 2, 2008
                            • 0 Attachment
                              On Mon, Jun 02, 2008 at 10:14:35PM +0300, Felipe Contreras wrote:

                              > So it doesn't matter which hostname I have, there doesn't seem to be a
                              > way to choose the relay host based on my origin domain.

                              You did not say that's what you wanted. See SOHO_README.

                              --
                              Viktor.

                              Disclaimer: off-list followups get on-list replies or get ignored.
                              Please do not ignore the "Reply-To" header.

                              To unsubscribe from the postfix-users list, visit
                              http://www.postfix.org/lists.html or click the link below:
                              <mailto:majordomo@...?body=unsubscribe%20postfix-users>

                              If my response solves your problem, the best way to thank me is to not
                              send an "it worked, thanks" follow-up. If you must respond, please put
                              "It worked, thanks" in the "Subject" so I can delete these quickly.
                            • /dev/rob0
                              ... Did you set generic_maps ? Where was postconf -n ? ... Did you set transport_maps ? Where was postconf -n ? ... This is Sendmail s sendmail(1), not
                              Message 14 of 22 , Jun 2, 2008
                              • 0 Attachment
                                On Mon June 2 2008 12:15:43 Felipe Contreras wrote:
                                > Perhaps, but can you explain me this?
                                >
                                > hostname:
                                > annwn.felipec.org
                                >
                                > generic:
                                > felipec@... felipe.contreras+test@...

                                Did you set generic_maps ? Where was "postconf -n"?

                                > transport:
                                > felipec.org relay:company.com

                                Did you set transport_maps ? Where was "postconf -n"?

                                > Jun 2 20:04:46 annwn sendmail[11371]: m52H4i30011371: from=felipec,

                                This is Sendmail's sendmail(1), not Postfix's.

                                > Jun 2 20:04:47 annwn postfix/smtp[11376]: connect to
                                > gmail-smtp-in.l.google.com[209.85.135.27]:25: Connection refused

                                That looks like port 25 blocking.
                                --
                                Offlist mail to this address is discarded unless
                                "/dev/rob0" or "not-spam" is in Subject: header
                              • Felipe Contreras
                                ... Yes: smtp_generic_maps = hash:/etc/postfix/generic transport_maps = hash:/etc/postfix/transport ... Ahh, good catch. ... Yes, that s what my company does.
                                Message 15 of 22 , Jun 2, 2008
                                • 0 Attachment
                                  On Mon, Jun 2, 2008 at 10:26 PM, /dev/rob0 <rob0@...> wrote:
                                  > On Mon June 2 2008 12:15:43 Felipe Contreras wrote:
                                  >> Perhaps, but can you explain me this?
                                  >>
                                  >> hostname:
                                  >> annwn.felipec.org
                                  >>
                                  >> generic:
                                  >> felipec@... felipe.contreras+test@...
                                  >
                                  > Did you set generic_maps ? Where was "postconf -n"?
                                  >
                                  >> transport:
                                  >> felipec.org relay:company.com
                                  >
                                  > Did you set transport_maps ? Where was "postconf -n"?

                                  Yes:

                                  smtp_generic_maps = hash:/etc/postfix/generic
                                  transport_maps = hash:/etc/postfix/transport

                                  >> Jun 2 20:04:46 annwn sendmail[11371]: m52H4i30011371: from=felipec,
                                  >
                                  > This is Sendmail's sendmail(1), not Postfix's.

                                  Ahh, good catch.

                                  >> Jun 2 20:04:47 annwn postfix/smtp[11376]: connect to
                                  >> gmail-smtp-in.l.google.com[209.85.135.27]:25: Connection refused
                                  >
                                  > That looks like port 25 blocking.

                                  Yes, that's what my company does. That's why I have to relay through
                                  the company smtp.

                                  Anway, transport still seems to be used for destination addresses, my
                                  domain is not used at all.

                                  Best regards.

                                  --
                                  Felipe Contreras
                                • Wietse Venema
                                  ... The relay host can be chosen based on the domain portion of the envelope sender address (with sender_dependent_relayhost_maps) but this is not necessarily
                                  Message 16 of 22 , Jun 2, 2008
                                  • 0 Attachment
                                    Felipe Contreras:
                                    > So it doesn't matter which hostname I have, there doesn't seem to be a
                                    > way to choose the relay host based on my origin domain.

                                    The relay host can be chosen based on the domain portion of the
                                    envelope sender address (with sender_dependent_relayhost_maps) but
                                    this is not necessarily what you need, because it does not control
                                    the use of smtp_generic_maps.

                                    Wietse
                                  • Felipe Contreras
                                    ... That seems to work, except that I can t find documentation regarding the format. I tried: company.com relay:company.com Then company.com
                                    Message 17 of 22 , Jun 2, 2008
                                    • 0 Attachment
                                      On Mon, Jun 2, 2008 at 10:52 PM, Wietse Venema <wietse@...> wrote:
                                      > Felipe Contreras:
                                      >> So it doesn't matter which hostname I have, there doesn't seem to be a
                                      >> way to choose the relay host based on my origin domain.
                                      >
                                      > The relay host can be chosen based on the domain portion of the
                                      > envelope sender address (with sender_dependent_relayhost_maps) but
                                      > this is not necessarily what you need, because it does not control
                                      > the use of smtp_generic_maps.

                                      That seems to work, except that I can't find documentation regarding the format.

                                      I tried:
                                      company.com relay:company.com

                                      Then
                                      company.com relay:[smtp.company.com]

                                      Then:
                                      @... relay:[smtp.company.com]

                                      And finally
                                      @... [smtp.company.com]

                                      Thanks.

                                      --
                                      Felipe Contreras
                                    • Wietse Venema
                                      ... $ man 5 postconf | less +/^sender_dependent_relayhost_maps sender_dependent_relayhost_maps (default: empty) A sender-dependent override for the global
                                      Message 18 of 22 , Jun 2, 2008
                                      • 0 Attachment
                                        Felipe Contreras:
                                        > On Mon, Jun 2, 2008 at 10:52 PM, Wietse Venema <wietse@...> wrote:
                                        > > Felipe Contreras:
                                        > >> So it doesn't matter which hostname I have, there doesn't seem to be a
                                        > >> way to choose the relay host based on my origin domain.
                                        > >
                                        > > The relay host can be chosen based on the domain portion of the
                                        > > envelope sender address (with sender_dependent_relayhost_maps) but
                                        > > this is not necessarily what you need, because it does not control
                                        > > the use of smtp_generic_maps.
                                        >
                                        > That seems to work, except that I can't find documentation regarding the format.
                                        >

                                        $ man 5 postconf | less '+/^sender_dependent_relayhost_maps'
                                        sender_dependent_relayhost_maps (default: empty)
                                        A sender-dependent override for the global relayhost parameter setting.
                                        The tables are searched by the envelope sender address and @domain.
                                        This information is overruled with relay_transport, default_transport
                                        and with the transport(5) table.

                                        The lookup result is the relayhost override, and has (surprise)
                                        the same form as the relayhost parameter value.

                                        $ man 5 postconf | less '+/^relayhost'

                                        Wietse
                                      • Felipe Contreras
                                        ... From that text I would assume @company.com should work, but it doesn t, only @host.company.com seems to work here. Best regards. -- Felipe Contreras
                                        Message 19 of 22 , Jun 2, 2008
                                        • 0 Attachment
                                          On Tue, Jun 3, 2008 at 12:30 AM, Wietse Venema <wietse@...> wrote:
                                          > Felipe Contreras:
                                          >> On Mon, Jun 2, 2008 at 10:52 PM, Wietse Venema <wietse@...> wrote:
                                          >> > Felipe Contreras:
                                          >> >> So it doesn't matter which hostname I have, there doesn't seem to be a
                                          >> >> way to choose the relay host based on my origin domain.
                                          >> >
                                          >> > The relay host can be chosen based on the domain portion of the
                                          >> > envelope sender address (with sender_dependent_relayhost_maps) but
                                          >> > this is not necessarily what you need, because it does not control
                                          >> > the use of smtp_generic_maps.
                                          >>
                                          >> That seems to work, except that I can't find documentation regarding the format.
                                          >>
                                          >
                                          > $ man 5 postconf | less '+/^sender_dependent_relayhost_maps'
                                          > sender_dependent_relayhost_maps (default: empty)
                                          > A sender-dependent override for the global relayhost parameter setting.
                                          > The tables are searched by the envelope sender address and @domain.
                                          > This information is overruled with relay_transport, default_transport
                                          > and with the transport(5) table.

                                          From that text I would assume @... should work, but it
                                          doesn't, only @... seems to work here.

                                          Best regards.

                                          --
                                          Felipe Contreras
                                        • Victor Duchovni
                                          ... Given an address of the form localpart@domain, the lookup keys are: localpart@domain @domain in that order. This is a common feature of all the address
                                          Message 20 of 22 , Jun 2, 2008
                                          • 0 Attachment
                                            On Tue, Jun 03, 2008 at 12:44:29AM +0300, Felipe Contreras wrote:

                                            > On Tue, Jun 3, 2008 at 12:30 AM, Wietse Venema <wietse@...> wrote:
                                            > > Felipe Contreras:
                                            > >> On Mon, Jun 2, 2008 at 10:52 PM, Wietse Venema <wietse@...> wrote:
                                            > >> > Felipe Contreras:
                                            > >> >> So it doesn't matter which hostname I have, there doesn't seem to be a
                                            > >> >> way to choose the relay host based on my origin domain.
                                            > >> >
                                            > >> > The relay host can be chosen based on the domain portion of the
                                            > >> > envelope sender address (with sender_dependent_relayhost_maps) but
                                            > >> > this is not necessarily what you need, because it does not control
                                            > >> > the use of smtp_generic_maps.
                                            > >>
                                            > >> That seems to work, except that I can't find documentation regarding the format.
                                            > >>
                                            > >
                                            > > $ man 5 postconf | less '+/^sender_dependent_relayhost_maps'
                                            > > sender_dependent_relayhost_maps (default: empty)
                                            > > A sender-dependent override for the global relayhost parameter setting.
                                            > > The tables are searched by the envelope sender address and @domain.
                                            > > This information is overruled with relay_transport, default_transport
                                            > > and with the transport(5) table.
                                            >
                                            > From that text I would assume @... should work, but it
                                            > doesn't, only @... seems to work here.
                                            >

                                            Given an address of the form localpart@domain, the lookup keys are:

                                            localpart@domain
                                            @domain

                                            in that order. This is a common feature of all the address rewriting tables.

                                            --
                                            Viktor.

                                            Disclaimer: off-list followups get on-list replies or get ignored.
                                            Please do not ignore the "Reply-To" header.

                                            To unsubscribe from the postfix-users list, visit
                                            http://www.postfix.org/lists.html or click the link below:
                                            <mailto:majordomo@...?body=unsubscribe%20postfix-users>

                                            If my response solves your problem, the best way to thank me is to not
                                            send an "it worked, thanks" follow-up. If you must respond, please put
                                            "It worked, thanks" in the "Subject" so I can delete these quickly.
                                          • Wietse Venema
                                            ... Your envelope sender address has the form user@host.company.com. Postfix works as documented. Wietse
                                            Message 21 of 22 , Jun 2, 2008
                                            • 0 Attachment
                                              Felipe Contreras:
                                              > > $ man 5 postconf | less '+/^sender_dependent_relayhost_maps'
                                              > > sender_dependent_relayhost_maps (default: empty)
                                              > > A sender-dependent override for the global relayhost parameter setting.
                                              > > The tables are searched by the envelope sender address and @domain.
                                              > > This information is overruled with relay_transport, default_transport
                                              > > and with the transport(5) table.
                                              >
                                              > From that text I would assume @... should work, but it
                                              > doesn't, only @... seems to work here.

                                              Your envelope sender address has the form user@....
                                              Postfix works as documented.

                                              Wietse
                                            Your message has been successfully submitted and would be delivered to recipients shortly.