Loading ...
Sorry, an error occurred while loading the content.
 

Re: bad address pattern

Expand Messages
  • Ralf Hildebrandt
    ... We need postconf -n output -- Ralf Hildebrandt (Ralf.Hildebrandt@charite.de) snickebo@charite.de Postfix - Einrichtung, Betrieb und Wartung
    Message 1 of 9 , Jun 1, 2008
      * Glenn English <ghe@...>:
      > Postfix (2.3.8 binary Debian testing install) has quit working reliably.
      > I've restarted it, reinstalled it, and found the string in the cidr
      > check in the utilities (don't understand what's going on). I'm at a loss...
      >
      > Here's part of a log:
      >
      > > Jun 1 20:34:28 server postfix/smtpd[6412]: connect from unknown[209.164.135.37]
      > > Jun 1 20:34:28 server postfix/smtpd[6412]: fatal: bad address pattern: "be"

      > Here's postconf:

      We need "postconf -n" output

      --
      Ralf Hildebrandt (Ralf.Hildebrandt@...) snickebo@...
      Postfix - Einrichtung, Betrieb und Wartung Tel. +49 (0)30-450 570-155
      http://www.arschkrebs.de
      #!/bin/sh
      cat <<EOF | dc -e "[lila/sulila%Plusili0<y]sy?si256salyx"
      403736150440747681954588245935305944858835839713675044439128476844672\
      007875165788798502153167817380873133828163530564
      EOF
    • Wietse Venema
      ... It s probably a bad mynetworks setting in main.cf. Wietse
      Message 2 of 9 , Jun 2, 2008
        Ralf Hildebrandt:
        > * Glenn English <ghe@...>:
        > > Postfix (2.3.8 binary Debian testing install) has quit working reliably.
        > > I've restarted it, reinstalled it, and found the string in the cidr
        > > check in the utilities (don't understand what's going on). I'm at a loss...
        > >
        > > Here's part of a log:
        > >
        > > > Jun 1 20:34:28 server postfix/smtpd[6412]: connect from unknown[209.164.135.37]
        > > > Jun 1 20:34:28 server postfix/smtpd[6412]: fatal: bad address pattern: "be"
        >
        > > Here's postconf:
        >
        > We need "postconf -n" output

        It's probably a bad "mynetworks" setting in main.cf.

        Wietse
      • Glenn English
        ... Hash: SHA1 ... That was it. Looking at the source again, in non-panic mode, it seems to be looking for the /nn at the end of a cidr address. I have a
        Message 3 of 9 , Jun 2, 2008
          -----BEGIN PGP SIGNED MESSAGE-----
          Hash: SHA1

          Wietse Venema wrote:

          >
          > It's probably a bad "mynetworks" setting in main.cf.
          >

          That was it. Looking at the source again, in non-panic mode, it seems to
          be looking for the /nn at the end of a cidr address.

          I have a number of lines in mynetworks to allow some users to send from
          alien networks:

          > # begin email clients list
          > 71.123.14.46 # aw
          > 71.211.167.203 # be
          > 98.196.220.102 # betty
          > 75.171.165.24 # bob
          > 24.8.143.224 # david
          > 192.168.20.229 # ghe
          > 67.198.106.39 # jerry
          > 72.253.99.191 # re
          > 71.218.143.191 # tr
          > # end email clients list

          this one triggers the error from cidr_match_parse() in src/util/:

          > 71.211.167.203 # be

          The others don't seem to. A /32 after the IP doesn't help. But changing
          "be" to "qwbe" (or leaving off the label) does, and allows him to use
          the server.

          Anybody have the time/understanding/inclination to explain???

          - --
          Glenn English
          ghe@...

          -----BEGIN PGP SIGNATURE-----
          Version: GnuPG v1.4.6 (GNU/Linux)
          Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

          iD8DBQFIRCe304yQfZbbTLYRAjoQAKCa3cT39rNFgWHFhznhpAyHYL3ofQCeN5n0
          EpiaYeK6l/RTrLG48CcWLrY=
          =f/bd
          -----END PGP SIGNATURE-----
        • MrC
          ... The only reference to comments in the cidr_table(5) documentation is: blank lines and comments Empty lines and whitespace-only lines are ignored, as are
          Message 4 of 9 , Jun 2, 2008
            Glenn English wrote:
            >> # begin email clients list
            >> 71.123.14.46 # aw
            >> 71.211.167.203 # be
            >> 98.196.220.102 # betty
            >> 75.171.165.24 # bob
            >> 24.8.143.224 # david
            >> 192.168.20.229 # ghe
            >> 67.198.106.39 # jerry
            >> 72.253.99.191 # re
            >> 71.218.143.191 # tr
            >> # end email clients list
            >
            > this one triggers the error from cidr_match_parse() in src/util/:
            >
            >> 71.211.167.203 # be

            The only reference to comments in the cidr_table(5) documentation is:

            blank lines and comments
            Empty lines and whitespace-only lines are ignored, as are lines
            whose first non-whitespace character is a `#'.

            Lose the comments at the end of the line.

            MrC

            >
            > The others don't seem to. A /32 after the IP doesn't help. But changing
            > "be" to "qwbe" (or leaving off the label) does, and allows him to use
            > the server.
            >
            > Anybody have the time/understanding/inclination to explain???
            >
          • Noel Jones
            ... Postfix doesn t allow in-line comments. Postfix is trying to make sense of the hostname be , which fails. If you want to comment your entries, put the
            Message 5 of 9 , Jun 2, 2008
              Glenn English wrote:
              > -----BEGIN PGP SIGNED MESSAGE-----
              > Hash: SHA1
              >
              > Wietse Venema wrote:
              >
              >> It's probably a bad "mynetworks" setting in main.cf.
              >>
              >
              > That was it. Looking at the source again, in non-panic mode, it seems to
              > be looking for the /nn at the end of a cidr address.
              >
              > I have a number of lines in mynetworks to allow some users to send from
              > alien networks:
              >
              >> # begin email clients list
              >> 71.123.14.46 # aw
              >> 71.211.167.203 # be
              >> 98.196.220.102 # betty
              >> 75.171.165.24 # bob
              >> 24.8.143.224 # david
              >> 192.168.20.229 # ghe
              >> 67.198.106.39 # jerry
              >> 72.253.99.191 # re
              >> 71.218.143.191 # tr
              >> # end email clients list
              >
              > this one triggers the error from cidr_match_parse() in src/util/:
              >
              >> 71.211.167.203 # be
              >
              > The others don't seem to. A /32 after the IP doesn't help. But changing
              > "be" to "qwbe" (or leaving off the label) does, and allows him to use
              > the server.
              >
              > Anybody have the time/understanding/inclination to explain???
              >
              > - --
              > Glenn English
              > ghe@...
              >

              Postfix doesn't allow in-line comments. Postfix is trying to
              make sense of the hostname "be", which fails.

              If you want to comment your entries, put the comments on a
              separate line.

              The first section of
              http://www.postfix.org/postconf.5.html
              documents the format of main.cf


              --
              Noel Jones
            • ghe
              ... Hash: SHA1 ... I didn t know that -- but the fact that it didn t hurl all the time makes me wonder what it s doing with the ones it *did* make sense of.
              Message 6 of 9 , Jun 2, 2008
                -----BEGIN PGP SIGNED MESSAGE-----
                Hash: SHA1

                Noel Jones wrote:

                | Postfix doesn't allow in-line comments. Postfix is trying to make sense
                | of the hostname "be", which fails.

                I didn't know that -- but the fact that it didn't hurl all the time
                makes me wonder what it's doing with the ones it *did* make sense of.

                | If you want to comment your entries, put the comments on a separate line.

                I think I can live with that.

                They weren't really comments; they're labels for a piece of software
                that needs to know who's at what IP.

                Thanks to all for the cluebats...

                - --
                Glenn English
                ghe@...

                -----BEGIN PGP SIGNATURE-----
                Version: GnuPG v1.4.8 (Darwin)
                Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

                iEYEARECAAYFAkhEgGkACgkQ04yQfZbbTLamgwCeM79VHb7RdK2k9Pi7qTGfFWZk
                iagAniiUKW/YVSOge8aFWs2T5xL+zAyU
                =ZK30
                -----END PGP SIGNATURE-----
              • mouss
                ... not promissed, thus unpredictable. be happy that you didn t erase the whole disk. ... The last guy who song my intuition is good was killed. so read the
                Message 7 of 9 , Jun 2, 2008
                  ghe wrote:
                  > Noel Jones wrote:
                  >
                  > | Postfix doesn't allow in-line comments. Postfix is trying to make sense
                  > | of the hostname "be", which fails.
                  >
                  > I didn't know that -- but the fact that it didn't hurl all the time
                  > makes me wonder what it's doing with the ones it *did* make sense of.

                  not promissed, thus unpredictable. be happy that you didn't erase the
                  whole disk.

                  >
                  > | If you want to comment your entries, put the comments on a separate
                  > line.
                  >
                  > I think I can live with that.
                  >
                  > They weren't really comments; they're labels for a piece of software
                  > that needs to know who's at what IP.

                  The last guy who song "my intuition is good" was killed. so read the
                  documentation.
                  >
                  > Thanks to all for the cluebats...
                  >
                • Wietse Venema
                  ... Postfix uses the inet_pton() system routine, and apparently that routine returned an error for be but not for the other strings. I have no idea what
                  Message 8 of 9 , Jun 2, 2008
                    ghe:
                    > Noel Jones wrote:
                    >
                    > | Postfix doesn't allow in-line comments. Postfix is trying to make sense
                    > | of the hostname "be", which fails.
                    >
                    > I didn't know that -- but the fact that it didn't hurl all the time
                    > makes me wonder what it's doing with the ones it *did* make sense of.

                    Postfix uses the inet_pton() system routine, and apparently that
                    routine returned an error for "be" but not for the other strings.
                    I have no idea what result it produced for the junk.

                    Wietse

                    > | If you want to comment your entries, put the comments on a separate line.
                    >
                    > I think I can live with that.
                    >
                    > They weren't really comments; they're labels for a piece of software
                    > that needs to know who's at what IP.
                    >
                    > Thanks to all for the cluebats...
                    >
                    > --
                    > Glenn English
                    > ghe@...
                    -- End of PGP signed section.
                  Your message has been successfully submitted and would be delivered to recipients shortly.