Loading ...
Sorry, an error occurred while loading the content.

Re: Postfix trying to use invalid IP address...

Expand Messages
  • Victor Duchovni
    ... Without an explicit search line, there may an implicit search list based on the FQDN of the machine or other system configuration files. ... Nothing too
    Message 1 of 20 , May 30, 2008
    • 0 Attachment
      On Fri, May 30, 2008 at 12:10:29PM -0500, /dev/rob0 wrote:

      > > The only thing in my /etc/resolv.conf is "nameserver 209.51.143.76"
      >
      > No "search" line. Thus it seems that: 1. either the Debian (? referring
      > to the original post) C libraries are appending ".com" to unqualified
      > names (can Debian people test this, please?), or 2. the nameserver at
      > 209.51.143.76 is doing it.

      Without an explicit "search" line, there may an implicit search list
      based on the FQDN of the machine or other system configuration files.

      > 209.51.143.76 is NOT doing that for me. I get NXDOMAIN for "all." Do we
      > have yet another ill-considered Debian patch in play?

      Nothing too dramatic I imagine, just a default search list. If you want
      to disable search use:

      search .

      --
      Viktor.

      Disclaimer: off-list followups get on-list replies or get ignored.
      Please do not ignore the "Reply-To" header.

      To unsubscribe from the postfix-users list, visit
      http://www.postfix.org/lists.html or click the link below:
      <mailto:majordomo@...?body=unsubscribe%20postfix-users>

      If my response solves your problem, the best way to thank me is to not
      send an "it worked, thanks" follow-up. If you must respond, please put
      "It worked, thanks" in the "Subject" so I can delete these quickly.
    Your message has been successfully submitted and would be delivered to recipients shortly.