Loading ...
Sorry, an error occurred while loading the content.

Postfix 2.5.1 : unable to compile package make: *** [smtp_connect.o] Error 1 in smtp_connect.c

Expand Messages
  • TOUZEAU DAVID
    Dear i use these options to compile postifx 2.5.1 make makefiles LD_LIBRARY_PATH= /opt/artica/lib:/opt/artica/db/lib CCARGS= -DHAS_LDAP -DUSE_TLS
    Message 1 of 14 , Mar 1, 2008
    View Source
    • 0 Attachment
      Dear

      i use these options to compile postifx 2.5.1

      make makefiles LD_LIBRARY_PATH="/opt/artica/lib:/opt/artica/db/lib"
      CCARGS="-DHAS_LDAP -DUSE_TLS -DUSE_SASL_AUTH -DUSE_CYRUS_SASL
      -I/opt/artica/include/ -I/opt/artica/include/openssl
      -I/opt/artica/include/sasl -I/opt/artica/db/include"
      AUXLIBS="-L/opt/artica/lib -L/opt/artica/db/lib -lssl -lcrypto -lsasl2
      -lldap -ldb"

      i receive this compilation error

      gcc -Wmissing-prototypes -Wformat -DHAS_LDAP -DUSE_TLS -DUSE_SASL_AUTH
      -DUSE_CYRUS_SASL -I/opt/artica/include/ -I/opt/artica/include/openssl
      -I/opt/artica/include/sasl -I/opt/artica/db/include -g -O -I.
      -I../../include -DLINUX2 -c smtp.c
      gcc -Wmissing-prototypes -Wformat -DHAS_LDAP -DUSE_TLS -DUSE_SASL_AUTH
      -DUSE_CYRUS_SASL -I/opt/artica/include/ -I/opt/artica/include/openssl
      -I/opt/artica/include/sasl -I/opt/artica/db/include -g -O -I.
      -I../../include -DLINUX2 -c smtp_connect.c
      In file included from smtp_connect.c:105:
      /opt/artica/include/smtp.h:72: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or
      ‘__attribute__’ before ‘*’ token
      /opt/artica/include/smtp.h:74: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or
      ‘__attribute__’ before ‘*’ token
      /opt/artica/include/smtp.h:75: error: expected ‘)’ before ‘*’ token
      /opt/artica/include/smtp.h:76: error: expected ‘)’ before ‘*’ token
      In file included from smtp_connect.c:107:
      ./smtp_reuse.h:14: error: expected ‘)’ before ‘*’ token
      ./smtp_reuse.h:15: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or
      ‘__attribute__’ before ‘*’ token
      ./smtp_reuse.h:16: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or
      ‘__attribute__’ before ‘*’ token
      smtp_connect.c:112: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or
      ‘__attribute__’ before ‘*’ token
      smtp_connect.c:120: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or
      ‘__attribute__’ before ‘*’ token
      smtp_connect.c:169: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or
      ‘__attribute__’ before ‘*’ token
      smtp_connect.c:276: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or
      ‘__attribute__’ before ‘*’ token
      smtp_connect.c:366: error: expected ‘)’ before ‘*’ token
      smtp_connect.c:442: error: expected ‘)’ before ‘*’ token
      smtp_connect.c:469: error: expected ‘)’ before ‘*’ token
      smtp_connect.c:545: error: expected ‘)’ before ‘*’ token
      smtp_connect.c:619: error: expected ‘)’ before ‘*’ token
      smtp_connect.c:677: error: expected ‘)’ before ‘*’ token
      smtp_connect.c:997: error: expected ‘)’ before ‘*’ token
      make: *** [smtp_connect.o] error 1
      make: *** [update] error 1

      Did anybody have encounter this error ?
      How can i fix it ?



      --
      David Touzeau -------------------------- Linux Ubuntu 7.04 feisty
      FreePascal-Lazarus,perl,delphi,php artica for postfix management console
      (http://www.artica.fr) icq:160018849
    • Terry Carmen
      ... I don t think I ve ever seen this library before. Is this an official distribution from postfix.org, or is it a package you got from somewhere else? You
      Message 2 of 14 , Mar 1, 2008
      View Source
      • 0 Attachment
        TOUZEAU DAVID wrote:
        > Dear
        > /opt/artica/include/smtp.h:72: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or
        > ‘__attribute__’ before ‘*’ token
        > /opt/artica/include/smtp.h:74: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or
        > ‘__attribute__’ before ‘*’ token
        > /opt/artica/include/smtp.h:75: error: expected ‘)’ before ‘*’ token
        I don't think I've ever seen this library before.

        Is this an official distribution from postfix.org, or is it a package you got from somewhere else?

        You might have better luck compiling from here:

        http://www.postfix.org/download.html

        Terry
      • Wietse Venema
        TOUZEAU DAVID: [ Charset CP1252 unsupported, converting... ] ... You MUST compile with the POSTFIX smtp.h file not with /opt/artica/include/smtp.h. Wietse
        Message 3 of 14 , Mar 1, 2008
        View Source
        • 0 Attachment
          TOUZEAU DAVID:
          [ Charset CP1252 unsupported, converting... ]
          > Dear
          >
          > i use these options to compile postifx 2.5.1
          >
          > make makefiles LD_LIBRARY_PATH="/opt/artica/lib:/opt/artica/db/lib"
          > CCARGS="-DHAS_LDAP -DUSE_TLS -DUSE_SASL_AUTH -DUSE_CYRUS_SASL
          > -I/opt/artica/include/ -I/opt/artica/include/openssl
          > -I/opt/artica/include/sasl -I/opt/artica/db/include"
          > AUXLIBS="-L/opt/artica/lib -L/opt/artica/db/lib -lssl -lcrypto -lsasl2
          > -lldap -ldb"
          >
          > i receive this compilation error
          >
          > gcc -Wmissing-prototypes -Wformat -DHAS_LDAP -DUSE_TLS -DUSE_SASL_AUTH
          > -DUSE_CYRUS_SASL -I/opt/artica/include/ -I/opt/artica/include/openssl
          > -I/opt/artica/include/sasl -I/opt/artica/db/include -g -O -I.
          > -I../../include -DLINUX2 -c smtp.c
          > gcc -Wmissing-prototypes -Wformat -DHAS_LDAP -DUSE_TLS -DUSE_SASL_AUTH
          > -DUSE_CYRUS_SASL -I/opt/artica/include/ -I/opt/artica/include/openssl
          > -I/opt/artica/include/sasl -I/opt/artica/db/include -g -O -I.
          > -I../../include -DLINUX2 -c smtp_connect.c
          > In file included from smtp_connect.c:105:
          > /opt/artica/include/smtp.h:72: error: expected _=_, _,_, _;_, _asm_ or
          > ___attribute___ before _*_ token

          You MUST compile with the POSTFIX smtp.h file not with
          /opt/artica/include/smtp.h.

          Wietse
        • TOUZEAU DAVID
          Many thanks, by rename the smtph.h of sasl, it s working now ! ... -- David Touzeau -------------------------- Linux Ubuntu 7.04 feisty
          Message 4 of 14 , Mar 2, 2008
          View Source
          • 0 Attachment
            Many thanks, by rename the smtph.h of sasl, it's working now !

            Wietse Venema a écrit :
            > TOUZEAU DAVID:
            > [ Charset CP1252 unsupported, converting... ]
            >
            >> Dear
            >>
            >> i use these options to compile postifx 2.5.1
            >>
            >> make makefiles LD_LIBRARY_PATH="/opt/artica/lib:/opt/artica/db/lib"
            >> CCARGS="-DHAS_LDAP -DUSE_TLS -DUSE_SASL_AUTH -DUSE_CYRUS_SASL
            >> -I/opt/artica/include/ -I/opt/artica/include/openssl
            >> -I/opt/artica/include/sasl -I/opt/artica/db/include"
            >> AUXLIBS="-L/opt/artica/lib -L/opt/artica/db/lib -lssl -lcrypto -lsasl2
            >> -lldap -ldb"
            >>
            >> i receive this compilation error
            >>
            >> gcc -Wmissing-prototypes -Wformat -DHAS_LDAP -DUSE_TLS -DUSE_SASL_AUTH
            >> -DUSE_CYRUS_SASL -I/opt/artica/include/ -I/opt/artica/include/openssl
            >> -I/opt/artica/include/sasl -I/opt/artica/db/include -g -O -I.
            >> -I../../include -DLINUX2 -c smtp.c
            >> gcc -Wmissing-prototypes -Wformat -DHAS_LDAP -DUSE_TLS -DUSE_SASL_AUTH
            >> -DUSE_CYRUS_SASL -I/opt/artica/include/ -I/opt/artica/include/openssl
            >> -I/opt/artica/include/sasl -I/opt/artica/db/include -g -O -I.
            >> -I../../include -DLINUX2 -c smtp_connect.c
            >> In file included from smtp_connect.c:105:
            >> /opt/artica/include/smtp.h:72: error: expected _=_, _,_, _;_, _asm_ or
            >> ___attribute___ before _*_ token
            >>
            >
            > You MUST compile with the POSTFIX smtp.h file not with
            > /opt/artica/include/smtp.h.
            >
            > Wietse
            >
            >
            >

            --
            David Touzeau -------------------------- Linux Ubuntu 7.04 feisty
            FreePascal-Lazarus,perl,delphi,php artica for postfix management console
            (http://www.artica.fr) icq:160018849
          • Scott Kitterman
            ... If the server is also Ubuntu Feisty, you could also install 2.5.1 from the feisty-backports repository. It s now available there and in gutsy-backports.
            Message 5 of 14 , Mar 4, 2008
            View Source
            • 0 Attachment
              On Saturday 01 March 2008 10:11, TOUZEAU DAVID wrote:
              > Dear
              >
              > i use these options to compile postifx 2.5.1
              >
              ...

              > --
              > David Touzeau -------------------------- Linux Ubuntu 7.04 feisty
              > FreePascal-Lazarus,perl,delphi,php artica for postfix management console
              > (http://www.artica.fr) icq:160018849

              If the server is also Ubuntu Feisty, you could also install 2.5.1 from the
              feisty-backports repository. It's now available there and in
              gutsy-backports. There's a build system issue with the earlier releases so
              it's a bit delayed for them.

              Scott K
            • Maurizio Lo Bosco
              Hello, I have shared domains with local and remote mailboxes. I have configured the virtual_alias_domains and virtual_alias_maps but I have this strange
              Message 6 of 14 , Mar 4, 2008
              View Source
              • 0 Attachment
                Hello,
                I have shared domains with local and remote mailboxes.

                I have configured the virtual_alias_domains and virtual_alias_maps but I have
                this strange behaviour:
                let's suppose that the domain is mydomain.com and that I have one account for
                user1@...
                if I write to user1@... this mail is delivered to
                user1@...

                It seams that the server is ignoring the virtual_alias_domains and rewrite
                everything is mathing the map query. In case of no matching in
                virtual_alias_maps it forwards remotely to the correct relay.
                This is the output of postconf -n
                -------------------
                alias_database = hash:/etc/postfix/aliases
                alias_maps = ldap:/etc/postfix/ldap_aliases.conf, hash:/etc/postfix/aliases,
                hash:/var/lib/mailman/data/aliases
                append_dot_mydomain = no
                biff = no
                body_checks = regexp:/etc/postfix/body_checks
                bounce_queue_lifetime = 30m
                broken_sasl_auth_clients = yes
                command_directory = /usr/sbin
                command_time_limit = 4000s
                config_directory = /etc/postfix
                daemon_directory = /usr/lib/postfix
                empty_address_recipient = nobody
                forward_path
                = /home/$user/.forward${recipient_delimiter}${extension}, /home/$user/.forward
                header_checks = regexp:/etc/postfix/header_checks
                mail_owner = postfix
                mailbox_command =
                mailbox_size_limit = 0
                mailbox_transport = cyrus
                maximal_queue_lifetime = 1d
                mime_header_checks = regexp:/etc/postfix/mime_header_checks
                mydestination = mail.mydomain.com, localhost.$mydomain, localhost $myorigin
                myhostname = mail.mydomain.com
                mynetworks = 127.0.0.0/8, 192.168.0.0/16, ddd.ddd.ddd.ddd/32
                myorigin = mail.mydomain.com
                recipient_delimiter = +
                sendmail_path = /usr/sbin/sendmail_postfix
                setgid_group = postdrop
                smtp_connect_timeout = 15s
                smtp_helo_timeout = 40s
                smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
                smtpd_recipient_limit = 5000
                smtpd_recipient_restrictions = check_recipient_access
                regexp:/etc/postfix/invalid_recipient,
                permit_mynetworks, reject_unauth_destination
                smtpd_sasl_auth_enable = yes
                smtpd_sender_restrictions = check_sender_access
                regexp:/etc/postfix/invalid_sender
                soft_bounce = yes
                transport_maps = hash:/etc/postfix/transport
                virtual_alias_domains = mydomain.com, otherdomain1.com, otherdomain2.com
                virtual_alias_maps = ldap:/etc/postfix/ldap_maps_internal.conf,
                ldap:/etc/postfix/ldap_maps_alias.conf,
                hash:/var/lib/mailman/data/virtual-mailman,
                hash:/etc/postfix/virtual-aliases, ldap:/etc/postfix/ldap_maps_external.conf,
                hash:/etc/postfix/virtual, unix:passwd.byname
                -------------------
                The master.cf is
                ------------
                # filter to antivirus
                smtp inet n - n - - smtpd
                -o content_filter=smtp:127.0.0.1:10026
                -o receive_override_options=no_address_mappings
                :10027 inet n - y - - smtpd
                -o content_filter=
                -o myhostname=deliver.antivirus
                -o smtpd_helo_restrictions=
                -o smtpd_client_restrictions=
                -o smtpd_sender_restrictions=
                -o mynetworks=127.0.0.0/8, 192.168.99.16/28
                -o smtpd_recipient_restrictions=permit_mynetworks,reject
                -o smtpd_authorized_xforward_hosts=127.0.0.0/8,192.168.99.16/28
                -o receive_override_options=no_unknown_recipient_checks
                ------------
                I can not figure out where the problem is because the delivery to every local
                user is working.
                Thanks
                Maurizio
              • Randy Ramsdell
                ... ... Nothing here says it should accept mail for user1@some.other.server.com ... ... We use : virtual_alias_domains =
                Message 7 of 14 , Mar 4, 2008
                View Source
                • 0 Attachment
                  Maurizio Lo Bosco wrote:
                  > Hello,
                  > I have shared domains with local and remote mailboxes.
                  >
                  > I have configured the virtual_alias_domains and virtual_alias_maps but I have
                  > this strange behaviour:
                  > let's suppose that the domain is mydomain.com and that I have one account for
                  > user1@...
                  > if I write to user1@... this mail is delivered to
                  > user1@...
                  >
                  > It seams that the server is ignoring the virtual_alias_domains and rewrite
                  > everything is mathing the map query. In case of no matching in
                  > virtual_alias_maps it forwards remotely to the correct relay.
                  > This is the output of postconf -n
                  > -------------------
                  >
                  >
                  <snip>
                  > mydestination = mail.mydomain.com, localhost.$mydomain, localhost $myorigin
                  > myhostname = mail.mydomain.com
                  > mynetworks = 127.0.0.0/8, 192.168.0.0/16, ddd.ddd.ddd.ddd/32
                  > myorigin = mail.mydomain.com
                  >
                  >
                  Nothing here says it should accept mail for user1@...

                  > virtual_alias_domains = mydomain.com, otherdomain1.com, otherdomain2.com
                  > virtual_alias_maps = ldap:/etc/postfix/ldap_maps_internal.conf,
                  > ldap:/etc/postfix/ldap_maps_alias.conf,
                  > hash:/var/lib/mailman/data/virtual-mailman,
                  > hash:/etc/postfix/virtual-aliases, ldap:/etc/postfix/ldap_maps_external.conf,
                  > hash:/etc/postfix/virtual, unix:passwd.byname
                  >
                  <snip>
                  > I can not figure out where the problem is because the delivery to every local
                  > user is working.
                  > Thanks
                  > Maurizio
                  >

                  We use :
                  virtual_alias_domains = hash:/etc/postfix/virtual
                  virtual_alias_maps = hash:/etc/postfix/virtual

                  An entry in virtual:

                  user1@anotherdomain1 user1@anotherdomain2
                  Then we run postmap virutal /etc/init.d/postfix reload.

                  Not sure why this mail server is accepting mail for every domain on the
                  planet when you have a local user. Wouldn't it use the MX
                  some.other.server.com ?

                  Not much help, I know. Maybe a log of one of the messages would help.
                • Maurizio Lo Bosco
                  ... no, it doesn t look for the remote MX server. I have found that I can specify whatever address I want in the virtual_alias_maps regardless of the domain.
                  Message 8 of 14 , Mar 5, 2008
                  View Source
                  • 0 Attachment
                    On Tuesday 04 March 2008 21:05, Randy Ramsdell wrote:

                    > We use :
                    > virtual_alias_domains = hash:/etc/postfix/virtual
                    > virtual_alias_maps = hash:/etc/postfix/virtual
                    >
                    > An entry in virtual:
                    >
                    > user1@anotherdomain1 user1@anotherdomain2
                    > Then we run postmap virutal /etc/init.d/postfix reload.
                    >
                    > Not sure why this mail server is accepting mail for every domain on the
                    > planet when you have a local user. Wouldn't it use the MX
                    > some.other.server.com ?
                    no, it doesn't look for the remote MX server.

                    I have found that I can specify whatever address I want in the
                    virtual_alias_maps regardless of the domain.

                    mydestination = mail.mydomain.com
                    virtual_alias_domain = mydomain.com
                    virtual_alias_maps = hash:/etc/postfix/virtual
                    with virtual
                    myuser@my_gmail.com localuser1

                    it still accept the mail and rewrite the recipient to the localuser1.
                    postfix/pipe[3284]: 3038421015F: to=<localuser1@...>,
                    orig_to=<myuser@my_gmail.com>, relay=cyrus, delay=5.1, delays=5.1/0/0/0.06,
                    dsn=2.0.0, status=sent (delivered via cyrus service)
                    Is this behaviour correct?
                    Kind regards
                    Maurizio
                  • Victor Duchovni
                    ... Yes, this behaviour is correct and matches documentation. http://www.postfix.org/virtual.5.html http://www.postfix.org/postconf.5.html#virtual_alias_maps
                    Message 9 of 14 , Mar 5, 2008
                    View Source
                    • 0 Attachment
                      On Wed, Mar 05, 2008 at 10:17:49AM +0100, Maurizio Lo Bosco wrote:

                      > I have found that I can specify whatever address I want in the
                      > virtual_alias_maps regardless of the domain.
                      >
                      > mydestination = mail.mydomain.com
                      > virtual_alias_domain = mydomain.com
                      > virtual_alias_maps = hash:/etc/postfix/virtual
                      > with virtual
                      > myuser@my_gmail.com localuser1
                      >
                      > it still accept the mail and rewrite the recipient to the localuser1.
                      >
                      > postfix/pipe[3284]: 3038421015F: to=<localuser1@...>,
                      > orig_to=<myuser@my_gmail.com>, relay=cyrus, delay=5.1, delays=5.1/0/0/0.06,
                      > dsn=2.0.0, status=sent (delivered via cyrus service)
                      >
                      > Is this behaviour correct?

                      Yes, this behaviour is correct and matches documentation.

                      http://www.postfix.org/virtual.5.html
                      http://www.postfix.org/postconf.5.html#virtual_alias_maps
                      http://www.postfix.org/ADDRESS_REWRITING_README.html#virtual

                      --
                      Viktor.

                      Disclaimer: off-list followups get on-list replies or get ignored.
                      Please do not ignore the "Reply-To" header.

                      To unsubscribe from the postfix-users list, visit
                      http://www.postfix.org/lists.html or click the link below:
                      <mailto:majordomo@...?body=unsubscribe%20postfix-users>

                      If my response solves your problem, the best way to thank me is to not
                      send an "it worked, thanks" follow-up. If you must respond, please put
                      "It worked, thanks" in the "Subject" so I can delete these quickly.
                    • tomzu@buu.lv
                      Hi, Can t figure it out on myself so i decided to ask here :) I have a virtual domain (domain.com) with catch-all alias and only one mailbox (a@domain.com)
                      Message 10 of 14 , Mar 6, 2008
                      View Source
                      • 0 Attachment
                        Hi,

                        Can't figure it out on myself so i decided to ask here :)

                        I have a virtual domain (domain.com) with catch-all alias and only one
                        mailbox (a@...) that get all the mail.
                        But the thing is, if the mail has 3 recipients (b@..., c@...,
                        d@...), the mail gets delivered 3 times.

                        Is there a way to get around that, a get only one copy of mail?

                        /Toms
                      • Charles Marcus
                        tomzu@buu.lv, on 3/6/2008 5:58 AM, said the following: I have a virtual domain (domain.com) with catch-all alias and only one ... Yes... don t use catch-alls.
                        Message 11 of 14 , Mar 6, 2008
                        View Source
                        • 0 Attachment
                          tomzu@..., on 3/6/2008 5:58 AM, said the following:
                          I have a virtual domain (domain.com) with catch-all alias and only one
                          > mailbox (a@...) that get all the mail.
                          > But the thing is, if the mail has 3 recipients (b@..., c@...,
                          > d@...), the mail gets delivered 3 times.
                          >
                          > Is there a way to get around that, a get only one copy of mail?

                          Yes... don't use catch-alls. There are many reasons not to, and I still
                          have never heard a compelling reason to ever use one, except for a
                          domain-wide spam honey-pot type of situation.

                          Enable recipient validation, and if you need aliases, use them... but if
                          you alias b@ and c@ to a@, you will still get 3 messages delivered to a@...

                          --

                          Best regards,

                          Charles
                        • Alexey Lobanov
                          Hi. ... I know a workaround. Intelligent mail storage systems can suppress all duplicates while local delivery, by Message-ID. Cyrus IMAP is an example. Alexey
                          Message 12 of 14 , Mar 6, 2008
                          View Source
                          • 0 Attachment
                            Hi.

                            06.03.2008 13:58, tomzu@... пишет:

                            > Hi,
                            >
                            > Can't figure it out on myself so i decided to ask here :)
                            >
                            > I have a virtual domain (domain.com) with catch-all alias and only one
                            > mailbox (a@...) that get all the mail.
                            > But the thing is, if the mail has 3 recipients (b@..., c@...,
                            > d@...), the mail gets delivered 3 times.
                            >
                            > Is there a way to get around that, a get only one copy of mail?

                            I know a workaround. Intelligent mail storage systems can suppress all
                            duplicates while local delivery, by Message-ID. Cyrus IMAP is an example.

                            Alexey


                            >
                            > /Toms
                            >
                          • tomzu@buu.lv
                            That s an idea! :) Thanks Alex On Thu, 06 Mar 2008 17:05:23 +0300, Alexey Lobanov
                            Message 13 of 14 , Mar 6, 2008
                            View Source
                            • 0 Attachment
                              That's an idea! :) Thanks Alex

                              On Thu, 06 Mar 2008 17:05:23 +0300, Alexey Lobanov <A.Lobanov@...>
                              wrote:
                              > Hi.
                              >
                              > 06.03.2008 13:58, tomzu@... пишет:
                              >
                              >> Hi,
                              >>
                              >> Can't figure it out on myself so i decided to ask here :)
                              >>
                              >> I have a virtual domain (domain.com) with catch-all alias and only one
                              >> mailbox (a@...) that get all the mail.
                              >> But the thing is, if the mail has 3 recipients (b@...,
                              > c@...,
                              >> d@...), the mail gets delivered 3 times.
                              >>
                              >> Is there a way to get around that, a get only one copy of mail?
                              >
                              > I know a workaround. Intelligent mail storage systems can suppress all
                              > duplicates while local delivery, by Message-ID. Cyrus IMAP is an example.
                              >
                              > Alexey
                              >
                              >
                              >>
                              >> /Toms
                              >>
                            • Bill Weiss
                              ... duplicates ... Please note that formail can t tell the difference between duplicate messages and intentional Message-ID collisions. If that matters for
                              Message 14 of 14 , Mar 6, 2008
                              View Source
                              • 0 Attachment
                                Alexey Lobanov(A.Lobanov@...)@Thu, Mar 06, 2008 at 05:05:23PM +0300:
                                > Hi.
                                >
                                > 06.03.2008 13:58, tomzu@... ??????????:
                                >
                                > > Hi,
                                > >
                                > > Can't figure it out on myself so i decided to ask here :)
                                > >
                                > > I have a virtual domain (domain.com) with catch-all alias and only one
                                > > mailbox (a@...) that get all the mail.
                                > > But the thing is, if the mail has 3 recipients (b@..., c@...,
                                > > d@...), the mail gets delivered 3 times.
                                > >
                                > > Is there a way to get around that, a get only one copy of mail?
                                >
                                > I know a workaround. Intelligent mail storage systems can suppress all
                                > duplicates while local delivery, by Message-ID. Cyrus IMAP is an example.

                                Procmail and formail can do this as well. Example from procmailex(5):

                                :0 Whc: msgid.lock
                                | formail -D 8192 msgid.cache

                                :0 a:
                                duplicates

                                Or, if you're sure you don't want those duplicates:

                                :0 Wh: msgid.lock
                                | formail -D 8192 msgid.cache

                                Please note that formail can't tell the difference between duplicate
                                messages and intentional Message-ID collisions. If that matters for you,
                                you might want to come up with some other solution.

                                --
                                Bill Weiss
                              Your message has been successfully submitted and would be delivered to recipients shortly.