Loading ...
Sorry, an error occurred while loading the content.
 

Sender address rejected

Expand Messages
  • Leonard Jacobs
    I am using postfix 2.5.0 and everything seems to be working fine. Several errors have arisen lately that I have not been able to correct. I can t figure out
    Message 1 of 6 , Feb 16, 2008
      I am using postfix 2.5.0 and everything seems to be working fine.
      Several errors have arisen lately that I have not been able to correct.

      I can't figure out how to parse this error message or correct the
      undeliverable problem:

      Feb 13 08:44:40 postfix postfix/smtpd[14716]: NOQUEUE: reject: RCPT from
      parsley.oreillynet.com[208.201.239.25]: 450 4.1.7
      <edd@...>: Sender address rejected: unverified
      address: connect to parsley.oreillynet.com[208.201.239.25]:25:
      Connection refused; from=<edd@...>
      to=<ljacobs@...> proto=ESMTP helo=<parsley.oreillynet.com>
      Feb 13 08:44:40 postfix postfix/smtpd[14716]: NOQUEUE: reject: RCPT from
      parsley.oreillynet.com[208.201.239.25]: 450 4.1.7
      <edd@...>: Sender address rejected: unverified
      address: connect to parsley.oreillynet.com[208.201.239.25]:25:
      Connection refused; from=<edd@...>
      to=<ljacobs@...> proto=ESMTP helo=<parsley.oreillynet.com>

      Or this log message, which I understand may be a result of a different
      problem.

      Feb 14 13:39:38 postfix postfix/smtpd[29966]: NOQUEUE: reject: RCPT from
      gwa6.webcontrolcenter.com[63.134.207.31]: 550 5.1.7
      <mt@...>: Sender address rejected: undeliverable address:
      host mailb5.webcontrolcenter.com[216.119.115.134] said: 550 Sender is
      not allowed. (in reply to MAIL FROM command); from=<mt@...>
      to=<jgreen@...> proto=ESMTP helo=<gwa6.webcontrolcenter.com>

      My postconf -n output:

      address_verify_map = btree:/var/lib/postfix/address_verify.map
      address_verify_negative_cache = yes
      address_verify_negative_expire_time = 3d
      address_verify_negative_refresh_time = 12h
      address_verify_positive_expire_time = 31d
      address_verify_positive_refresh_time = 7d
      address_verify_sender = postmaster
      alias_database = hash:/etc/postfix/aliases
      alias_maps = hash:/etc/postfix/aliases
      biff = no
      body_checks = pcre:/etc/postfix/body_checks.regexp
      body_checks_size_limit = 250000
      bounce_notice_recipient = ljacobs@...
      bounce_size_limit = 10000
      command_directory = /usr/sbin
      config_directory = /etc/postfix
      content_filter = smtp-amavis:[127.0.0.1]:10024
      daemon_directory = /usr/libexec/postfix
      data_directory = /var/lib/postfix
      debug_peer_level = 2
      default_destination_concurrency_limit = 100
      default_destination_recipient_limit = 50
      default_privs = nobody
      default_process_limit = 200
      delay_notice_recipient = ljacobs@...
      delay_warning_time = 4h
      disable_vrfy_command = yes
      double_bounce_sender = double-bounce
      empty_address_recipient = MAILER-DAEMON
      error_notice_recipient = ljacobs@...
      header_checks = pcre:/etc/postfix/header_checks.regexp
      header_size_limit = 256
      html_directory = no
      ignore_mx_lookup_error = yes
      in_flow_delay = 1s
      inet_interfaces = all
      local_destination_concurrency_limit = 2
      local_recipient_maps =
      mail_owner = postfix
      mail_spool_directory = /var/spool/mail
      mailbox_command = /usr/bin/procmail
      mailq_path = /usr/bin/mailq
      manpage_directory = /usr/local/man
      maximal_backoff_time = 1000s
      maximal_queue_lifetime = 5d
      message_size_limit = 20000000
      mime_header_checks = pcre:/etc/postfix/mime_header_checks.regexp
      minimal_backoff_time = 300s
      mydestination = $myhostname, localhost.$mydomain, $mydomain, lists.$mydomain, lists.shambhala.com
      mydomain = mandala-designs.com
      mynetworks = 127.0.0.1, 192.168.1.0/24, xxx.xxx.57.98, xxx.xxx.116.135
      myorigin = $mydomain
      newaliases_path = /usr/bin/newaliases
      owner_request_special = no
      queue_directory = /var/spool/postfix
      readme_directory = /etc/postfix/readme
      recipient_delimiter = +
      relay_domains = $mynetworks, shambhala.com, hash:/etc/postfix/transport.map
      sample_directory = /etc/postfix
      sendmail_path = /usr/sbin/sendmail
      setgid_group = postdrop
      smtp_always_send_ehlo = yes
      smtpd_banner = $myhostname - ESMTP - $mail_name - Attn: UCE trespassers will be pursued.
      smtpd_hard_error_limit = 20
      smtpd_helo_required = yes
      smtpd_recipient_restrictions = reject_unauth_pipelining,
      reject_non_fqdn_sender,
      reject_non_fqdn_recipient,
      reject_unverified_recipient,
      reject_unknown_sender_domain,
      reject_unverified_sender,
      permit_mynetworks,
      check_sender_access hash:/etc/postfix/myspamlist.map,
      reject_unauth_destination,
      check_policy_service inet:127.0.0.1:10023,
      pcre:/etc/postfix/to_recipients_bw.regexp
      reject_non_fqdn_hostname,
      reject_rbl_client bl.spamcop.net,
      reject_rbl_client zen.spamhaus.org,
      reject_rbl_client sub.mxrate.net=127.0.0.2,
      reject_rbl_client dul.dnsbl.sorbs.net,
      reject_rbl_client korea.services.net,
      reject_rbl_client dnsbl.njabl.org,
      reject_rbl_client sub.mxrate.net=127.0.0.4,
      reject_rbl_client list.dsbl.org,
      reject_rbl_client cbl.abuseat.org,
      warn_if_reject reject_invalid_hostname,
      warn_if_reject reject_unknown_hostname,
      warn_if_reject reject_non_fqdn_hostname,
      reject_rhsbl_sender bulk.rhs.mailpolice.com,
      reject_rhsbl_sender porn.rhs.mailpolice.com,
      permit
      strict_rfc821_envelopes = yes
      transport_maps = hash:/etc/postfix/transport.map
      unknown_address_reject_code = 554
      unknown_client_reject_code = 554
      unknown_hostname_reject_code = 554
      unknown_local_recipient_reject_code = 550

      Any advice would be appreciated.
      unverified_sender_reject_code = 550



      ---
      [This E-mail scanned for viruses by Declude EVA]
    • Justin Piszcz
      ... Here you are using sender address verification, it is trying to verify that address at parsley.oreillynet.com but it cannot connect to it, so until that is
      Message 2 of 6 , Feb 16, 2008
        On Sat, 16 Feb 2008, Leonard Jacobs wrote:

        > I am using postfix 2.5.0 and everything seems to be working fine. Several
        > errors have arisen lately that I have not been able to correct.
        >
        > I can't figure out how to parse this error message or correct the
        > undeliverable problem:
        >
        > Feb 13 08:44:40 postfix postfix/smtpd[14716]: NOQUEUE: reject: RCPT from
        > parsley.oreillynet.com[208.201.239.25]: 450 4.1.7
        > <edd@...>: Sender address rejected: unverified address:
        > connect to parsley.oreillynet.com[208.201.239.25]:25: Connection refused;
        > from=<edd@...> to=<ljacobs@...> proto=ESMTP
        > helo=<parsley.oreillynet.com>
        > Feb 13 08:44:40 postfix postfix/smtpd[14716]: NOQUEUE: reject: RCPT from
        > parsley.oreillynet.com[208.201.239.25]: 450 4.1.7
        > <edd@...>: Sender address rejected: unverified address:
        > connect to parsley.oreillynet.com[208.201.239.25]:25: Connection refused;
        > from=<edd@...> to=<ljacobs@...> proto=ESMTP
        > helo=<parsley.oreillynet.com>
        Here you are using sender address verification, it is trying to verify
        that address at parsley.oreillynet.com but it cannot connect to it, so
        until that is resolved, it will error with 450 (until it can confirm or
        reject the presence of that address).

        If you read up on SAV, its mostly unwelcomed and probably a good idea not
        to use it, there's even lists that you could get added to (RBLs that list
        people who do the SAV callouts).

        >
        > Or this log message, which I understand may be a result of a different
        > problem.
        >
        > Feb 14 13:39:38 postfix postfix/smtpd[29966]: NOQUEUE: reject: RCPT from
        > gwa6.webcontrolcenter.com[63.134.207.31]: 550 5.1.7 <mt@...>:
        > Sender address rejected: undeliverable address: host
        > mailb5.webcontrolcenter.com[216.119.115.134] said: 550 Sender is not allowed.
        > (in reply to MAIL FROM command); from=<mt@...>
        > to=<jgreen@...> proto=ESMTP helo=<gwa6.webcontrolcenter.com>
        Unsure on this one.

        >
        > My postconf -n output:
        >
        > address_verify_map = btree:/var/lib/postfix/address_verify.map
        > address_verify_negative_cache = yes
        > address_verify_negative_expire_time = 3d
        > address_verify_negative_refresh_time = 12h
        > address_verify_positive_expire_time = 31d
        > address_verify_positive_refresh_time = 7d
        > address_verify_sender = postmaster
        > alias_database = hash:/etc/postfix/aliases
        > alias_maps = hash:/etc/postfix/aliases
        > biff = no
        > body_checks = pcre:/etc/postfix/body_checks.regexp
        > body_checks_size_limit = 250000
        > bounce_notice_recipient = ljacobs@...
        > bounce_size_limit = 10000
        > command_directory = /usr/sbin
        > config_directory = /etc/postfix
        > content_filter = smtp-amavis:[127.0.0.1]:10024
        > daemon_directory = /usr/libexec/postfix
        > data_directory = /var/lib/postfix
        > debug_peer_level = 2
        > default_destination_concurrency_limit = 100
        > default_destination_recipient_limit = 50
        > default_privs = nobody
        > default_process_limit = 200
        > delay_notice_recipient = ljacobs@...
        > delay_warning_time = 4h
        > disable_vrfy_command = yes
        > double_bounce_sender = double-bounce
        > empty_address_recipient = MAILER-DAEMON
        > error_notice_recipient = ljacobs@...
        > header_checks = pcre:/etc/postfix/header_checks.regexp
        > header_size_limit = 256
        > html_directory = no
        > ignore_mx_lookup_error = yes
        > in_flow_delay = 1s
        > inet_interfaces = all
        > local_destination_concurrency_limit = 2
        > local_recipient_maps = mail_owner = postfix
        > mail_spool_directory = /var/spool/mail
        > mailbox_command = /usr/bin/procmail
        > mailq_path = /usr/bin/mailq
        > manpage_directory = /usr/local/man
        > maximal_backoff_time = 1000s
        > maximal_queue_lifetime = 5d
        > message_size_limit = 20000000
        > mime_header_checks = pcre:/etc/postfix/mime_header_checks.regexp
        > minimal_backoff_time = 300s
        > mydestination = $myhostname, localhost.$mydomain, $mydomain, lists.$mydomain,
        > lists.shambhala.com
        > mydomain = mandala-designs.com
        > mynetworks = 127.0.0.1, 192.168.1.0/24, xxx.xxx.57.98, xxx.xxx.116.135
        > myorigin = $mydomain
        > newaliases_path = /usr/bin/newaliases
        > owner_request_special = no
        > queue_directory = /var/spool/postfix
        > readme_directory = /etc/postfix/readme
        > recipient_delimiter = +
        > relay_domains = $mynetworks, shambhala.com, hash:/etc/postfix/transport.map
        > sample_directory = /etc/postfix
        > sendmail_path = /usr/sbin/sendmail
        > setgid_group = postdrop
        > smtp_always_send_ehlo = yes
        > smtpd_banner = $myhostname - ESMTP - $mail_name - Attn: UCE trespassers will
        > be pursued.
        > smtpd_hard_error_limit = 20
        > smtpd_helo_required = yes
        > smtpd_recipient_restrictions = reject_unauth_pipelining,
        > reject_non_fqdn_sender, reject_non_fqdn_recipient,
        > reject_unverified_recipient, reject_unknown_sender_domain,
        > reject_unverified_sender, permit_mynetworks, check_sender_access
        > hash:/etc/postfix/myspamlist.map, reject_unauth_destination,
        > check_policy_service inet:127.0.0.1:10023,
        > pcre:/etc/postfix/to_recipients_bw.regexp reject_non_fqdn_hostname,
        > reject_rbl_client bl.spamcop.net, reject_rbl_client zen.spamhaus.org,
        > reject_rbl_client sub.mxrate.net=127.0.0.2, reject_rbl_client
        > dul.dnsbl.sorbs.net, reject_rbl_client korea.services.net, reject_rbl_client
        > dnsbl.njabl.org, reject_rbl_client sub.mxrate.net=127.0.0.4,
        > reject_rbl_client list.dsbl.org, reject_rbl_client cbl.abuseat.org,
        > warn_if_reject reject_invalid_hostname, warn_if_reject
        > reject_unknown_hostname, warn_if_reject reject_non_fqdn_hostname,
        > reject_rhsbl_sender bulk.rhs.mailpolice.com, reject_rhsbl_sender
        > porn.rhs.mailpolice.com, permit
        > strict_rfc821_envelopes = yes
        > transport_maps = hash:/etc/postfix/transport.map
        > unknown_address_reject_code = 554
        > unknown_client_reject_code = 554
        > unknown_hostname_reject_code = 554
        > unknown_local_recipient_reject_code = 550
        >
        > Any advice would be appreciated.
        > unverified_sender_reject_code = 550
        >
        >
        >
        > ---
        > [This E-mail scanned for viruses by Declude EVA]
        >
        >
      • Krzysztof Szarlej
        Hey guys I ve a problem with my SMTP. I have set the postfix togoether with dovecot, I turned on sasl and tls and I can t send the messages. I am getting error
        Message 3 of 6 , Jul 18, 2013
          Hey guys I've a problem with my SMTP. I have set the postfix togoether with dovecot, I turned on sasl and tls and I can't send the messages. I am getting error

          SMTP: '450 4.1.2 <user@...>: Recipient address rejected: Domain not found',

          From main.cf here are my smtpd rules:

          -----
          smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination
          smtpd_sasl_auth_enable = yes
          smtpd_sasl_path = private/auth
          smtpd_sasl_security_options = noanonymous
          smtpd_sasl_type = dovecot
          smtpd_tls_auth_only = yes
          smtpd_tls_cert_file = /etc/ssl/certs/mail.pem
          smtpd_tls_key_file = /etc/ssl/private/mail.key
          smtpd_tls_security_level = encrypt
          smtpd_tls_wrappermode = no
          unknown_local_recipient_reject_code = 550
          -------

          Records in my zone seems to be alright: (i paste all but SOA)

          ----
          mydomain.eu. 86400 IN MX 10 mail.mydomain.eu.
          mydomain.eu. 86400 IN NS fns1.42.pl.
          mydomain.eu. 86400 IN NS fns2.42.pl.

          mydomain.eu. 86400 IN A vpsIP
          mail.mydomain.eu. 86400 IN A vpsIP
          www.mydomain.eu. 86400 IN A vpsIP
          -----

          I have revDNS configured. I am able to receive mails from outside (i.e from gmail, but i am not able to send any messages).

          Any suggestions? Tried to play with smtpd_restrictions but I faild. Also changed the smtpd_tls_securiity_level to may. Changed it also in master.cf (i have configuration for port 587 there) and it still did not work. the port 587 configuration in master.cf goes as follows:

          submission inet n       -       -       -       -       smtpd
            -o smtpd_tls_security_level=encrypt
            -o smtpd_sasl_auth_enable=yes
            -o milter_macro_daemon_name=ORIGINATING
            -o smtpd_client_restrictions=
            -o smtpd_helo_restrictions=
            -o smtpd_sender_restrictions=reject_sender_login_mismatch,permit
            -o smtpd_sender_restrictions=permit_sasl_authenticated,reject
            -o smtpd_recipient_restrictions=reject_non_fqdn_recipient,reject_unknown_recipient_domain,permit_sasl_authenticated,reject


          regards
          Krzysztof
        • Noel Jones
          ... Please show the full, unaltered log entry (in plain text only, HTML markup makes the logs difficult to read). For more help, please see:
          Message 4 of 6 , Jul 18, 2013
            On 7/18/2013 7:55 PM, Krzysztof Szarlej wrote:
            > Hey guys I've a problem with my SMTP. I have set the postfix
            > togoether with dovecot, I turned on sasl and tls and I can't send
            > the messages. I am getting error
            >
            > SMTP: '450 4.1.2 <user@... <mailto:user@...>>: Recipient
            > address rejected: Domain not found',

            Please show the full, unaltered log entry (in plain text only, HTML
            markup makes the logs difficult to read).

            For more help, please see:
            http://www.postfix.org/DEBUG_README.html#mail


            My wild guess is you need to turn off the chroot flag in master.cf
            for the submission service (and if that works, for every other
            service). http://www.postfix.org/DEBUG_README.html#no_chroot


            -- Noel Jones



            >
            > From main.cf <http://main.cf> here are my smtpd rules:
            >
            > -----
            > smtpd_recipient_restrictions = permit_mynetworks,
            > permit_sasl_authenticated, reject_unauth_destination
            > smtpd_sasl_auth_enable = yes
            > smtpd_sasl_path = private/auth
            > smtpd_sasl_security_options = noanonymous
            > smtpd_sasl_type = dovecot
            > smtpd_tls_auth_only = yes
            > smtpd_tls_cert_file = /etc/ssl/certs/mail.pem
            > smtpd_tls_key_file = /etc/ssl/private/mail.key
            > smtpd_tls_security_level = encrypt
            > smtpd_tls_wrappermode = no
            > unknown_local_recipient_reject_code = 550
            > -------
            >
            > Records in my zone seems to be alright: (i paste all but SOA)
            >
            > ----
            > mydomain.eu <http://mydomain.eu>. 86400 IN MX 10 mail.mydomain.eu
            > <http://mail.mydomain.eu>.
            > mydomain.eu <http://mydomain.eu>. 86400 IN NS fns1.42.pl
            > <http://fns1.42.pl>.
            > mydomain.eu <http://mydomain.eu>. 86400 IN NS fns2.42.pl
            > <http://fns2.42.pl>.
            >
            > mydomain.eu <http://mydomain.eu>. 86400 IN A vpsIP
            > mail.mydomain.eu <http://mail.mydomain.eu>. 86400 IN A vpsIP
            > www.mydomain.eu <http://www.mydomain.eu>. 86400 IN A vpsIP
            > -----
            >
            > I have revDNS configured. I am able to receive mails from outside
            > (i.e from gmail, but i am not able to send any messages).
            >
            > Any suggestions? Tried to play with smtpd_restrictions but I faild.
            > Also changed the smtpd_tls_securiity_level to may. Changed it also
            > in master.cf <http://master.cf> (i have configuration for port 587
            > there) and it still did not work. the port 587 configuration in
            > master.cf <http://master.cf> goes as follows:
            >
            > submission inet n - - - - smtpd
            > -o smtpd_tls_security_level=encrypt
            > -o smtpd_sasl_auth_enable=yes
            > -o milter_macro_daemon_name=ORIGINATING
            > -o smtpd_client_restrictions=
            > -o smtpd_helo_restrictions=
            > -o smtpd_sender_restrictions=reject_sender_login_mismatch,permit
            > -o smtpd_sender_restrictions=permit_sasl_authenticated,reject
            > -o
            > smtpd_recipient_restrictions=reject_non_fqdn_recipient,reject_unknown_recipient_domain,permit_sasl_authenticated,reject
            >
            >
            > regards
            > Krzysztof
          • Krzysztof Szarlej
            Well after i made some changes the postfix dont want to start. I mean the smpt, it says it that connect timeout exceeded. # tail /var/log/maillog Jul 19
            Message 5 of 6 , Jul 19, 2013
              Well after i made some changes the postfix dont want to start. I mean the smpt, it says it that connect timeout exceeded.

              # tail /var/log/maillog

              Jul 19 09:01:54 szarlej postfix/master[4428]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
              Jul 19 09:02:54 szarlej postfix/smtpd[4549]: fatal: parameter "smtpd_recipient_restrictions": specify at least one working instance of: check_relay_domains, reject_unauth_destination, reject, defer or defer_if_permit
              Jul 19 09:02:55 szarlej postfix/master[4428]: warning: process /usr/libexec/postfix/smtpd pid 4549 exit status 1
              Jul 19 09:02:55 szarlej postfix/master[4428]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling

              my recipient restrictions now:

              smtpd_recipient_restrictions = reject_non_fqdn_recipient, check_relay_domains, permit_sasl_authenticated, permit_mynetworks, reject_unauth_destination, reject_unlisted_recipient, reject_invalid_hostname, reject_non_fqdn_sender, permit


            • /dev/rob0
              ... Not likely so, look at postconf smtpd_recipient_restrictions . ... Leading whitespace is required for line continuations. See man 5 postconf for file
              Message 6 of 6 , Jul 19, 2013
                On Fri, Jul 19, 2013 at 09:05:52AM +0200, Krzysztof Szarlej wrote:
                > Well after i made some changes the postfix dont want to start. I
                > mean the smpt, it says it that connect timeout exceeded.
                >
                > # tail /var/log/maillog
                >
                > Jul 19 09:01:54 szarlej postfix/master[4428]: warning:
                > /usr/libexec/postfix/smtpd: bad command startup -- throttling
                > Jul 19 09:02:54 szarlej postfix/smtpd[4549]: fatal: parameter
                > "smtpd_recipient_restrictions": specify at least one working
                > instance of: check_relay_domains, reject_unauth_destination,
                > reject, defer or defer_if_permit
                > Jul 19 09:02:55 szarlej postfix/master[4428]: warning: process
                > /usr/libexec/postfix/smtpd pid 4549 exit status 1
                > Jul 19 09:02:55 szarlej postfix/master[4428]: warning:
                > /usr/libexec/postfix/smtpd: bad command startup -- throttling
                >
                > my recipient restrictions now:

                Not likely so, look at "postconf smtpd_recipient_restrictions".

                > smtpd_recipient_restrictions = reject_non_fqdn_recipient,
                > check_relay_domains, permit_sasl_authenticated, permit_mynetworks,

                Leading whitespace is required for line continuations. See "man 5
                postconf" for file syntax. Also, remove check_relay_domains. It's
                deprecated and not needed anyway.

                > reject_unauth_destination, reject_unlisted_recipient,
                > reject_invalid_hostname, reject_non_fqdn_sender, permit

                Before posting again, review Noel's post and the URL given. Your
                followup was inadequate without "postconf -n" output.
                --
                http://rob0.nodns4.us/ -- system administration and consulting
                Offlist GMX mail is seen only if "/dev/rob0" is in the Subject:
              Your message has been successfully submitted and would be delivered to recipients shortly.