Loading ...
Sorry, an error occurred while loading the content.

Autoresponder

Expand Messages
  • Nigel Kendrick
    Hi, Having given up on vacation because it just seems to not do anything, I have been trying to use the following to setup an autoresponder for a one user:
    Message 1 of 9 , Feb 14 4:45 AM
    • 0 Attachment
      Hi,

      Having given up on vacation because it just seems to not do anything, I have
      been trying to use the following to setup an autoresponder for a one user:

      http://workaround.org/moin/PostfixTutorialContributions

      Autoresponder

      Contributed by Bjoern Meier

      * Use an entry in the forwardings table to forward email for a certain
      user to the email address user@...@...

      * Add an entry to the transport file that sends email for the domain
      autoreply.domain.tld to the autoreply: transport service:

      autoreply.domain.tld autoreply:

      * Add a service to the master.cf like this:

      autoreply unix - n n - - pipe
      flags= user=mailer argv=/usr/local/bin/autoreply $sender $recipient

      * Create an executable batch script in

      /usr/local/bin/autoreply: mail -s"Zur Zeit im Urlaub" -a"From: <$2>"
      $1 < /etc/postfix/autoreply.txt

      * Put an autoreply text into the file /etc/postfix/autoreply.txt

      * Reload Postfix



      The only thing I have changed is that the -a option is not supported by our
      mail command (Centos 4) so I have removed it.

      One thing I am not sure about is the first step - we are using a virtual
      file and so for the user I have a line like this:

      testuser testuser@...

      which I have changed to:

      testuser testuser@...

      but the instruction above implies the destination is set to:
      testuser@...@...

      or is this a typo??

      I believe I have everything in place but the maillog always shows that
      emails to 'testuser@...' are being forwarded to our
      external mail relay, which then bounces them as undeliverable - it's as if
      the transport is being ignored (I have 'postmap'ed the edited file.

      Is there anyone who has this working (or tips on 'vacation'?).

      Thanks

      Nigel Kendrick
    • postfix
      Hi Nigel thats exactly how we did it: /etc/postfix/master.cf autoreply unix - n n - - pipe flags= user=webadmin
      Message 2 of 9 , Feb 14 5:31 AM
      • 0 Attachment
        Hi Nigel
        thats exactly how we did it:

        /etc/postfix/master.cf
        autoreply unix - n n - - pipe
        flags= user=webadmin argv=/var/lib/autoreply/autoreply.pl $sender $mailbox

        /etc/postfix/transport
        autoreply.domain.tld autoreply:

        and then forward the users, who want an autoreply, to

        user.name@...@...

        how complicated you make the script depends on your site: here, the
        scripts gets its parameters from the LDAP directory.

        suomi


        Nigel Kendrick wrote:
        > Hi,
        >
        > Having given up on vacation because it just seems to not do anything, I have
        > been trying to use the following to setup an autoresponder for a one user:
        >
        > http://workaround.org/moin/PostfixTutorialContributions
        >
        > Autoresponder
        >
        > Contributed by Bjoern Meier
        >
        > * Use an entry in the forwardings table to forward email for a certain
        > user to the email address user@...@...
        >
        > * Add an entry to the transport file that sends email for the domain
        > autoreply.domain.tld to the autoreply: transport service:
        >
        > autoreply.domain.tld autoreply:
        >
        > * Add a service to the master.cf like this:
        >
        > autoreply unix - n n - - pipe
        > flags= user=mailer argv=/usr/local/bin/autoreply $sender $recipient
        >
        > * Create an executable batch script in
        >
        > /usr/local/bin/autoreply: mail -s"Zur Zeit im Urlaub" -a"From: <$2>"
        > $1 < /etc/postfix/autoreply.txt
        >
        > * Put an autoreply text into the file /etc/postfix/autoreply.txt
        >
        > * Reload Postfix
        >
        >
        >
        > The only thing I have changed is that the -a option is not supported by our
        > mail command (Centos 4) so I have removed it.
        >
        > One thing I am not sure about is the first step - we are using a virtual
        > file and so for the user I have a line like this:
        >
        > testuser testuser@...
        >
        > which I have changed to:
        >
        > testuser testuser@...
        >
        > but the instruction above implies the destination is set to:
        > testuser@...@...
        >
        > or is this a typo??
        >
        > I believe I have everything in place but the maillog always shows that
        > emails to 'testuser@...' are being forwarded to our
        > external mail relay, which then bounces them as undeliverable - it's as if
        > the transport is being ignored (I have 'postmap'ed the edited file.
        >
        > Is there anyone who has this working (or tips on 'vacation'?).
        >
        > Thanks
        >
        > Nigel Kendrick
        >
      • Nigel Kendrick
        Just replying to myself! I have added the following to main.cf transport_maps = hash:/etc/postfix/transport so that alternative transports are actually
        Message 3 of 9 , Feb 14 6:06 AM
        • 0 Attachment
          Just replying to myself!

          I have added the following to main.cf

          transport_maps = hash:/etc/postfix/transport

          so that alternative transports are actually noticed!

          I also created a user called 'noreply' and changed master.cf as follows:

          autoreply unix - n n - - pipe
          flags= user=noreply argv=/usr/local/bin/autoreply $sender $recipient


          Autoreplies are now working but they all come from
          'noreply@...'. Is there a way to set the sender of the auto
          reply as the intended recipient of the original message? I have tried
          various macros in 'user=' without much success or does it come back down to
          the -a parameter in the mail command?

          Thanks
        • AlxFrag
          ... if you can t make it work, you can try the script vacation.pl contained in the postfixadmin package. This has similar configuration with that you ve
          Message 4 of 9 , Feb 15 12:02 AM
          • 0 Attachment
            Nigel Kendrick wrote:
            >
            > Just replying to myself!
            >
            > I have added the following to main.cf
            >
            > transport_maps = hash:/etc/postfix/transport
            >
            > so that alternative transports are actually noticed!
            >
            > I also created a user called 'noreply' and changed master.cf as follows:
            >
            > autoreply unix - n n - - pipe
            > flags= user=noreply argv=/usr/local/bin/autoreply $sender $recipient
            >
            >
            > Autoreplies are now working but they all come from
            > 'noreply@...'. Is there a way to set the sender of the auto
            > reply as the intended recipient of the original message? I have tried
            > various macros in 'user=' without much success or does it come back down to
            > the -a parameter in the mail command?
            >
            > Thanks
            >
            >
            >
            if you can't make it work, you can try the script 'vacation.pl'
            contained in the postfixadmin package.
            This has similar configuration with that you've described.
          • Márcio Luciano Donada
            Hi list, I am using the autoresponder to send holiday of users. But to enable it, type the queue problems with e-mail has increased significantly and also with
            Message 5 of 9 , Feb 5 7:50 AM
            • 0 Attachment
              Hi list,
              I am using the autoresponder to send holiday of users. But to enable it,
              type the queue problems with e-mail has increased significantly and also
              with the delivery of messages that were passed to autorespoder not
              arrived in the User's

              My configuration: (master.cf)

              smtp inet n - - - - smtpd
              -o content_filter=autoresponder:dummy

              autoresponder unix - n n - - pipe
              flags=Fq user=autoresponse argv=/usr/local/sbin/autoresponse -s
              ${sender} -r ${recipient} -S ${sasl_username} -C ${client_address}


              in main.cf
              autoresponder_destination_recipient_limit = 1

              My question is, that makes any e-mail passing through autoresponse. What
              I would like to happen is that only to be sent to the user autoresponse
              that has enabled it. Does anyone have a about this?

              --
              Márcio Luciano Donada <mdonada -at- auroraalimentos -dot- com -dot- br>
              Aurora Alimentos - Cooperativa Central Oeste Catarinense
              Departamento de T.I.
              Vacation in 3 days!!!
            • Muhammed Sameer
              Hey, * You may have to use a combination of lookup + transport, ie use either a hash, RDBMS map to query which users have autoresponder enabled and then feed
              Message 6 of 9 , Feb 5 12:45 PM
              • 0 Attachment
                Hey,

                * You may have to use a combination of lookup + transport, ie use either a hash, RDBMS map to query which users have autoresponder enabled and then feed those mails to the transport autoresponder

                Regards,
                Muhammed Sameer

                --- On Fri, 2/5/10, Márcio Luciano Donada <mdonada@...> wrote:

                > From: Márcio Luciano Donada <mdonada@...>
                > Subject: Autoresponder
                > To: "Postfix users" <postfix-users@...>
                > Date: Friday, February 5, 2010, 10:50 AM
                > Hi list,
                > I am using the autoresponder to send holiday of users. But
                > to enable it,
                > type the queue problems with e-mail has increased
                > significantly and also
                > with the delivery of messages that were passed to
                > autorespoder not
                > arrived in the User's
                >
                > My configuration: (master.cf)
                >
                > smtp      inet  n   
                >    -       - 
                >      -   
                >    -       smtpd
                >    -o content_filter=autoresponder:dummy
                >
                > autoresponder unix - n n - - pipe
                >      flags=Fq user=autoresponse
                > argv=/usr/local/sbin/autoresponse -s
                > ${sender} -r ${recipient} -S ${sasl_username} -C
                > ${client_address}
                >
                >
                > in main.cf
                > autoresponder_destination_recipient_limit = 1
                >
                > My question is, that makes any e-mail passing through
                > autoresponse. What
                > I would like to happen is that only to be sent to the user
                > autoresponse
                > that has enabled it. Does anyone have a about this?
                >
                > --
                > Márcio Luciano Donada <mdonada -at- auroraalimentos
                > -dot- com -dot- br>
                > Aurora Alimentos - Cooperativa Central Oeste Catarinense
                > Departamento de T.I.
                > Vacation in 3 days!!!
                >
              • mouss
                ... Writing a vacation auto-responder is not easy. There are way too many borked auto-responders. so please don t add yet another one. if you use dovecot, then
                Message 7 of 9 , Feb 5 1:37 PM
                • 0 Attachment
                  Márcio Luciano Donada a écrit :
                  > Hi list,
                  > I am using the autoresponder to send holiday of users. But to enable it,
                  > type the queue problems with e-mail has increased significantly and also
                  > with the delivery of messages that were passed to autorespoder not
                  > arrived in the User's
                  >
                  > My configuration: (master.cf)
                  >
                  > smtp inet n - - - - smtpd
                  > -o content_filter=autoresponder:dummy
                  >
                  > autoresponder unix - n n - - pipe
                  > flags=Fq user=autoresponse argv=/usr/local/sbin/autoresponse -s
                  > ${sender} -r ${recipient} -S ${sasl_username} -C ${client_address}
                  >
                  >
                  > in main.cf
                  > autoresponder_destination_recipient_limit = 1
                  >
                  > My question is, that makes any e-mail passing through autoresponse. What
                  > I would like to happen is that only to be sent to the user autoresponse
                  > that has enabled it. Does anyone have a about this?
                  >

                  Writing a vacation auto-responder is not easy. There are way too many
                  borked auto-responders. so please don't add yet another one.

                  if you use dovecot, then use its vacation plugin.
                  if you use "local" accounts, then use the "old" vacation program.
                  ...

                  if you want to write your own, then take the time to read and understand
                  RFC 3834
                  http://tools.ietf.org/html/rfc3834
                  If you find this hard, then please understand that it is hard for us
                  when we get unsollicited auto-responses (search the web for "backscatter").
                • pch0317
                  Hi list, I would like to create autoresponder functionality in my mail system, but I don t know how to start. User should turn on/off autoresponder from client
                  Message 8 of 9 , Nov 2, 2011
                  • 0 Attachment
                    Hi list,

                    I would like to create autoresponder functionality in my mail system,
                    but I don't know how to start.
                    User should turn on/off autoresponder from client application and set
                    message text which will be send in autoreply message.

                    My system work on RHEL 6.1: postfix, dovecot, squirrelmail, users are
                    from Active Directory Server 2003. Users work with Thunderbird 7,
                    Outlook 2007 and 2010. Users haven't technical knowledge and they
                    haven't shell access to server.

                    How to create autoresponder functionality in my environment.



                    Thanks
                  • Patrick Ben Koetter
                    ... I take it you mean vacation when you write autoresponder. There is no vacation plugin that works from within all your clients. The easiest way will be to
                    Message 9 of 9 , Nov 2, 2011
                    • 0 Attachment
                      * pch0317 <pch0317@...>:
                      > Hi list,
                      >
                      > I would like to create autoresponder functionality in my mail
                      > system, but I don't know how to start.
                      > User should turn on/off autoresponder from client application and
                      > set message text which will be send in autoreply message.
                      >
                      > My system work on RHEL 6.1: postfix, dovecot, squirrelmail, users
                      > are from Active Directory Server 2003. Users work with Thunderbird
                      > 7, Outlook 2007 and 2010. Users haven't technical knowledge and they
                      > haven't shell access to server.
                      >
                      > How to create autoresponder functionality in my environment.

                      I take it you mean 'vacation' when you write autoresponder.

                      There is no vacation plugin that works from within all your clients. The
                      easiest way will be to offer a webmail client, in your case squirrelmal, that
                      interfaces with the server to en-/disable vacation.

                      I recommend you use the managesieve server, it is part of dovecot, and also
                      enable sieve filtering in dovecot.

                      The Webmail client will use the managesieve protocol to tell the managesieve
                      server it should enable vacation. The sieve filter will send a vacation reply
                      to any sender.

                      +------------+ managesieve +-------------+
                      | Webmail |+------------> | Dovecot |
                      |------------| avelsieve |-------------|
                      | | | |
                      | | | |
                      | | | sieve |
                      +------------+ +-------------+
                      + +
                      | |
                      | |
                      +------------+ e-mail | |
                      | sender | +--------------+ |
                      |------------| |
                      | | autoreply |
                      | | ++------------------------+
                      +------------+

                      I haven't used squirrelmail in a while, but instead of a plugin speaking
                      managesieve you may need to run Avelsieve <http://email.uoa.gr/avelsieve/> to
                      create sieve filter rules.

                      p@rick


                      --
                      All technical questions asked privately will be automatically answered on the
                      list and archived for public access unless privacy is explicitely required and
                      justified.

                      saslfinger (debugging SMTP AUTH):
                      <http://postfix.state-of-mind.de/patrick.koetter/saslfinger/>
                    Your message has been successfully submitted and would be delivered to recipients shortly.