Loading ...
Sorry, an error occurred while loading the content.

mail deferring incorrectly?

Expand Messages
  • Ed W
    Hi, I m using Postfix 2.2.5. My mail to xxx@ast-uk.com is sitting in the outbound queue (for hours) with error message: (delivery temporarily suspended:
    Message 1 of 3 , Aug 1, 2007
    • 0 Attachment
      Hi,

      I'm using Postfix 2.2.5. My mail to xxx@... is sitting in the
      outbound queue (for hours) with error message:
      (delivery temporarily suspended: connect to
      mx2.ast-uk.com[80.229.47.244]: Connection timed out)

      However, if I check dig I see:

      ;; ANSWER SECTION:
      ast-uk.com. 13471 IN MX 20 mx2.ast-uk.com.
      ast-uk.com. 13471 IN MX 10 mx.ast-uk.com.


      A quick test shows that mx2 is there, but times out on a telnet to 25.
      However, mx is working fine.

      Q: How come postfix continuously tries only the highest priority MX and
      is never failing over to the secondary MX? How can I make it do so in
      this case (clearly mx2 is dead, but not dead enough..)

      Thanks

      Ed W
    • Ed W
      ... Oh bother - sorry yes of course (once again) you are absolutely correct. Failure to read the log files Sorry for the noise - thanks for your endless help
      Message 2 of 3 , Aug 1, 2007
      • 0 Attachment
        > You have shown no evidence that Postfix does not first try the primary
        > MX, and if you check your logs closely, you will find that it does.
        >


        Oh bother - sorry yes of course (once again) you are absolutely
        correct. Failure to read the log files

        Sorry for the noise - thanks for your endless help and attention Victor

        Ed W
      Your message has been successfully submitted and would be delivered to recipients shortly.