Loading ...
Sorry, an error occurred while loading the content.

parameter setgid_group: unknown group name: postdrop

Expand Messages
  • JOYDEEP
    Dear list, could any one kindly help me to fix it ? after starting postconf I get the error ===================================== parameter setgid_group:
    Message 1 of 5 , Jun 1, 2007
    • 0 Attachment
      Dear list,

      could any one kindly help me to fix it ?

      after starting postconf I get the error

      =====================================
      parameter setgid_group: unknown group name: postdrop
      =========================================

      here is " postconf -n "

      broken_sasl_auth_clients = yes
      command_directory = /usr/sbin
      config_directory = /etc/postfix
      daemon_directory = /usr/lib/postfix
      delay_warning_time = 4h
      local_recipient_maps = $alias_maps unix:passwd.byname
      mail_owner = postfix
      mailq_path = /usr/bin/mailq
      manpage_directory = /usr/share/man
      mydestination = localhost
      mydomain = opendingo.com
      myhostname = lvps87-230-8-228.opendingo.com
      mynetworks_style = host
      newaliases_path = /usr/bin/newaliases
      queue_directory = /var/spool/postfix
      readme_directory = /usr/share/doc/packages/postfix/README_FILES
      sendmail_path = /usr/sbin/sendmail
      setgid_group = postdrop
      smtpd_banner = $myhostname ESMTP $mail_name ($mail_version) (SuSe Linux)
      smtpd_recipient_restrictions = permit_mynetworks,
      permit_sasl_authenticated, reject_unauth_destination
      smtpd_sasl_auth_enable = yes
      smtpd_sasl_local_domain = $myhostname
      smtpd_sasl_security_options = noanonymous
      unknown_local_recipient_reject_code = 450
      virtual_gid_maps = static:800
      virtual_mailbox_base = /home/vmail/domains
      virtual_mailbox_domains = ldap:domain
      virtual_mailbox_maps = ldap:accounts
      virtual_transport = lmtp:unix:/var/lib/imap/socket/lmtp
      virtual_uid_maps = static:800
    • Benjamin Donnachie
      ... Create the group postdrop? Ben
      Message 2 of 5 , Jun 1, 2007
      • 0 Attachment
        JOYDEEP wrote:
        > could any one kindly help me to fix it ?
        > parameter setgid_group: unknown group name: postdrop

        Create the group postdrop?

        Ben
      • JOYDEEP
        ... Thanks for your response. but what will be the permission of the group postdrop ? thanks in advanced.
        Message 3 of 5 , Jun 3, 2007
        • 0 Attachment
          Benjamin Donnachie wrote:
          > JOYDEEP wrote:
          >
          >> could any one kindly help me to fix it ?
          >> parameter setgid_group: unknown group name: postdrop
          >>
          >
          > Create the group postdrop?
          >
          > Ben
          >
          >
          >
          Thanks for your response. but what will be the permission of the group
          postdrop ?
          thanks in advanced.
        • Victor Duchovni
          ... None when you create the group. After you do so, and run as root : postfix set-permissions your mail system will begin to work correctly, because
          Message 4 of 5 , Jun 3, 2007
          • 0 Attachment
            On Mon, Jun 04, 2007 at 10:56:12AM +0530, JOYDEEP wrote:

            > Benjamin Donnachie wrote:
            > > JOYDEEP wrote:
            > >
            > >> could any one kindly help me to fix it ?
            > >> parameter setgid_group: unknown group name: postdrop
            > >>
            > >
            > > Create the group postdrop?
            > >
            > > Ben
            > >
            > >
            > >
            > Thanks for your response. but what will be the permission of the group
            > postdrop ?

            None when you create the group. After you do so, and run as "root":

            postfix set-permissions

            your mail system will begin to work correctly, because "postdrop" and
            "postqueue" will be able to access restricted sub-directories in the
            Postfix queue.

            --
            Viktor.

            Disclaimer: off-list followups get on-list replies or get ignored.
            Please do not ignore the "Reply-To" header.

            To unsubscribe from the postfix-users list, visit
            http://www.postfix.org/lists.html or click the link below:
            <mailto:majordomo@...?body=unsubscribe%20postfix-users>

            If my response solves your problem, the best way to thank me is to not
            send an "it worked, thanks" follow-up. If you must respond, please put
            "It worked, thanks" in the "Subject" so I can delete these quickly.
          • JOYDEEP
            ... Thanks a lot Victor. Now it is working with out the error :-) have a nice day.
            Message 5 of 5 , Jun 3, 2007
            • 0 Attachment
              Victor Duchovni wrote:
              > On Mon, Jun 04, 2007 at 10:56:12AM +0530, JOYDEEP wrote:
              >
              >
              >> Benjamin Donnachie wrote:
              >>
              >>> JOYDEEP wrote:
              >>>
              >>>
              >>>> could any one kindly help me to fix it ?
              >>>> parameter setgid_group: unknown group name: postdrop
              >>>>
              >>>>
              >>> Create the group postdrop?
              >>>
              >>> Ben
              >>>
              >>>
              >>>
              >>>
              >> Thanks for your response. but what will be the permission of the group
              >> postdrop ?
              >>
              >
              > None when you create the group. After you do so, and run as "root":
              >
              > postfix set-permissions
              >
              > your mail system will begin to work correctly, because "postdrop" and
              > "postqueue" will be able to access restricted sub-directories in the
              > Postfix queue.
              >
              >

              Thanks a lot Victor. Now it is working with out the error :-)
              have a nice day.
            Your message has been successfully submitted and would be delivered to recipients shortly.